+ Responder ao Tópico



  1. Caro amigo freitascs, tentei aki mas não funcionou não.. na verdade nem rodar no terminal roda, tive q fazer na mão mesmo mas não funcionou...

    deve esta dando alguma incompatibilidade com a regra criada no pcc 1.3.

    Caro amigo scan, será q não é possivel colocar essa regra pra pingar pra fora no programa ?
    iria ajudar muita gente q eu acho q deve estar com o mesmo problema q eu estou.

  2. Que pena que não funcionou, mais é assim mesmo Loadbalance é muito relativo tem alguns script que funcionam em certas versão do Mikrotik e em outras nem funciona.

    mais vamos continuar tentando por que eu passei muito tempo tentando fazer loadbalance e nunca dava certo usava script de pessoas que estavam funcionando mais na minha RB nem rolava ai até que conseguir com o programa PCC1.3 do amigo Scan.



  3. Aki o load esta funcionando perfeitamente, graças ao nosso amigo scan.. agora só to mesmo querendo resolver esse problema de mudança do link, sei q realmente é só a parte do ping, teria q ser pra fora e não pro gatewey, mas ta mesmo dificil de achar alguma coisa q funcione junto com o pcc ...


    Freitascs, eu vi q teve algumas pessoas q usou both-addresses-and-ports no lugar de both-addresses , pra poer juntar os links, vc sabe se funciona legal, será q tem algum problema com os sites https e com o msn, sebe me dizer isso ?
    Última edição por NTurbo; 03-05-2011 às 23:39.

  4. Citação Postado originalmente por wala Ver Post
    tem que fazer um check gateway que funcione pois o gerado pelo o programa não esta funcionando automatico se vc for na opção system e script vc vera que a regra foi criada mais não funciona se vc testar manulamente o script na opçao rum script vc ve que ele funciona
    se for a regra criada automatica do programa aki no meu funcionou perfeito, se eu tirar o cabo do link do modem ele ativa o outro para assumir todo o trafego, só não ficou perfeito q pra mim, não adianta dessa forma pq meu modem e roteado e responde ao ping mesmo com a net desconectada, mas se vc fizer ele em um modem bridge ele funciona perfeitamente..

    Como vc testou ?



  5. interessante tem uma regrinha pra colocar no load para pode acessalo o servidor por traz do mesmo!!

  6. esse aqui tem tudo haver com o que você precisa.

    https://under-linux.org/wiki/index.ph...Link_de_Sombra



  7. Eu acabei por deixar o meu modem em bridge mesmo.. até achar uma solução..

    Shalom.


    Citação Postado originalmente por teletanbs Ver Post
    interessante tem uma regrinha pra colocar no load para pode acessalo o servidor por traz do mesmo!!
    aki eu tenho acesso a ele por traz, tenho uma 750 fazendo o load e uma 450G fazendo meu servidor hotspot, eu tenho acesso ao load pela minha maquina q esta saindo pelo hotspot, e tenho acesso por ddns pela internet...

    Para ter acesso interno basta vc colocar uma config de ip diferente eu por exemplo coloquei aki uma config de faixa 10.0.0.1/29 no LB e uma faixa 192.168.0.1/24 para o hotspot e tenho acesso as duas rbs sem problema nenhum...

    explique melhor a sua duvida..
    Última edição por NTurbo; 09-05-2011 às 10:31.

  8. Pessoalllllllllll estou com tremenda dificuldade em usar o PCC, sou meio novo ainda em mk, mais ja trabalho com hotspot e PPPOE server. estou com um PCMK com 3 placas de rede, ether 3Con (Clientes), ether on-board (internet1), ether realtek(internet2), tenho dois links velox, e ambos os modens estão roteados, e ambos com link de 4512Down 512Up (não estou tendo problemas com os modens roteados). O meu único problema e o manuseio do PCC, pois quero juntar os links no mk..

    segue minha rede:
    192.168.251.0/24 Clientes
    20.20.20.1 gatway modem 1
    10.2.2.1 gatway modem 2

    gostaria muito de fazer o balanceamento dos links, só não estou conseguindo mecher no programa..
    se pocivel alguém me ajudar, des de já agradeço.. obrigado a todos..

    qualquer coisa me add no msn quem quer me ajudar(ricardo.palma.lima@hotmail.com). trabalho com redes, hardware e webdesigner, caso tbm posso ajudar em algo.. grato!



  9. Bom se você quiser tenho um script pronto 100% funcionando do meu loadbalance de 2 link ADSL da velox, mais os seus modens terão que ficar em Bridge para funcionar, e o loadbalance não junta os links e sim balanceia a carga dividindo os clientes em cada link e também quando um link cair o outro assume todos os clientes que estavam no outro link aqui o meu esta desta forma nunca deu problema.

    Link para download do meu loadbalance
    LoadBalance 2ADSL Bridge 100%.txt - 4shared.com - document sharing - download

  10. Citação Postado originalmente por freitascs Ver Post
    Bom se você quiser tenho um script pronto 100% funcionando do meu loadbalance de 2 link ADSL da velox, mais os seus modens terão que ficar em Bridge para funcionar, e o loadbalance não junta os links e sim balanceia a carga dividindo os clientes em cada link e também quando um link cair o outro assume todos os clientes que estavam no outro link aqui o meu esta desta forma nunca deu problema.

    Link para download do meu loadbalance
    LoadBalance 2ADSL Bridge 100%.txt - 4shared.com - document sharing - download
    cara, só tem 1 problema, eu trabalho com hotspot e pppoe server no mesmo mk, vai ter algum problema, me add no msn pra conversarmos.. ricardo.palma.lima@hotmail.com



  11. Citação Postado originalmente por ShiFT Ver Post
    cara, só tem 1 problema, eu trabalho com hotspot e pppoe server no mesmo mk, vai ter algum problema, me add no msn pra conversarmos.. ricardo.palma.lima@hotmail.com


    Para oque vc quer fazer é simples cara


    Código :
    /ip firewall mangle
     
    add action=mark-routing chain=prerouting comment="FAIXA - PPPOE" disabled=yes new-routing-mark=CLIENTES-PPPOE passthrough=no src-address=10.1.10.0/24 (FAIXA CLIENTE PPPOE)
    add action=mark-routing chain=prerouting comment="FAIXA - HOTSPOT" disabled=yes new-routing-mark=CLIENTES-HOTSPOT passthrough=no src-address=20.2.20.0/24  (FAIXA CLIENTE HOTSPOT)
     
     
    /ip route
     
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=200.200.200.254 ( IP OU MODEM DO LINK ) routing-mark=CLIENTES-PPPOE scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=254.254.254.254 ( IP OU MODEM DO LINK ) routing-mark=CLIENTES-HOTSPOT scope=30 target-scope=10

  12. Citação Postado originalmente por p4ulo182 Ver Post
    Para oque vc quer fazer é simples cara


    Código :
    /ip firewall mangle
     
    add action=mark-routing chain=prerouting comment="FAIXA - PPPOE" disabled=yes new-routing-mark=CLIENTES-PPPOE passthrough=no src-address=10.1.10.0/24 (FAIXA CLIENTE PPPOE)
    add action=mark-routing chain=prerouting comment="FAIXA - HOTSPOT" disabled=yes new-routing-mark=CLIENTES-HOTSPOT passthrough=no src-address=20.2.20.0/24  (FAIXA CLIENTE HOTSPOT)
     
     
    /ip route
     
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=200.200.200.254 ( IP OU MODEM DO LINK ) routing-mark=CLIENTES-PPPOE scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=254.254.254.254 ( IP OU MODEM DO LINK ) routing-mark=CLIENTES-HOTSPOT scope=30 target-scope=10
    nesse caso eu uso o as regras do amigo assima, e adiciono mais a sua. sendo que meu pppoe server em nat eu trabalho com /24 e quando add os clientes, eu coloco os ip sucessivamente ex:

    200.200.200.10 é o gatway e 200.200.200.11 é o que vai atribuir pro cliente. eu sempre deixo um espaço de 8 ip pra proxima rede, no caso o segundo cliente ia atribuir o seguinte
    200.200.200.20 gateway e 200.200.200.21 ip.

    trabalhando dessa forma, eu não vou ter problemas?

    obrigado pela atenção..



  13. Bom ShiFT o certo mesmo é você usar uma RB só pra loadbalance e o PC Servidor MK só pra gerenciar os seus clientes.

    tipo no meu provedor tenho RB450 pra loadbalance e um PC Servidor MK 3.30 com Hotspot e cara não tenho dor de cabeça nenhuma na boa sistema 100% estável, por que já ouvir falar que loadbalance junto com hotspot e pppoe dizem que não fica muito bom não, mais ai se você quiser fazer um teste com a configuração extra que o amigo ai te passou se não ficar 100% dai você colocar uma RB só pro loadbalance e você vai ficar super satisfeito com o rendimento.
    Última edição por freitascs; 10-05-2011 às 16:44.

  14. Citação Postado originalmente por freitascs Ver Post
    Bom ShiFT o certo mesmo é você usar uma RB só pra loadbalance e o PC Servidor MK só pra gerenciar os seus clientes.

    tipo no meu provedor tenho RB450 pra loadbalance e um PC Servidor MK 3.30 com Hotspot e cara não tenho dor de cabeça nenhuma na boa sistema 100% estável, por que já ouvir falar que loadbalance junto com hotspot e pppoe dizem que não fica muito bom não, mais ai se você quiser fazer um teste com a configuração extra que o amigo ai te passou se não ficar 100% dai você colocar uma RB só pro loadbalance e você vai ficar super satisfeito com o rendimento.
    Agora eu não entendi mais nada freitas.. veja bem, vc me disse o seguinte:

    Bom se você quiser tenho um script pronto 100% funcionando do meu loadbalance de 2 link ADSL da velox, mais os seus modens terão que ficar em Bridge para funcionar, e o loadbalance não junta os links e sim balanceia a carga dividindo os clientes em cada link e também quando um link cair o outro assume todos os clientes que estavam no outro link aqui o meu esta desta forma nunca deu problema.

    se vc tem uma rb pra fazer o loadbalance, então como que os clientes vão pegar o link separado? afinal na tua rb a ether cliente vai para o servidor mk e no servidor a ether clientes vai para clientes, vc então tem uma unica ether recebendo no servidor, como os clientes vão dividir o link?
    Pow cara, me desulpe, to meio perdido ainda, espero que tenha intendido o que eu quis dizer, estou tentando pegar a logica do negocio ainda..

  15. Citação Postado originalmente por ShiFT Ver Post
    Agora eu não entendi mais nada freitas.. veja bem, vc me disse o seguinte:

    Bom se você quiser tenho um script pronto 100% funcionando do meu loadbalance de 2 link ADSL da velox, mais os seus modens terão que ficar em Bridge para funcionar, e o loadbalance não junta os links e sim balanceia a carga dividindo os clientes em cada link e também quando um link cair o outro assume todos os clientes que estavam no outro link aqui o meu esta desta forma nunca deu problema.

    se vc tem uma rb pra fazer o loadbalance, então como que os clientes vão pegar o link separado? afinal na tua rb a ether cliente vai para o servidor mk e no servidor a ether clientes vai para clientes, vc então tem uma unica ether recebendo no servidor, como os clientes vão dividir o link?
    Pow cara, me desulpe, to meio perdido ainda, espero que tenha intendido o que eu quis dizer, estou tentando pegar a logica do negocio ainda..
    É Simples amigo.
    Ele tem um servidor hotspot esse somente controla os clientes, o servidor LoadBalance que faz a distribuição dos clientes nos links, isso é automático nem precisa se preocupar é tudo automático, com um servidor hotspot separado só pra controlar os clientes, ja a distribuição do link é feira pela LB, todo o trabalho vai ser feito por ela, e tudo automático.

    Assim mais ou menos;

    Link 1
    --------------> Servidor LB --> Servidor HotSpot --> Clientes
    Link 2

    Como mostrado o hotspot só vai controlar os clientes, a distribuição do link vai ficar por conta da LB..

    Deu pra clarear + ou - ?

  16. bom acho que muita gente não dá certo pois vocês querem uma maquina só pra fazer tudo faça o load em uma maquina separada ou de preferencia RB

  17. amigos minha rb450g se ligar ela direto no pc e colocar ip ...

    ela navega normalmente ...

    ai quando conecto ela na minha rb433ah não navega ...

    jah tentei deixar dhcp client (automatico) e fica so procurandoo ...

    aii tenteni setar o ip no IP>> address ..e setar uma rota e tbm não funcionou....

    o que será q pod estar acontecendoo ??

  18. Citação Postado originalmente por NTurbo Ver Post
    É Simples amigo.
    Ele tem um servidor hotspot esse somente controla os clientes, o servidor LoadBalance que faz a distribuição dos clientes nos links, isso é automático nem precisa se preocupar é tudo automático, com um servidor hotspot separado só pra controlar os clientes, ja a distribuição do link é feira pela LB, todo o trabalho vai ser feito por ela, e tudo automático.

    Assim mais ou menos;

    Link 1
    --------------> Servidor LB --> Servidor HotSpot --> Clientes
    Link 2

    Como mostrado o hotspot só vai controlar os clientes, a distribuição do link vai ficar por conta da LB..

    Deu pra clarear + ou - ?
    no causo a etcher cliente do servidor LB fica em bridge? e a ether internet no servidor hotspot fica em bridge tbm? ta bem dificil eu entender, pois ele falou que cada cliente que entra, faz um balanço, 1 pra cada link..

    pow, não da pra fazer tudo num servidor (PC MK)?

  19. Citação Postado originalmente por ShiFT Ver Post
    no causo a etcher cliente do servidor LB fica em bridge? e a ether internet no servidor hotspot fica em bridge tbm? ta bem dificil eu entender, pois ele falou que cada cliente que entra, faz um balanço, 1 pra cada link..

    pow, não da pra fazer tudo num servidor (PC MK)?
    Vc pode até tentar.. mais o ideal é fazer o LB em uma RB separada... sobre as ether q vc perguntou basta vc configurar da forma q foi explicado q vai funcionar...

    é simples... siga a explicação q vai funcionar...

  20. o povo tambem quer um aparelho que faça tudo!!






Tópicos Similares

  1. Respostas: 24
    Último Post: 25-03-2014, 06:52
  2. script para gerar tabelas dos logs???
    Por tomelin no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 26-06-2006, 08:25
  3. programa para testar segurança do firewall
    Por johnny no fórum Servidores de Rede
    Respostas: 9
    Último Post: 01-11-2005, 12:48
  4. problemas para gerar modulo do tomcat
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-09-2004, 09:07
  5. Programa para gerenciar configuração!!!
    Por Algoritmo_PB no fórum Servidores de Rede
    Respostas: 2
    Último Post: 24-07-2004, 14:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L