+ Responder ao Tópico



  1. Olá Scan ou demais do forum! Como poderia fazer no pcc uma forma de que um determinado ip (8.8.8.8) ao pingar o mesmo só saia por uma rota(LINK0) por exemplo, caso alguém tenha alguma regra em mãos agradeço. Preciso fazer uma jogada de que o Netwach ao pingar para esse cara entenda que sempre será a saída pelo LINK0 e não fique aleatoriamente pingando, uma vez pelo LINK0 e outra pelo LINK1. Agradeço a ajuda quem poder.

  2. Boa tarde!

    darioeluan, ao meu entender, basta selecionar o link desejado, clicar em loopback por link e acrescentar o ip do google lá...

    OBS: posso estar errado.

    Att.: Scan



  3. ele quer um failover!!

  4. bom dia!
    estive a olhar o wiki do celiorio2, no qual demonstra como fazer um Failover muito bom por sinal, mas que não resolve como um todo o PCC, pois, o script funciona somente com links rotiados, e o teste é feito em cima do ip-link "depois do rotiado", neste caso, o link ADSL ficaria inviavel esta regra, pelo fato de mudar o ip e consequentemente o ip gatway, mas digamos que mesmo que o ip mude, mas o gatway é o mesmo no adsl, dai surge outro problema, como realizar o deste de forma individual "ou seja, de forma que o teste passe somente pelo canal especifico, ou seja, vc tem 3 links adsl da mesma operadora, e por mais que um link perca o sinal, o teste vai dar ok, que o link esta ok, mas na realidade o teste deu ok por outro canal."
    Por este e outros motivos, venho por meio desta pedir um script funcional que resolva o problema levantado acima, para que eu possa colocar no PCC, e o mesmo gerar de forma nativa.
    Att.: Scan



  5. Scan, meu cenário é o seguinte, usei seu programa para configurar 2 links, um dedicado da Embratel e outro
    vem compartilhado de um micro com windows xp que tem uma internet da opensky, a escolha no programa foi como LInks dedicados, não podia ser ADLS pq não é ip
    dinâmico e nem tem senha, o problema que não tem ip do roteador da ponta igual ao primeiro Link que sei qual o ip para que faça testes de ping e assim
    saiba se responde ou não para que seja executado o UP e DOWN conforme regra abaixo. A única maneira que não tenho 100% de certeza mais que está funcionando até o
    momento foi colocar uma regra no IP Route que o ip 8.8.8.8 ping saia apenas pelo gateway da internet que vem do Windows xp, esta regra só não funcionou no
    primeiro dia mais no dia seguinte funcionou normal até o momento e olha que já rebootei a RB várias vezes( 3 meses em funcionamento). Agora tenho dúvidas também
    quando fala que tem ser roteado como assim, de exemplo? A minha internet chega em um roteador da Embratel e dela vai para a RB, só que o gateway é o mesmo
    do roteador, ou seja, na hora que for fazer chacagem de ping ele vai responder pq está do lado mais pode ser que para fora não tenha internet, sendo assim ao executar
    o UP E DOWN automaticamente sempre terá resposta de UP pq o ip este respondendo. Diferente do outro link que testei que também é dedicado, porém o ip do gateway
    não fica no roteador(Conforme scripts 2) e sim em outro local, dessa forma ao colocar a regra no NEWATACH ele vai pingar para o ip e não obterá resposta executando assim o scripts
    como DOWN correto? Tenho estas dúvidas quanto a isso, só lembrando que este SCRIPTS 2 ele funcionou 100% o link1 ao cair automaticamente ele deu um DOWN. Tenho estas
    dúvidas?





    /ip route (Scripts 1)
    add check-gateway=ping comment=Link0 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=200.228.93.1 routing-mark=\
    to_EMBRATEL scope=30 target-scope=10
    add check-gateway=ping comment=Link1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=\
    to_SAT1 scope=30 target-scope=10
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=200.228.93.1 routing-mark=Rota0 scope=30 \
    target-scope=10
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=Rota1 scope=30 \
    target-scope=10
    add check-gateway=ping comment=Link0 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=200.228.93.1 scope=30 \
    target-scope=10
    add check-gateway=ping comment=Link1 disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=30 \
    target-scope=10
    add check-gateway=ping comment="Serve para que o ip do dns do google saia apenas pelo Gateway abaixo, e assim possa coloc\
    ar a regra no netwach para dar UP e DOWN automaticamente." disabled=no distance=2 dst-address=8.8.8.8/32 gateway=\
    192.168.2.1 scope=30 target-scope=10




    /tool netwatch (Scripts 1)
    add comment="" disabled=no down-script="/ip firewall filter set [find comment=\"Link1\"] disabled=yes;\r\
    \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\
    \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\
    \n/ip route set [find comment=\"Link1\"] disabled=yes;" host=8.8.8.8 interval=5s timeout=2s500ms up-script="/ip firew\
    all filter set [find comment=\"Link1\"] disabled=no;\r\
    \n/ip firewall nat set [find comment=\"Link1\"] disabled=no;\r\
    \n/ip firewall mangle set [find comment=\"Link1\"] disabled=no;\r\
    \n/ip route set [find comment=\"Link1\"] disabled=no;"




    /ip route (Scripts 2)
    add check-gateway=ping comment=Link0 disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=200.228.93.1 routing-mark=to_EMBRATEL scope=30 \
    target-scope=10
    add check-gateway=ping comment=Link1 disabled=yes distance=1 dst-address=\
    0.0.0.0/0 gateway=177.8.17.9 routing-mark=to_WKVE scope=30 target-scope=\
    10
    add check-gateway=ping comment=Link0 disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=200.228.93.1 scope=30 target-scope=10
    add check-gateway=ping comment=Link1 disabled=yes distance=2 dst-address=\
    0.0.0.0/0 gateway=177.8.17.9 scope=30 target-scope=10




    /tool netwatch (Scripts 2)
    add comment="" disabled=no down-script="/ip firewall filter set [find comment=\
    \"Link1\"] disabled=yes;\r\
    \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\
    \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\
    \n/ip route set [find comment=\"Link1\"] disabled=yes;" host=177.8.17.9 \
    interval=5s timeout=2s up-script="/ip firewall filter set [find comment=\"\
    Link1\"] disabled=no;\r\
    \n/ip firewall nat set [find comment=\"Link1\"] disabled=no;\r\
    \n/ip firewall mangle set [find comment=\"Link1\"] disabled=no;\r\
    \n/ip route set [find comment=\"Link1\"] disabled=no;

  6. Boa tarde!

    DarioEluan, aqui eu uso da seguinte forma :
    Embratel : IP do Cliente 200.200.200.2/30 -> bloco liberado para o cliente 201.200.200.2/25

    ou seja, no ip do cliente embratel eu tenho o gatway 200.200.200.1 na borda da embratel .
    e no bloco eu tenho 201.200.200.1 como gatway ...

    neste caso eu uso em no mikrotik os dois, qual a logica ...

    se o ping falhar para o 200.200.200.1 siguinifica que a borda embratel esta com algum problema, e neste caso o link e desativado, o ponto positivo deste teste e que n importa por qual canal de link esta saindo o teste.

    se o ping falhar para 201.200.200.1 siguinifica que dentro da empresa houve algum problem, ou seja, por mais que o borda da embratel diga que esta ok, o link e desativado....

    dai o porque disse que deve ser rotiado, pois no link rotiado temos o ip da operadora, e o bloco de rede interno .....
    coisa que no adsl e possivel mas, nao com tanta facilidade assim.

    espero ter ajudado.

    att.: Scan



  7. ficou um tiquinho complicado!!

  8. Bom dia!

    Deixa eu tentar simplificar...

    Circuito Embratel: ao adiquirir um circuito Embratel, eles lhe dão a OTS,no qual dispões informação como:
    Cliente : 200.200.200.2/30
    Embratel:200.200.200.1
    Bloco: 192.168.0.1/24.

    Neste momento temos as informações necessárias para o teste...

    O teste pode ser feito de duas formas:
    1: O ip Embratel disponibilizado para voce, é unico e exclusivo, ou seja, seu ip cliente com mascara /30 ... implica que só é disponivel um ip para esta rede...
    diantes desta informação, basta fazer o seguinte código:
    /tool netwatch
    add down-script="script Dow link"; host=200.200.200.1 interval=3s timeout=2s up-script="script Up link"

    OBS: como o ip embratel é unico para o cliente, não importa por qual via "saida de link esta partindo o teste", pois se por algum motivo este ip estiver off, a função acima desativa o mesmo.

    2: neste segundo caso, o teste vai ser utilizado em cima do bloco de ip liberado, no qual vc vai usar para seus servidores internos, e ou clientes, para tanto, pode ocorrer de o programa dizer que esta ok para o teste acima "teste realizado no ip da embratel" e sua rede esta com o rotiador queimado, ou seja, vc na realidade n esta usando tal link, para tanto, basta fazer um código de verificação para o bloco de ips internos, exemplo:
    /tool netwatch
    add down-script="script Dow link"; host=192.168.0.1 interval=3s timeout=2s up-script="script Up link"


    Espero ter ajudado.

    Att.: Scan



  9. legal!!

  10. /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=WAN_COPEL_conn passthrough=yes per-connection-classifier=:3/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=WAN_COPEL_conn passthrough=yes per-connection-classifier=:3/1
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=adsl_WAN_ADSL_conn passthrough=yes per-connection-classifier=:3/2


    Alguem tem ideia de o pq essas linhas dao erro aqui? Comeca em per-connection e =:3/0 tbm


    To com firmware 5.5 mas testei com o 4.17 e deu o mesmo erro..



  11. Boa tarde!

    Zepinguim, qual seria o erro que dá ao colocar este código...

    OBS:
    a meu ver, deveria ser:

    /ip firewall mangle add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=LAN new-connection-mark=\
    WAN_COPEL_conn passthrough=yes per-connection-classifier=both-addresses:3/0
    /ip firewall mangle add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=LAN new-connection-mark=\
    WAN_COPEL_conn passthrough=yes per-connection-classifier=both-addresses:3/1
    /ip firewall mangle add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=LAN new-connection-mark=\
    adsl_WAN_ADSL_conn assthrough=yes per-connection-classifier=both-addresses:3/2

    OU seja, o per-connection-classifier está faltando parametros.

    Att.: Scan

  12. Hum, blz vou fazer uns testes depois e posto aqui... tem ideia de porque ta sendo gerado o código errado? Dava o msm erro na versao 1.3 e agora na 1.5 mesma coisa... que buxa hehe.... por eqto to deixando essas linhas de fora, funciona igual...



  13. Scan, primeiramente parabéns pelo excelente trabalho!

    Muito bom esse programa, antes eu usava o BFW para balancear, mas agora ficou perfeito, só estou tendo um pequeno problema com um redirecionamento que usava junto ao BFW, não tenho muita experiência com o Mikrotik, queria saber se vc podia me ajudar ou alguem aqui forum a fazer, antes estava assim:

    1° No Brazilfw (balanceador):

    Eu colocava essa regra para redirecionar uma camera pra um link

    #ipupdate 2.0 by Washington Rodrigues 2009
    internet1 no-ip dominio: xxxxx.zapto.org meu e-mail: xxxxx@hotmail.com senha: xxxxx

    e ainda redirecionava 5000 a 9000 para o IP 192.168.0.58


    2. No Mikrotik (servidor)

    add action=dst-nat chain=dstnat comment=\
    "Fazenda_Ordenha - Redirecionamento Cameras CEDE" disabled=no \
    dst-address=10.100.0.250 dst-port=5000 protocol=udp to-addresses=172.18.0.5 \
    to-ports=5000
    add action=dst-nat chain=dstnat comment=\
    "Fazenda_Ordenha - Redirecionamento Cameras CEDE" disabled=no \
    dst-address=10.100.0.250 dst-port=5000 protocol=tcp to-addresses=172.18.0.5 \
    to-ports=5000
    add action=dst-nat chain=dstnat comment=\
    "Fazenda_Ordenha - Redirecionamento Cameras ORDENHA" disabled=no \
    dst-address=10.100.0.250 dst-port=9000 protocol=udp to-addresses=172.18.0.3 \
    to-ports=9000
    add action=dst-nat chain=dstnat comment=\
    "Fazenda_Ordenha - Redirecionamento Cameras ORDENHA" disabled=no \
    dst-address=10.100.0.250 dst-port=9000 protocol=tcp to-addresses=172.18.0.3 \
    to-ports=9000

  14. Buxa aqui n tem jeito, sempre gera errado "per-connection-classifier=:2/1" ao inves de per-connection-classifier=both-addresses:2/1

  15. To deixando essas linhas fora mas funciona que eh uma beleza igual, pelo menos o failover hehe.. belo trabalho scan, parabens

  16. Bom dia!

    zepinguin, verifiquei aqui o código gerado da versão 1.5 e está ok, veja qual versão vc esta usando ai e atualize se for o caso.

    Att.:Scan

  17. Bom dia!

    gilmuor, o programa PCC tem com direcionar certas faixas de ips para links especificos, ou seja, independentemente da porta, o pcc ao identificar que trata-se de um dst-address=xxx, vai envialo para o link especifico, mas para isso vai precisar de um ip para destino...

    OBs: eu até o momento não passei por esta situação, mas creio que o pessoal que acompanha este post deve sanar suas dúvidas com uma solução.

    Att.: Scan

  18. /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=adsl_adsl_conn passthrough=yes per-connection-classifier=:3/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=adsl_adsl_conn passthrough=yes per-connection-classifier=:3/1
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=adsl_adsl2_conn passthrough=yes per-connection-classifier=:3/2


    nao tem jeito, que foda... exclui tudo, baixei o pcc de novo, gerei o codigo e ainda falta coisa ali... sei láaa

    gilmour quando eu quero fazer algo sair por um link especifico, crio uma rota em ip->routes dstadrees coloco o ip quer quero q sempre sai por um link e no gateway boto o gw da interface que quero que saia.. funciona blz

  19. Entendo, as regras do meu servidor continuam, a bronca é transferir as que eram do BFW, para o balanceador, no que se refere a:

    1° Direcionar as portas 5000 e 9000 para o IP 192.168.0.58

    2° Autenticar o dominio no-ip para que o cliente acesse a camera,

    link onde está saindo o domino para o cliente: internet1 no-ip dominio: xxxxx.zapto.org

    meu e-mail: xxxxx@hotmail.com

    senha: xxxxx

    Estou precisando muito colocar novamente pra funcionar, o problema é que não sei por onde começar, se tiver alguem disposto a ajudar um amigo, ficarei muito grato!

  20. Para direcionar as portas bastaria fazer uma nat.
    O programa que o cliente utiliza deveria autenticar sozinho.
    Qual o modelo de camera e o programa que ele utiliza.
    Tenho cameras por ip e também um dvr e não dá problema algum.






Tópicos Similares

  1. Respostas: 24
    Último Post: 25-03-2014, 06:52
  2. script para gerar tabelas dos logs???
    Por tomelin no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 26-06-2006, 08:25
  3. programa para testar segurança do firewall
    Por johnny no fórum Servidores de Rede
    Respostas: 9
    Último Post: 01-11-2005, 12:48
  4. problemas para gerar modulo do tomcat
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-09-2004, 09:07
  5. Programa para gerenciar configuração!!!
    Por Algoritmo_PB no fórum Servidores de Rede
    Respostas: 2
    Último Post: 24-07-2004, 14:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L