Página 4 de 50 PrimeiroPrimeiro 123456789 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Pliniosartori!

    Cara, ta ai uma coisa que não pude solucionar, tive este mesmo problema mas na época não podia perder tempo para solucionar, tive que comprar uma RB com 5 portas para solucionar meu problema, mas em pesquisa aqui no forum, vi um poste de um colega que disse que é possivel fazer isso usando vlan, no MK ficaria uma ether para casa vlan "deste geito daria para fazer a regra pcc direcionando a rota para cada ether normalmente."

    OBS: não cheguei a estudar esta sulução, mas pesquise aqui no forum sobre vlan que pode dar certo .

  2. Olá Scan!
    Acho que você não intendeu direito o que eu postei antes.
    Eu falei sobre o problema que dava, porem eu veirifiquei e descobri o problema, o problema era que o programa tinha criado só as rotas d 2 dos meus 3 links, tipow assim, ele fez tudo para os 3 links, todas as regras no firewall, tudo tudo, ele só não fez as regras de route de UM dos meus links, os outros 2 estavam funcionando blz, então o que eu fiz? Fui lá e criei as regras em route, fiz uma regra com o gateway normal, 201.xxx.xxx.xxx. e criei mais uma regra em routes, com o mesmo gateway, só que com marcação de conexão (ex. conn_link). Aí resolveu o meu problema, agora está tudo ok, as luzinhas das minhas 3 redes estão bem lokas piscando hehe. Postei isso, para caso alguem tenha o mesmo problema que eu, conseguir resolver, quem sabe scan, o seu problema não era o msm??

    Um abraço!!



  3. blz, não tive problemas aqui, e obrigado pela observação.

    t++

  4. Não sei se intendi direito a questão do pliniosartori, mas pelo que intendi, ele tem um hub, com 3 adsl, dela sai UM cabo para o servidor, isto?
    Não tem como você colocar os 3 ips dos modens numa interface sóó?? Tipow assim, pega no programa, e coloca os ips dos 3, e em nome de interface, coloca o mesmo nome para as 3, será que não resolve o teu problema??? eu nunca testei, por que aqui eu tenho um computador separado sóó para fazer os balanceamentos e daí o sinal ja entra no meu servidor (RB) dividido e pronto, fiz isso, por que as regras de balanceamento estavam acho que entrando em conflito com as do hotspot, mas tenta fazer isso que eu flei, coloca todos os ips e tudu mais e coloca todos eles com o mesmo nome de interface, quem sabe dê certo!!
    Se der certo me avisa!!
    Abraço!!
    Scan! Esse teu prog é mtooo massa!! Ajudo muitaa gentee!!



  5. Segue nova versão do sistema para gerar código para balanceamento PCC.

    Ver. 0.6
    http://www.saocarlosnet.com.br/PCC_0.6.zip
    http://www.saocarlosnet.com.br/log.txt

    OBS: não tive tempo de verificar o código gerado, mas na outra semana irei fazer os testes.

    At.: Scan

  6. Ta com um bug na parte do pcc que deveria aparecer a interface dos clientes fica aparecendo os pppoe, mais tirando isso ta otimo...

    Citação Postado originalmente por scan Ver Post
    Segue nova versão do sistema para gerar código para balanceamento PCC.

    Ver. 0.6
    http://www.saocarlosnet.com.br/PCC_0.6.zip
    http://www.saocarlosnet.com.br/log.txt

    OBS: não tive tempo de verificar o código gerado, mas na outra semana irei fazer os testes.

    At.: Scan



  7. Boa tarde RogerioDj!

    Estive a olhar o código gerado e verifiquei que o mesmo só gera uma interface pppoe se vc configurar para adsl - bridge, onde neste caso vc indica a interface que esta conectado o modem adsl, como não é preciso configurar ip para o mesmo, é criado uma conexão pppoe onde a mesma é que vai ser utilizada para conexão adsl e nat, a interface onde esta o adsl só serve como meio para a autenticaçào.

    Agora, se o seu adsl estiver rotiado, ou seja, vc fez a autenticação no próprio modem, neste caso vc deve usar a primeira opção do programa que é Dedicado / adsl - rotiado.

    Obrigado por testar o programa e se tiver mais uma observação é só falar.

  8. Acho que não expliquei o erro, vou tentar novamente,olhe o script gerado e as interfaces destacadas, pois deveriam constar a interface que vai para os clientes e não as adsls...

    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=out
    /ip firewall mangle add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" disabled=no new-ttl=set:30 protocol=icmp
    /ip firewall mangle add action=mark-connection chain=input comment="" disabled=no in-interface=link-1adsl new-connection-mark=link-1adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-connection chain=input comment="" disabled=no in-interface=link-2adsl new-connection-mark=link-2adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-connection chain=input comment="" disabled=no in-interface=link-3adsl new-connection-mark=link-3adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output comment="" connection-mark=link-1adsl_conn disabled=no new-routing-mark=to_link-1adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output comment="" connection-mark=link-2adsl_conn disabled=no new-routing-mark=to_link-2adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output comment="" connection-mark=link-3adsl_conn disabled=no new-routing-mark=to_link-3adsl passthrough=yes
    /ip firewall mangle add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=link-1adsl new-connection-mark=link-1adsl_conn passthrough=yes per-connection-classifier=both-addresses:7/0
    /ip firewall mangle add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=link-2adsl new-connection-mark=link-2adsl_conn passthrough=yes per-connection-classifier=both-addresses:7/1
    /ip firewall mangle add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=link-2adsl new-connection-mark=link-2adsl_conn passthrough=yes per-connection-classifier=both-addresses:7/2
    /ip firewall mangle add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=link-3adsl new-connection-mark=link-3adsl_conn passthrough=yes per-connection-classifier=both-addresses:7/3
    /ip firewall mangle add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=link-3adsl new-connection-mark=link-3adsl_conn passthrough=yes per-connection-classifier=both-addresses:7/4
    /ip firewall mangle add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=link-3adsl new-connection-mark=link-3adsl_conn passthrough=yes per-connection-classifier=both-addresses:7/5
    /ip firewall mangle add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=link-3adsl new-connection-mark=link-3adsl_conn passthrough=yes per-connection-classifier=both-addresses:7/6
    /ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=link-1adsl_conn disabled=no in-interface=link-1adsl new-routing-mark=to_link-1adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=link-2adsl_conn disabled=no in-interface=link-2adsl new-routing-mark=to_link-2adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=link-3adsl_conn disabled=no in-interface=link-3adsl new-routing-mark=to_link-3adsl passthrough=yes



    Citação Postado originalmente por scan Ver Post
    Boa tarde RogerioDj!

    Estive a olhar o código gerado e verifiquei que o mesmo só gera uma interface pppoe se vc configurar para adsl - bridge, onde neste caso vc indica a interface que esta conectado o modem adsl, como não é preciso configurar ip para o mesmo, é criado uma conexão pppoe onde a mesma é que vai ser utilizada para conexão adsl e nat, a interface onde esta o adsl só serve como meio para a autenticaçào.

    Agora, se o seu adsl estiver rotiado, ou seja, vc fez a autenticação no próprio modem, neste caso vc deve usar a primeira opção do programa que é Dedicado / adsl - rotiado.

    Obrigado por testar o programa e se tiver mais uma observação é só falar.



  9. Bom dia RogerioDJ!

    Agora eu entendi, vou fazer a modificação aqui e retorno a versão corrigida.

    t++

  10. Bom dia!

    Segue em anexo nova versão do programa com correções.

    ver. 0.7
    http://www.saocarlosnet.com.br/pcc_0.7.zip
    http://www.saocarlosnet.com.br/log.txt

    OBS: se encontrarem algum erro, favor é só falar que eu verifico e corrigo.



  11. Bom dia RogerioDj!

    Acabei de testar a versão 0.7 aqui no meu servidor com 3 links dedicados Embratel + 4 links ADSL, funcionou perfeitamente, pode usar agora que vc vai ver que foi corrigido os erros, mas caso encontre mais algum é só falar.

    t++

  12. Meu brother,

    Muito legal seu programa,

    Já uso ele aqui e funciona blz, mas estou com uma dúvida, na verdade um probleminha, desde que configurei o pcc, tenho tido problemas no carregamento de páginas, dá erro ao carregar e quando atualizo a página ela recarrega normal, o que poderia ser??

    Imagino que possa ser algo com o dns, já chequei as operadoras e está normal, mas tenho dúvidas quanto a configuração do DNS para os dois links, o dns de um link fica como primário e o do outro como secundário??



  13. Bom dia Palozo!
    já tive problemas de DNS aqui tambem, e na maioria das vezes éra o próprio DNS.
    OBS:
    eu uso o links -> PCC -> MK - controle de clientes
    no esquema acima eu não uso o dns do pcc, e sim o dns do MK - controle de clientes, moral da história, o cliente requisita para o MK - controle de clientes, o mesmo requisita para o pcc mas já informando o ip destino e não requisitando o dns, assim evita o bloqueio de dns por parte das operadoras.
    tipo vc querer usar o dns da embratel nos links Embratel e velox.

    E, vc colocando um servidor dns ao lado do MK - controle de clientes, fica melhor ainda.

    espero ter ajudado.
    t++

  14. Sugestoes/Correçoes
    Caro scan , sugiro algumas modificaçoes/correçoes no programa, que alias é muito bom:

    1 - Opçao para escolher qual dos links será a rota padrão (distance=1 e sem routing-mark)
    2 - em /interface pppoe-client , setar como no as opçoes add-default-route e use-peer-dns , pois as mesmas interferem nas rotas e dns setados pelo codigo gerado.
    3 - Criar uma regra pra direcionar o trafego https (porta tcp 443) para a rota principal (esta regra deve ficar antes das regras do balanceamento PCC)
    (/ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=ether1)
    4 - Mudar a politica de balanceamento de=both-address para=both-address-and-ports , acho que esta ultima divide o trafego mais uniformemente.

    O resto ta excelente, o programa faz muito bem o que promete. Parabens pela iniciativa

  15. Boa tarde gsiena!

    ótimas observações, eu estava procurando como remover as rotas que o pppoe cliente gerava.
    adicionei todas as observações sitadas no versão do programa que vou postar logo mais com exeção da primeira.
    só não entendi o a observação 1, pois a jogada é justamente usando o routing-mark, no site da MK mostra desta forma pois na medida que o link cai ele vai para o prossimo. por isso temos a sequencia de links com distance 1, 2 , 3, etc.

    obrigado pela ajuda e se tiver mais idéias para melhorar o programa é só falar.
    t++

  16. Segue em anexo nova versão do programa, versão 0.8.

    http://www.saocarlosnet.com.br/PCC_ver_0.8.zip
    http://www.saocarlosnet.com.br/log.txt

    t++

  17. Excelente ajuda caro amigo, vou fazer alguns testes aqui na RB450!

  18. a minha duvida ainda é a onde colocar os dns pois tou usando opendns 208.67.222.222 e 208.67.220.220 no mikrotik cliente e continuar aparecendo paginas brancas dos sites e dificuldades de abri o msn

    esquema

    load
    192.168.254.3
    255.255.255.0
    192.168.254.2
    dns 208.67.222.222
    dns 208.67.220.220

    mikrotik cliente
    192.168.2.3
    255.255.255.0
    192.168.2.2
    dns 208.67.222.222
    dns 208.67.220.220

    afinal a onde estou errando dessa vez para ficar aparecendo pas paginas brancas e não carregar o site direito.

  19. Bacana baixei aqui quando chegar minha rb 450 vo testar.

  20. Mais algumas dicas para o nosso amigo scan:
    1 - Pequeno erro de gramática, Link Dedicado / Link rotiado ADSL , trocar "rotiado" para "roteado"
    2 - Quanto aos comentarios/scripts , basta que sejam feitos apenas no menu /ip route , Quando um pacote é direcionado para uma routing-mark cujo link esteja down, automaticamente vai para a rota padrao (rotas padrao sao aquelas que nao tem routing-mark setada), Não é nescessário desabilitar regras em qualquer menu do /ip firewall , apenas em /ip route se desabilitar uma regra de um link inativo, automaticamente vai para o proximo link ativo.
    3 - Em /ip firewall mangle, trocar tudo onde tem: chain=input para chain=prerouting (dica retirada de NetworkPro on Combining NATed Links - MikroTik Wiki ), fiz isso aqui e melhorou ligeiramente o balanceamento, e ainda torna possivel acessar o Mikrotik LoadBalance externamente através de qualquer link ativo, mesmo que outros links estejam down.
    4 - /ip firewall mangle add action=accept chain=prerouting comment="Link1" disabled=no dst-address=200.199.200.2/26 in-interface=ether1
    Nesta regra, em dst-address , esta adicionando o endereço ip , o correto seria adicionar a network do link em questao... ex: 200.199.200.0/26
    5 - Na address-list loopback, incluir as networks de redes locais e links dedicados, ex: 192.168.0.0/24 , 200.199.200.0/26 , fazendo isso pode eliminar esta regra: /ip firewall mangle add action=accept chain=prerouting comment="" disabled=no dst-address=200.199.200.0/26 in-interface=ether1
    6 - A opçao check-gateway=ping nao tem efeito em links adsl bridge (onde o gateway é diretamente a interface pppoe-client) , então pode ser removida essa opção para links adsl bridge.

    Bom , basicamente é isso, se eu observar mais detalhes volto a postar
    Obrigado
    Gabriel Siena






Tópicos Similares

  1. Respostas: 24
    Último Post: 25-03-2014, 06:52
  2. script para gerar tabelas dos logs???
    Por tomelin no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 26-06-2006, 08:25
  3. programa para testar segurança do firewall
    Por johnny no fórum Servidores de Rede
    Respostas: 9
    Último Post: 01-11-2005, 12:48
  4. problemas para gerar modulo do tomcat
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-09-2004, 09:07
  5. Programa para gerenciar configuração!!!
    Por Algoritmo_PB no fórum Servidores de Rede
    Respostas: 2
    Último Post: 24-07-2004, 14:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L