+ Responder ao Tópico



  1. #1

    Padrão Problema instalação do LUSCA

    Olá pessoal, de tanto ouvi falar com LUSCA resolvi testa-lo. Estou usando o slackware 13.0 64Bit, o pacote LUSCA_HEAD-r14371, porém estou tendo um erro no momento da compilação:

    ./cf_gen cf.data ./cf.data.depend
    make all-recursive
    make[2]: Entering directory `/usr/src/lusca/LUSCA_HEAD-r14371/src'
    Making all in fs
    make[3]: Entering directory `/usr/src/lusca/LUSCA_HEAD-r14371/src/fs'
    make[3]: *** No rule to make target `libufs.a', needed by `all-am'. Stop.
    make[3]: Leaving directory `/usr/src/lusca/LUSCA_HEAD-r14371/src/fs'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/usr/src/lusca/LUSCA_HEAD-r14371/src'
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/usr/src/lusca/LUSCA_HEAD-r14371/src'
    make: *** [all-recursive] Error 1

    Parametros de Configuração:

    CFLAGS=-march=native CXXFLAGS=-march=native --prefix=/usr/local/squid --sysconfdir=/etc/squid -localstatedir=/var/log/squid --datadir=/usr/share/squid --mandir=/usr/man --enable-delay-pools --enable-default-err-language=Portuguese --enable-auth="basic,digest,ntlm" --enable-removal-policies="lru,heap" --enable-ident-lookups --enable-useragent-log --enable-cache-digests --enable-referer-log --enable-arp-acl --with-pthreads --with-large-files --enable-htcp --enable-carp --enable-follow-x-forwarded-for --enable-snmp --enable-ssl --enable-storeio="ufs,diskd,coss,aufs,null" --enable-async-io --enable-linux-netfilter --with-maxfd=101825 --enable-dependency-tracking --enable-icmp --enable-cachemgr-hostname=localhost --enable-forw-via-db --enable-epoll --enable-http-violations --enable-truncate --enable-ntlm-fail-open --enable-stacktraces --enable-x-accelerator-vary --with-aio --with-dl --enable-large-cache-files


    Peço que quem puder ajudar ficarei imensamente grato. Ajuda ae AlexandreCorrea kkkk.

    Abraços

  2. #2

    Padrão

    --enable-storeio="ufs,diskd,coss,aufs,null"

    remova o ufs !!

    migramos o ufs para aufs

    se der erro novamente.. remova o diskd (nao lembro se essa release esta com diskd)

    o diskd foi removido para melhorar o aufs.. (nao que o diskd atrapalhe, mas apenas para liberar codigo) ..



  3. #3

    Padrão

    Olá mano Alexandre, muito grato a sua resposta, ja havia resolvido durante essa madrugada, retirando realmente o ufs,diskd. Não postei de imediato o resultado porque o forum estava dando erro. Muitissimo obrigado por responder a meu pedido, o direcionei a vc por sei que és um cara humilde e sempre disposto a ajudar a comunidade. Forte abraço.

  4. #4

    Padrão

    Boa noite Standart.
    Estou querendo isntala o Lusca sera que tu num pode me dar um help nisso.
    eu num faço ideia nem por onde começa.



  5. #5

    Padrão

    Posso Sim amigo DuContra, até onde eu puder, tem amigos mais experientes com o lusca aqui como o mano Alexandre Correa. eu neste momento estou com ele instalado em um servidor atendendo 300 clientes, porém estou com problemas de lentidão desde que o colloquei ele aqui, em algum momento tive que desativar a regra de redirecionamento para deixar que os clientes trabalhasse.

    Nos logs encontrei muitos erros como este:

    httpReadReply: Unexpected reply body data
    httpReadReply: Unexpected reply body data
    2010/02/06 13:06:44| storeLocateVary: Not our vary marker object, 6793CAEFCBC05C7426C22D95320558C1 = 'http://ads1.msn.com/l
    ibrary/dap.js', 'accept-encoding="gzip,%20deflate"'/'-'
    2010/02/06 13:06:47| storeLocateVary: Not our vary marker object, 6793CAEFCBC05C7426C22D95320558C1 = 'http://ads1.msn.com/l
    ibrary/dap.js', 'accept-encoding="gzip,%20deflate"'/'-'
    2010/02/06 13:06:48| httpReadReply: Unexpected reply body data from "GET Untitled Document
    "
    toreLocateVary: Not our vary marker object, 6793CAEFCBC05C7426C22D95320558C1 = 'http://ads1.msn.com/library/dap.js', 'accept-encoding="gzip,%20deflate"'/'-'


    Se o amigo quiser ajudar na instalação pode contar comigo. E quem puder ajudar a fazer funcionar perfeitinho, no ajude ai.

    Abraços

  6. #6

    Padrão

    estes erros ai sao normais.. nao é o que esta gerando problema..

    proxy voce precisa configurar de acordo com o perfil dos clientes e maquina/hardware..

    mais cache = mais memoria...

    veja se o seu sistema nao esta utilizando a memoria SWAP.. se estiver.. voce precisa colocar mais memoria.. proxy quando consome swap.. fica uma bos**..

    alem de outros parametros como, configuracao dos discos, cache_dir, memory pools.. etc etc .. cada caso provavelmente vai ser um caso !



  7. #7

    Padrão

    oi Alexandre, tem pouco mais de 10min que tirei ele de produção, etava muito ruim , sem contar que estava usando ele integrado com o thundercache e não sei porque motivo as unicas requisições que chegava no thunder era do avast e mais nada. Apesar de estar muito interessado em usa-lo, tive de voltar ao velho squid 2.7. Sobre a maquina é um Pentium 2 Quad, 8GB de memoria e 2TB de HD. O que me impressiona é que com squid esta funcionando perfeito.

    Abraços, se souber mais de algo que possa ajudar, estarei montando um maquina de laboratorio daqui mais alguns minutos, para testar ele, especialmente com relação a essa integração com o thunder.



    Citação Postado originalmente por alexandrecorrea Ver Post
    estes erros ai sao normais.. nao é o que esta gerando problema..

    proxy voce precisa configurar de acordo com o perfil dos clientes e maquina/hardware..

    mais cache = mais memoria...

    veja se o seu sistema nao esta utilizando a memoria SWAP.. se estiver.. voce precisa colocar mais memoria.. proxy quando consome swap.. fica uma bos**..

    alem de outros parametros como, configuracao dos discos, cache_dir, memory pools.. etc etc .. cada caso provavelmente vai ser um caso !

  8. #8

    Padrão

    Cara eu to mais perdido que azeitona em boca de banguelo...
    Fiz alguns passos como o Paulo me recomendou mas parei aki....
    Digitei esse comando aki e apareceu um erro....
    debian:/pacote/LUSCA_HEAD-r14371# ./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-async-io --with-pthreads --enable-storeio=aufs --enable-linux-netfilter --enable-arp-acl --enable-epoll --enable-removal-policies=lru,heap --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests --enable-underscores --enable-referer-log --enable-useragent-log --enable-auth=basic,digst,ntlm,negotiate --enable-negoiate-auth-helpers=squid_kerb_auth --enable-carp --enable-follow-x-forwarded-for --with-large-files --with-maxfd=65536 i386-debian-linux build_alias=i386-debian-linux host_alias=i386-debian-linux target_alias=i386-debian-linux CFLAGS=-Wall -g -02 LDFLAGS= CPPFLAGS=
    configure: WARNING: you should use --build, --host, --target isso aki e normal...

    ai deu o seguinte erro
    configure: error: unrecognized option: -g
    Try `./configure --help' for more information.

    ai resolvi tira o -g e o -02

    e dei um make all e no final deu esse erro aki.

    make[3]: *** Sem regra para processar o alvo `libdigst.a', necessário por `all-am'. Pare.
    make[3]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src/auth'
    make[2]: ** [all-recursive] Erro 1
    make[2]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src'
    make[1]: ** [all] Erro 2
    make[1]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src'
    make: ** [all-recursive] Erro 1


    ai parei aki e to procurando algo aki no google e nos foruns da vida pra ver se acho algo.
    se puder me ajuda com isso agradeço.



  9. #9

    Padrão

    Olá amigo DuContra, coloca ai que sistema esta utilizando, versão e kernel.

    Valeu

    Citação Postado originalmente por DuContra2 Ver Post
    Cara eu to mais perdido que azeitona em boca de banguelo...
    Fiz alguns passos como o Paulo me recomendou mas parei aki....
    Digitei esse comando aki e apareceu um erro....
    debian:/pacote/LUSCA_HEAD-r14371# ./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-async-io --with-pthreads --enable-storeio=aufs --enable-linux-netfilter --enable-arp-acl --enable-epoll --enable-removal-policies=lru,heap --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests --enable-underscores --enable-referer-log --enable-useragent-log --enable-auth=basic,digst,ntlm,negotiate --enable-negoiate-auth-helpers=squid_kerb_auth --enable-carp --enable-follow-x-forwarded-for --with-large-files --with-maxfd=65536 i386-debian-linux build_alias=i386-debian-linux host_alias=i386-debian-linux target_alias=i386-debian-linux CFLAGS=-Wall -g -02 LDFLAGS= CPPFLAGS=
    configure: WARNING: you should use --build, --host, --target isso aki e normal...

    ai deu o seguinte erro
    configure: error: unrecognized option: -g
    Try `./configure --help' for more information.

    ai resolvi tira o -g e o -02

    e dei um make all e no final deu esse erro aki.

    make[3]: *** Sem regra para processar o alvo `libdigst.a', necessário por `all-am'. Pare.
    make[3]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src/auth'
    make[2]: ** [all-recursive] Erro 1
    make[2]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src'
    make[1]: ** [all] Erro 2
    make[1]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src'
    make: ** [all-recursive] Erro 1


    ai parei aki e to procurando algo aki no google e nos foruns da vida pra ver se acho algo.
    se puder me ajuda com isso agradeço.

  10. #10

    Padrão

    Debian Lenny 5.0.3
    i386 64Bits
    Kenel 2.6.26-2-686



  11. #11

    Padrão

    criei uma ISO do debian com o lusca já instalado, a url para download é: http://bit.ly/PJN92 e o manual de instalação: http://mk-auth.ning.com/page/instalacao-1 adicionei tb um script em perl para que ele faça cache do youtube...
    Última edição por pedrovigia; 20-02-2010 às 22:24. Razão: ortografia