+ Responder ao Tópico



  1. #1

    Unhappy CACHE-FULL aumenta o ping externo demasiadamente. Issso confere?

    Tentei instalar o cache full aqui no server v3.30, mas sem sucesso. Observei quando são criadas as regras de leitura de cada patoce (acho que é aqui o problema) para saber se contem o "HIT", o ping que antes era de 80ms, para o speedtest, agora está em 320ms, 350ms.

    Ah, concluí que o cache só vale mesmo a pena quando se tem uma conexão razoável, pois o cache baixa todo o contetúdo, mesmo que não seja visto pelo cliente que solicitou a requisição. Deixando a conexão "lerda" se o link for baixo, no meu caso 1Mb.

    Após retirar as tais regras tudo volta ao normal, assim o pessoal pode jogar online tranquilamente. Isso aconteceu com vocês também, comentem ae.

  2. #2

    Padrão

    Olha nunca nem tentei o Cache full, porque tinha encontrado problemas com amigos meus, eu recomendo Proxy Squid+thundercache, desafoga um bocado o seu link sem ter muitos problemas, agora tem uma coisa teria que ser um projeto milimetricamente calculado se vc quer usar algum proxy e tbm ter serviço de jogos On line, o que na internet via rádio não combina, eu não sou contra o uso de p2p no provedor, mas penso 2 vezes sobre o uso da banda pelo steam (por exemplo) Agora a dica está dada



  3. #3

    Padrão

    Citação Postado originalmente por sosouteiro Ver Post
    Após retirar as tais regras tudo volta ao normal, assim o pessoal pode jogar online tranquilamente. Isso aconteceu com vocês também, comentem ae.
    Tentou verificar quando vc ativa as regras quanto fica o consumo de link? Individual e total?
    Talvez tenha algum erro que permita os usuarios navegarem acima da banda contratada.

  4. #4

    Padrão

    Olha nunca nem tentei o Cache full, porque tinha encontrado problemas com amigos meus, eu recomendo Proxy Squid+thundercache, desafoga um bocado o seu link sem ter muitos problemas, agora tem uma coisa teria que ser um projeto milimetricamente calculado se vc quer usar algum proxy e tbm ter serviço de jogos On line, o que na internet via rádio não combina, eu não sou contra o uso de p2p no provedor, mas penso 2 vezes sobre o uso da banda pelo steam (por exemplo) Agora a dica está dada
    Estou tentando implantar o squid+thunder, ta me dadno um trabalho... mas vai dar certo.

    Tentou verificar quando vc ativa as regras quanto fica o consumo de link? Individual e total?
    Talvez tenha algum erro que permita os usuarios navegarem acima da banda contratada.
    Aqui os clientes estão autenticando com PPPoE. Foram criados profiles para cada velocidade de conexão, ou seja, é tudo automático, não tem como ele navegar sem autenticar, e se autenticar vai cair no queues automático feito pelo profile o servidor de PPPoE.



  5. #5

    Padrão

    Estou com o mesmo problema aqui . Quando ativo o Web Proxy a latencia sobe para mais que 200ms, e quando desativo fica menor que 80 ms. Pensei que eram as regras de cahe full, mas não , é do proxy mesmo. Abaixo as regras:

    /ip firewall filter>

    add action=drop chain=input comment="Bloqueio externo do proxy " disabled=no \
    dst-port=3129 in-interface=ether2 protocol=tcp

    /ip firewall nat>

    add action=redirect chain=dstnat comment="REDIRECIONAR PROXY" disabled=no \
    dst-port=80 in-interface=ether1 protocol=tcp to-ports=3129

    /ip firewall mangle>

    add action=mark-connection chain=output comment="CACHE FULL" disabled=no \
    dscp=4 new-connection-mark=WEB-PROXY out-interface=ether1 passthrough=yes
    add action=mark-packet chain=output comment="" connection-mark=WEB-PROXY \
    disabled=no new-packet-mark=Web-Proxy passthrough=no

    /ip proxy>

    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=10000000KiB \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=3129 serialize-connections=\
    no src-address=0.0.0.0
    /ip proxy access
    add action=deny comment="block telnet & spam e-mail relaying" disabled=no \
    dst-port=23-25
    add action=deny comment=\
    "allow CONNECT only to SSL ports 443 [https] and 563 [snews]" disabled=no \
    dst-port=!443,563 method=CONNECT
    add action=allow comment="" disabled=no src-address=192.168.xxx.0/24
    /ip proxy cache
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\?"
    add action=deny comment="" disabled=no dst-host=https: path=/
    add action=allow comment="" disabled=yes


    Se alguém puder ajudar dando uma analisada nas regras eu agradeceria muito

  6. #6

    Padrão

    Citação Postado originalmente por sosouteiro Ver Post
    Estou tentando implantar o squid+thunder, ta me dadno um trabalho... mas vai dar certo.



    Aqui os clientes estão autenticando com PPPoE. Foram criados profiles para cada velocidade de conexão, ou seja, é tudo automático, não tem como ele navegar sem autenticar, e se autenticar vai cair no queues automático feito pelo profile o servidor de PPPoE.
    Bem você está certo em usar autenticação PPoE para os jogadores de rede, agora se vc tem até 60 clientes e um link profissional ( ADSL não faz milagres hehehe) nem precise se qq cache, mas pra te dar uma força com o thunder aew vai uma força Tutorial Debian cache para integração com Mikrotik


    Citação Postado originalmente por marciorct Ver Post
    Estou com o mesmo problema aqui . Quando ativo o Web Proxy a latencia sobe para mais que 200ms, e quando desativo fica menor que 80 ms. Pensei que eram as regras de cahe full, mas não , é do proxy mesmo. Abaixo as regras:

    /ip firewall filter>

    add action=drop chain=input comment=\"Bloqueio externo do proxy \" disabled=no \
    dst-port=3129 in-interface=ether2 protocol=tcp

    /ip firewall nat>

    add action=redirect chain=dstnat comment=\"REDIRECIONAR PROXY\" disabled=no \
    dst-port=80 in-interface=ether1 protocol=tcp to-ports=3129

    /ip firewall mangle>

    add action=mark-connection chain=output comment=\"CACHE FULL\" disabled=no \
    dscp=4 new-connection-mark=WEB-PROXY out-interface=ether1 passthrough=yes
    add action=mark-packet chain=output comment=\"\" connection-mark=WEB-PROXY \
    disabled=no new-packet-mark=Web-Proxy passthrough=no

    /ip proxy>

    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=10000000KiB \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=3129 serialize-connections=\
    no src-address=0.0.0.0
    /ip proxy access
    add action=deny comment=\"block telnet & spam e-mail relaying\" disabled=no \
    dst-port=23-25
    add action=deny comment=\
    \"allow CONNECT only to SSL ports 443 [https] and 563 [snews]\" disabled=no \
    dst-port=!443,563 method=CONNECT
    add action=allow comment=\"\" disabled=no src-address=192.168.xxx.0/24
    /ip proxy cache
    add action=deny comment=\"\" disabled=no dst-host=\":cgi-bin \\\?\"
    add action=deny comment=\"\" disabled=no dst-host=https: path=/
    add action=allow comment=\"\" disabled=yes


    Se alguém puder ajudar dando uma analisada nas regras eu agradeceria muito
    não ví nada de errado no seu script, deve estar em algum outro ponto da rede ,em algum router por exemplo!



  7. #7

    Padrão

    Nossa cara, valeu pelo link do tutorial! Eu esto encontrando dificuldades em implantar o thunder, infelizmente. Aqui o meu link é dedicado da Intelig. Muito bom, por sinal. Aqui no nordeste o "tempo de resposta" (pings) é sempre alto. Pois o fornecedor mais próximo ficava em minas e vinha com fibra até nós. Agora com a intelig por aqui, muda tudo. O ping era entre 300ms e 500ms, agora mal passa dos 80ms. É uma riqueza!!!

  8. #8

    Padrão

    Citação Postado originalmente por sosouteiro Ver Post
    Nossa cara, valeu pelo link do tutorial! Eu esto encontrando dificuldades em implantar o thunder, infelizmente. Aqui o meu link é dedicado da Intelig. Muito bom, por sinal. Aqui no nordeste o "tempo de resposta" (pings) é sempre alto. Pois o fornecedor mais próximo ficava em minas e vinha com fibra até nós. Agora com a intelig por aqui, muda tudo. O ping era entre 300ms e 500ms, agora mal passa dos 80ms. É uma riqueza!!!
    De nada , cara mais ainda acho q tu é mto paciente, eu já teria mudado pro link via satélete KKKKKKK
    !!!!!!!!!!!!!



  9. #9

    Padrão

    Eu consegui montar o cache-full com o debian 5 mais o squid!!! Tô na peleja para implantar o Thunder, mas vai dar certo. O problema que eu to encontrando é para criar a rota para que o mikrotik repasse os ips dos clientes da rede interna para eu poder gerar um relatório com que cada IP acessa, seja ele no sarg ou mais posteriormente no Thunder.

    Detalhe, o ping continua estável entre 75ms e 85ms.

    Alguém tem como me dá uma luz ai?
    Última edição por sosouteiro; 18-02-2010 às 09:02.

  10. #10

    Padrão

    Bom, imagino que vc (criador do tópico) use o Web-proxy... já ouvi muito que ele não é lá essas coisas... ainda não tenho proxy aqui, mas estou começando um Squid... nem tentei o Web-proxy pelos relatos que eu tive... Talvez o seu problema seja até capacidade de processamento no web-proxy... pode ser bastante coisa... mas eu tentaria com primeiro Squid...



  11. #11

    Padrão

    Citação Postado originalmente por pedemesa Ver Post
    Bom, imagino que vc (criador do tópico) use o Web-proxy... já ouvi muito que ele não é lá essas coisas... ainda não tenho proxy aqui, mas estou começando um Squid... nem tentei o Web-proxy pelos relatos que eu tive... Talvez o seu problema seja até capacidade de processamento no web-proxy... pode ser bastante coisa... mas eu tentaria com primeiro Squid...

    Aqui eu não estou mais usando o WEB-PROXY, estou usando uma máquina separada com o Debian 5 com o squid fazendo cache full junto ao mikrotik. Eu queria saber como repassar os ips dos clientes para o Debian e depois retornalos ao mikrotik.

  12. #12

    Padrão

    Citação Postado originalmente por sosouteiro Ver Post
    Aqui eu não estou mais usando o WEB-PROXY, estou usando uma máquina separada com o Debian 5 com o squid fazendo cache full junto ao mikrotik. Eu queria saber como repassar os ips dos clientes para o Debian e depois retornalos ao mikrotik.
    Aumento de latência tem relação direta com utilização do circuito/link.

    verifique controle de banda, utilização do link, capacidade do mesmo, se tiver mais de 1 servidor usando o link, etc, etc



  13. #13

    Padrão Re: CACHE-FULL aumenta o ping externo demasiadamente. Issso confere?

    Citação Postado originalmente por sosouteiro Ver Post
    Tentei instalar o cache full aqui no server v3.30, mas sem sucesso. Observei quando são criadas as regras de leitura de cada patoce (acho que é aqui o problema) para saber se contem o "HIT", o ping que antes era de 80ms, para o speedtest, agora está em 320ms, 350ms.

    Ah, concluí que o cache só vale mesmo a pena quando se tem uma conexão razoável, pois o cache baixa todo o contetúdo, mesmo que não seja visto pelo cliente que solicitou a requisição. Deixando a conexão "lerda" se o link for baixo, no meu caso 1Mb.

    Após retirar as tais regras tudo volta ao normal, assim o pessoal pode jogar online tranquilamente. Isso aconteceu com vocês também, comentem ae.
    Boa tarde amigo, nao sei se voce conseguiu resolver a questao do aumento do ping quando ativa o proxy do proprio mk...
    tenho funcionando em duas versoes -2.9.51 e 4.9 mas apenas na 4.9 acontece o mesmo: aumento do ping. ja tentei de varias formas mas sem resultado. voce conseguiu ?!
    Alguem sabe o por quê?

    abs

  14. #14

    Padrão Re: CACHE-FULL aumenta o ping externo demasiadamente. Issso confere?

    Aqui meu ping ta normal. Eu não uso o web-proxy justamente por isso. Uso a versão 3.30. Estou usando uma máquina separada com squid e thunder3, ficou perfeito!

    Com web-proxy, não teve jeito. :/



  15. #15

    Padrão Re: CACHE-FULL aumenta o ping externo demasiadamente. Issso confere?

    Pessoal tava pensando na seguinte solução tenho a versao 3.30 do mk aki original será que irei encontrar problemas de lentidão Servidor MK Controle<<<<<Servidor MK Cache<<<< Servidor Thundercache estive pensando no thundercache para armazenar os videos e o cache para armazenar arquivos com tamanho de ate 100 mb se alguem tiver uma solução parecida ou igual que funcione e queira compartilhar estamos ai.

  16. #16

    Padrão Re: CACHE-FULL aumenta o ping externo demasiadamente. Issso confere?

    Aki uso o web-proxy do mk mesmo.. ta on a 2 meses e não deu problema., nem ping e nem lentidão da rede..
    Pelas regras postadas anteriromente,, aminha é diferente.. marco no mangle todas as conexoes que saem do proxy.. E não todas da interface como mostra a regra.. Uso o X-cache: HIT.. Coloco a velocidade do cache para 2MB com PCQ.. ou seja.. o proxy nao utiliza mais que 2mb na minha rede,, nem se tiverem x conectados no proxy..
    Tah show aki.. Estou montando uma makina pra colocar DEBIAN + SQUID + THUNDER... Só por causa dos videos e dos logs gerados..



  17. #17

    Padrão Re: CACHE-FULL aumenta o ping externo demasiadamente. Issso confere?

    xtremejack

    com quantos clientes vc tem na sua rede ?

  18. #18

    Padrão Re: CACHE-FULL aumenta o ping externo demasiadamente. Issso confere?

    Citação Postado originalmente por sosouteiro Ver Post
    Aqui meu ping ta normal. Eu não uso o web-proxy justamente por isso. Uso a versão 3.30. Estou usando uma máquina separada com squid e thunder3, ficou perfeito!

    Com web-proxy, não teve jeito. :/
    Acompanhei o topico e parabens por voce ter conseguido implantar o thunder...parabens!

    O que mais me incomoda é que,como falei antes, testei em duas versoes (2x e 4x) e apenas na versao 4x tem aumento no ping quando ativo o proxy full . Na versao 2x nao há aumento no ping quando uso o proxy full.
    Será que tem a ver com hardware? com alguma regra a ser acrescentanda nessa versao? com a versao? com o quê??

    abs



  19. #19

    Padrão Re: CACHE-FULL aumenta o ping externo demasiadamente. Issso confere?

    Citação Postado originalmente por patrickfrank Ver Post
    xtremejack

    com quantos clientes vc tem na sua rede ?
    Minha rede ainda é bem pequena, pois tenho 2 meses e estou completamente ilegal perante a tia ana contra 2 provedores legalizados aki.. Respondendo.. Simultaneos média 18 ~ 25

  20. #20

    Padrão Re: CACHE-FULL aumenta o ping externo demasiadamente. Issso confere?

    ta bom começando com qualidade isso faz toda diferença aqui temos uma rede com cerca de 250 clientes e link dedicado de fibra otica.