+ Responder ao Tópico



  1. Pessoal o problema foi resolvido depois que desmarquei a opção IP > DNS > DNS Settings "Allow Remote Requestes" e parou de dar problema, só sei que resolveu

    Abraço a todos!

  2. Citação Postado originalmente por mamaunet Ver Post
    Caro guilhermeramires, uso o MK 4.6 e com os DNS do OpenDNS e quando ligo o Servidor ta tudo blz, depois que o cache do dns alcança uns 2 mil e 300 itens ele começa a dar erro de páginas nos clientes depois que dou um "flush" ele retorna normalmente... assim que chegar em casa te mando as confs com + detalhes.

    Abraço!
    Só por curiosidade, aumenta o cache size pra 4096 e checa se vai continuar.

    Abs.



  3. 2 coisas, pra vcs terem um ganho real na navegação o servidor deveresponder o mais rapido possivel a solicitação certo!!!
    então vamos dar uma forcinha pro mikrotik, habilitem o dns cache dele e marquem a opção de "allow remote requests" (deve ser + - isso que ta na caixinha) apos, usando uma maquina linux coloquem em seus resolv.conf o endereço do seu dns preferido e testem quem se sai melhor (eu uso o 8.8.8.8 e o 208.67.222.222) apos isso feito, coloque os ips ganhadores la no ip/dns/settings como primario e secundario ok... agora a magica.

    La em ip/fireall/nat crie uma regra

    add action=dst-nat chain=dstnat comment="Cache Acelerador de DNS" disabled=no dst-port=!53 in-interface=(sua interface clientes) protocol=udp src-address=!(ip mk) to-addresses=(ip mk) to-ports=53

    com isso todas as requisições iram pro cache e buscar tb do cache menos o que o MK buscar na internet atravez do cache.

  4. Amigo,

    Permita-me algumas indagações:

    Primeiramente duas modificações na regra que você propôs:

    add action=dst-nat chain=dstnat comment="Cache Acelerador de DNS" disabled=no dst-port=53 in-interface=(sua interface clientes) protocol=udp dst-address=!(ip mk) to-addresses=(ip mk) to-ports=53

    * No caso essa regra não "acelera" o dns. Ela simplemente força o cliente optar pelo cache de DNS do servidor Mikrotik.

    Essa regra somente será necessária se seus clientes não "setem" de forma automática o servidor DNS como sendo o seu servidor Mikrotik. No caso de configuração por DHCP, PPPoE ou qualquer outra forma de designação de ip pro cliente que você possa passar o parametro correto do seu servidor DNS, essa regra não é necessária.

    Abs.



  5. "" No caso essa regra não "acelera" o dns. Ela simplemente força o cliente optar pelo cache de DNS do servidor Mikrotik.""

    Pois bem Guilherme, se eu forço dessa forma que vai buscar a resposta é meu cache, e não meu cliente. Instale um linux ai como cliente e de um DIG pra qqr endereço e veja o resultado com e sem a regra, aceleradores externos pra que se ML é uma ferramenta excelente, contudo tenho que usar de artimanha pra que tudo seja repassado pra ele, exatamente porque cada cliente (na maioria das vezes) coloca seu proprio DNS quando se trata de wireless achando que esta ganhando algo, e dai vem a resposta.

    Com esta regra simplória consigo reduzir um fluxo importante (pequeno mas precioso), mas a resposta é absurdamente superior aos defaults.

    Só um adendo: Pra que usamos cache de DNS se não acelerar nada né, então o processo de saida e retorno do pacote deveriam ser imperceptiveis, mas de 450ms(em casos) pra 2ms como é o caso com esta regra, pra mim que não tenho banda isso importa!!!
    Última edição por int21; 10-08-2010 às 19:09.






Tópicos Similares

  1. Respostas: 6
    Último Post: 23-10-2017, 12:28
  2. Link da Net Virtua parou de funcionar no Mikrotik
    Por hud90cs no fórum Mikrotik
    Respostas: 14
    Último Post: 31-05-2017, 13:06
  3. Respostas: 9
    Último Post: 13-07-2015, 22:56
  4. Respostas: 7
    Último Post: 17-12-2010, 18:05
  5. Script para horario de verao no Mikrotik
    Por hyperpotato no fórum Redes
    Respostas: 2
    Último Post: 17-10-2009, 08:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L