Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Ola! muito bom este script. mas tenho umas duvidas Nas aspa ex: "" coloca o nome do script criado? para todas as regras? tem aspas em tudo explique melhor porfavor.
    fico grato.

  2. #22

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Citação Postado originalmente por Bender Ver Post
    Aqui tambem to com o mesmo problema com o ROS 5.11, alguem tem ideia de como coloca esse IP na regra? To tentando e até agora nao consegui.

    Segue modelo que estou usando no script.

    /tool e-mail send server= 98.138.84.55:25 [email protected] body=POP-XXXXX subject=BACKUP-POP-XXXXX password=xxxxxx [email protected] [email protected] file=POP-XXXXX.backup

    Obrigado.
    Noa tarde Bender tdo na Paz irmão, eu tenho o script para backup por e-mail para V 5.17...
    Mais tarde eu posto ele para vc testar...

    Fica na Paz...



  3. #23

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Citação Postado originalmente por GivigiRJ Ver Post
    Noa tarde Bender tdo na Paz irmão, eu tenho o script para backup por e-mail para V 5.17...
    Mais tarde eu posto ele para vc testar...

    Fica na Paz...
    ola vc pode compartilhar com todos ?

    grato

  4. #24

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Mikrotik 5.16 Servidor emails Gmail Funcionando perfeitamente

    Script 1 - GERAR O BACKUP
    Agende este script para ser executado uns 5 minutos antes do escript que envia o backup
    /system backup save name=Backup

    Script 2 - ENVIAR O BACKUP
    tool e-mail send tls=yes body="Em anexo backup mikrotik" file="Backup.backup" from="Mikrotik" subject="MIKROTIK - BACKUP" to="[email protected]"



  5. #25

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Cara funcionou 100% no meu servidor, versao 4.6!

    Muito util, beeelo post.

  6. #26

    Talking Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Ola amigo. Sou novo por aqui. Este teu scripts serve para 5.20 mk?
    Se tiver algo diferente posta ai porfavor. Grato desde de ja.



  7. #27

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Citação Postado originalmente por MICROCHIPNET Ver Post
    Ola amigo. Sou novo por aqui. Este teu scripts serve para 5.20 mk?
    Se tiver algo diferente posta ai porfavor. Grato desde de ja.
    A pergunta nao foi a mim, mais ja avisando que funciona sim com a firm que vc perguntou.

  8. #28

    Thumbs up Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Ola amigo! desde de ja fico grato. ok.
    eu usava a versao 3.30 e o back up funfava blz. depois e passar para 5.20 nao funfa mais nem memso eu fazer rodar o script manualmente. redei o script do log e ele me enviou blz. mas de eu deixar agendando nenhum envia. este servido esta 5 dias ligado e nao enviou nenhum log ou backup por email. aqui eu uso gmail com porta 25.

    vou refazer todos os script e refazer os scheduler. posto aqui se eu conseguir ok.



  9. #29

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Citação Postado originalmente por MICROCHIPNET Ver Post
    Ola amigo! desde de ja fico grato. ok.
    eu usava a versao 3.30 e o back up funfava blz. depois e passar para 5.20 nao funfa mais nem memso eu fazer rodar o script manualmente. redei o script do log e ele me enviou blz. mas de eu deixar agendando nenhum envia. este servido esta 5 dias ligado e nao enviou nenhum log ou backup por email. aqui eu uso gmail com porta 25.

    vou refazer todos os script e refazer os scheduler. posto aqui se eu conseguir ok.


    Server:173.194.77.108
    Port:587
    fromode ser um email hotmail
    user:[email protected]
    Password:...........



    Script

    enviar-log
    :log info message="enviando log por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    :global nome [/system identity get name]
    /tool e-mail send to="[email protected]" subject="log-mikrotik-$nome $data $hora" file=log-mikrotik.txt tls=yes


    fazer-e-enviar-backup-seu nome
    /system backup save name=backup-mikrotik.backup
    :log info message="enviando backup para seunome"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    :global nome [/system identity get name]
    /tool e-mail send to="[email protected]" subject="backup-mikrotik-$nome $data $hora" file=backup-mikrotik.backup tls=yes


    salvar-log

    /log print file=log-mikrotik.txt



    scheduler

    enviar-log-automatico
    Jan/01/1970
    00:00:00
    12:00:00
    enviar-log

    fazer-e-enviar-backup-seunome
    Jan/01/1970
    00:00:00
    12:00:00
    fazer-e-enviar-backup-seunome


    salvar-log-automatico
    Jan/01/1970
    00:00:00
    12:00:00
    salvar-log

    Todos 1° é name depois é o script

    O script acima eu estou dizendo para o mikrotik enviar do gmail para meu email hotmail

  10. #30

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Ótimo post, obrigado por compartilhar!



  11. #31
    djcleyton
    Visitante

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Muito Obrigado apenas tive que mudar o ip do server para : 74.125.140.108
    Obs: testei na versão 5.20 X86.

    Citação Postado originalmente por Claudineibj Ver Post
    Server:173.194.77.108
    Port:587
    fromode ser um email hotmail
    user:[email protected]
    Password:...........



    Script

    enviar-log
    :log info message="enviando log por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    :global nome [/system identity get name]
    /tool e-mail send to="[email protected]" subject="log-mikrotik-$nome $data $hora" file=log-mikrotik.txt tls=yes


    fazer-e-enviar-backup-seu nome
    /system backup save name=backup-mikrotik.backup
    :log info message="enviando backup para seunome"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    :global nome [/system identity get name]
    /tool e-mail send to="[email protected]" subject="backup-mikrotik-$nome $data $hora" file=backup-mikrotik.backup tls=yes


    salvar-log

    /log print file=log-mikrotik.txt



    scheduler

    enviar-log-automatico
    Jan/01/1970
    00:00:00
    12:00:00
    enviar-log

    fazer-e-enviar-backup-seunome
    Jan/01/1970
    00:00:00
    12:00:00
    fazer-e-enviar-backup-seunome


    salvar-log-automatico
    Jan/01/1970
    00:00:00
    12:00:00
    salvar-log

    Todos 1° é name depois é o script

    O script acima eu estou dizendo para o mikrotik enviar do gmail para meu email hotmail

  12. #32
    ZOOM NET TELECOM LTDA Avatar de OSNIR
    Ingresso
    Feb 2011
    Localização
    PARIPIRANGA - BAHIA
    Posts
    353
    Posts de Blog
    1

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Depois de queimar alguns neuronios consegui colocar para funcionar em meus 2 servidores, tive que criar um e-mail no gmail, pois no meu servidor "kinghost" não consigo enviar, mas agora estou me deparando com um problema: nas rbs que funcionam como ap´s, como enviar o backup automatico se elas estão em bridge?

    Fiz a mesma configuiraçãomas não funciona.



  13. #33

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Citação Postado originalmente por rinaldovaz Ver Post
    escrevi esse artigo pois já vi muitos casos em que equipamentos sofreram defeitos e tiveram logs / backups perdidos por estarem guardados no próprio equipamento. O título não sugere que este guia sirva apenas para versão 4.6 do routeros, apenas que as regras foram testadas em bancada e estão funcionado bem nessa versão.


    Sugestões para melhorar ou mesmo consertar serão muito bem vindas.


    Configurando o envio de emails:


    No winbox:

    Menu

    /tool>email>

    server: Smtp.gmail.com
    port: 587
    from: [email protected]
    user: [email protected]
    password: ********** (sua senha no gmail=)

    clique no botao "apply" e imediatamente a url smtp.gmail.com é resolvida trocada para o ip certo.

    Escrevendo um script para gerar o arquivo log-mikrotik.txt
    no winbox

    menu

    /system>scripts

    adicione um script chamado "salvar-log"

    name: Salvar-log

    source: (código fonte)

    /log print file=log-mikrotik.txt


    _______________________________________

    escrevendo um script para gerar o arquivo backup-mikrotik.backup

    do mesmo jeito com o seguinte código fonte:

    Name: Salvar-backup

    source:

    /system backup save name=backup-mikrotik.backup


    _______________________________________


    agora é preciso criar mais 2 scripts, um para enviar o log e outro para enviar o backup por email



    name: Enviar-log

    source:

    :log info message="enviando log por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="[email protected]" subject="log-mikrotik $data $hora" file=log-mikrotik.txt tls=yes


    _______________________________________

    name: Enviar-backup

    source:

    :log info message="enviando backup por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="[email protected]" subject="backup-mikrotik $data $hora" file=backup-mikrotik.backup tls=yes



    _______________________________________


    configurando o envio automático dos logs/backups

    no winbox

    /system>scheduler

    agora é só agendar os 4 scripts de acordo com a necessidade, geralmente uso backup a cada 24 horas e logs a cada 6 horas como nas regras abaixo:

    /system scheduler add comment="" disabled=no interval=1d name=enviar-backup-automatico \
    on-event=enviar-backup policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/01/1970 start-time=23:10:00
    /system scheduler add comment="" disabled=no interval=1d name=salvar-backup-automatico \
    on-event=salvar-backup policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/01/1970 start-time=23:00:00
    /system scheduler add comment="" disabled=no interval=6h name=salvar-log-automatico on-event=\
    salvar-log policy=reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=jan/01/1970 start-time=00:00:00
    /system scheduler add comment="" disabled=no interval=6h name=enviar-log-automatico on-event=\
    enviar-log policy=reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=jan/01/1970 start-time=00:10:00




    escolhi o gmail porque tem muito espaço de caixa de entrada e um recurso próprio que facilida a visualização dos logs sem a necessidade de baixar anexos. Isso faz muita diferença pois infelizmente o arquivo ".txt" que o routeros gera é no padrão unix, é muito complicado de visualizar no bloco de notas do windows.




    ao tentar configurar em tools = e-mail= smtp.gmail.com
    aparece um erro dizendo error in server! Ip address or ipv6 address expectd!!

    O que faço agora?

  14. #34
    Avatar de adrianoateky
    Ingresso
    Aug 2011
    Localização
    Braço do Norte - Santa Catarina
    Posts
    48

    Thumbs up Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    depois de atualizar mikrotik para versao 6.2 parou de funcionar backups e envios de email, alguem sabe o que mudou se foi o script ou a configuração de email,
    Agradeço!



  15. #35
    Avatar de adrianoateky
    Ingresso
    Aug 2011
    Localização
    Braço do Norte - Santa Catarina
    Posts
    48

    Red face Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Descobri o que mudou!

    /system backup save name=backup-mikrotik.backup
    :log info message="enviando backup por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="email" subject="backup-mikrotik-PopRouter1 $data $hora" file=backup-mikrotik.backup start-tls=yes

    antes tls=yes
    depois start-tls=yes

    Se fui útil agradeça!

  16. #36

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    desenterrando o tópico, estou tentando aqui, esta dando erro de conexão, o que pode ser ? será que alguém pode me passar as informações da configuração atualizada ? pois essa ai não ta indo... abraçoss



  17. #37

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Muito simples, quando para eu vou e pingo para o seguinte endereço: smtp.gmail.com, pego o ip
    que tá pingando e atualizo em Tools > Email. Só isso. Nesse exato momento está pingando em
    64.233.186.108, o meu ontem estava dando problema, atualizei e tudo voltou ao normal.

  18. #38

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Citação Postado originalmente por denilsoncosta Ver Post
    Muito simples, quando para eu vou e pingo para o seguinte endereço: smtp.gmail.com, pego o ip
    que tá pingando e atualizo em Tools > Email. Só isso. Nesse exato momento está pingando em
    64.233.186.108, o meu ontem estava dando problema, atualizei e tudo voltou ao normal.
    qual é a porta que você usa ? aqui continua dando erro, ja tentei dessa forma..



  19. #39

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Porta 587, um detalhe que considero importante é vc colocar como email e usuário, o email incluindo o @gmail, se for versão 6.28 marcar a opção Start Tls=yes e tirar essa opção de dentro do script de envio.

  20. #40

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Citação Postado originalmente por denilsoncosta Ver Post
    Porta 587, um detalhe que considero importante é vc colocar como email e usuário, o email incluindo o @gmail, se for versão 6.28 marcar a opção Start Tls=yes e tirar essa opção de dentro do script de envio.
    continua não funcionando, a versão do meu mk é 6.27, o que você acha que pode ser ?