Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico




  1. Citação Postado originalmente por ultralaser Ver Post
    Amigo, não consegui fazer funcionar com o seu script, mas encontrei um no forum do MK.com que funcionou, vou postar o code para quem precisar... Obrigado!
    -
    -
    -
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # EDIT YOUR DETAILS / CONFIGURATION HERE
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnsuser "YourChangeIPUserID"
    :global ddnspass "PASSWORD"
    :global ddnshost "MyRouterHostname.example.org"
    :global ddnsinterface "ether1"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip

    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }

    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }

    :if ([ :typeof $ddnsip ] = "nothing" ) do={

    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")

    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={

    :log info "DDNS: No changes necessary."

    }

    }






Tópicos Similares

  1. ajuda com script ddns
    Por gotch no fórum Redes
    Respostas: 2
    Último Post: 14-02-2007, 22:23
  2. ddns - so falta isso
    Por dogao no fórum Servidores de Rede
    Respostas: 1
    Último Post: 29-11-2005, 21:30
  3. ddns - me ajudem
    Por dogao no fórum Servidores de Rede
    Respostas: 0
    Último Post: 29-11-2005, 11:14
  4. Servidor DDNS para linux
    Por fred_m no fórum Servidores de Rede
    Respostas: 2
    Último Post: 25-05-2005, 08:05
  5. ddns-updates e ddns-update-style no Dhcp??????
    Por c4f0f0 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 13-06-2003, 10:29

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L