+ Responder ao Tópico



  1. #1

    Padrão Mikrotik-Backup por email

    Alguém sabe como envio 02 arquivos anexados no mesmo email .
    Exemplo , tenho um arquivo backup.backup e outro backup.rsc , e gostaria que esses arquivos ficassem anexados no mesmo email .

    Valeu...

  2. #2

    Padrão Re: Mikrotik-Backup por email

    Criar Script Chamado Backup e marcar todas as Policy o conteudo será:


    :global bkpname ([/system identity get name] . "-" . [/system clock get time]);
    :global assunto ("Backup-".[/system identity get name]);
    :global mailde "[email protected]";
    :global mailpara "[email protected]";
    :global ipserver [:resolve "mail.dominio.com.br"];
    :global texto ("Arquivo Gerado dia: " . [/system clock get date] . " as: " . [/system clock get time] . "hs");
    :global arquivobkp "yes";
    :global arquivorsc "yes";

    :log info "Iniciando Procedimento de backup automatico por: Gustavo Zanatta"

    :log info "Efetuando Backup"
    :if ($arquivobkp = "yes") do={/system backup save name=$bkpname}
    :if ($arquivorsc = "yes") do={/export file=$bkpname}

    :delay 10s

    :log info "Configurando e enviando e-mails"
    /tool e-mail set server=$ipserver from="$mailde"
    :if ($arquivobkp = "yes") do={/tool e-mail send to=$mailpara subject="$assunto-bkp" file="$bkpname.backup" body=$texto}
    :if ($arquivorsc = "yes") do={/tool e-mail send to=$mailpara subject="$assunto-rsc" file="$bkpname.rsc" body=$texto}

    :delay 10s
    :log info "E-mails enviado, removendo arquivos de Backup"

    :if ($arquivobkp = "yes") do={/file remove "$bkpname.backup"}
    :if ($arquivorsc = "yes") do={/file remove "$bkpname.rsc"}

    :log info "Backup Concluido"


    # Fim ------------------------------------

    Copiar e Colcar no New Terminal

    /system scheduler add name="Backup" start-date=dec/12/2009 start-time=00:00:01 interval=3d on-event="Backup" \
    policy=reboot,read,write,policy,test,password,sniff,sensitive


    -------------------

    Corra para o Abraço amigo



  3. #3

    Padrão Re: Mikrotik-Backup por email

    Acho , que não e bem isso que estou querendo veja o script que uso para o envio do Backup:

    /tool e-mail send [email protected] subject=backup_teste file=backup.backup

    na opção " file " é onde eu informo o arquivo a ser anexado ao email , justamente nessa opção tenho como adicionar alguma regra para colocar outro arquivo anexado?

  4. #4

    Padrão Re: Mikrotik-Backup por email

    Amigo presciso de ajuda nesse script o meu funcionou certino, mas o backup nao vai para o email vai somente o arquivo .rsc



  5. #5

    Padrão Re: Mikrotik-Backup por email

    Provavelmente lá em file o arquivo backup.backup não está criado , vc precisa criar o arquivo para poder enviar .....
    criar arquivo ,utilize esse script abaixo:
    /system backup save name=backup
    depois que gerar o arquivo vc utiliza o scrip de envio por email.

  6. #6

    Padrão Re: Mikrotik-Backup por email

    está criando sim mais ele nao vai ... somente o arquivo rsc cai no email (Por Favor me Ajude)

    :global bkpname ([/system identity get name] . "-" . [/system clock get time]);
    :global assunto ("Backup-".[/system identity get name]);
    :global mailde "[email protected]";
    :global mailpara "[email protected]";
    :global ipserver [:resolve "smtp.gmail.com"];
    :global texto ("Arquivo Gerado dia: " . [/system clock get date] . " as: " . [/system clock get time] . "hs");
    :global arquivobkp "yes";
    :global arquivorsc "yes";
    :log info "Iniciando Procedimento de backup automatico por: Leonardo Matera"
    :log info "Efetuando Backup"
    :if ($arquivobkp = "yes") do={/system backup save name=$bkpname}
    :if ($arquivorsc = "yes") do={/export file=$bkpname}
    :delay 10s
    :log info "Configurando e enviando e-mails"
    /tool e-mail set server=$ipserver from="$mailde"
    :if ($arquivobkp = "yes") do={/tool e-mail send to=$mailpara subject="$assunto-bkp" file="$bkpname.backup" body=$texto}
    :if ($arquivorsc = "yes") do={/tool e-mail send to=$mailpara subject="$assunto-rsc" file="$bkpname.rsc" body=$texto}
    :delay 10s
    :log info "E-mails enviado, removendo arquivos de Backup"
    :if ($arquivobkp = "yes") do={/file remove "$bkpname.backup"}
    :if ($arquivorsc = "yes") do={/file remove "$bkpname.rsc"}
    :log info "Backup Concluido"

    # Fim ------------------------------------



  7. #7

    Thumbs up Re: Mikrotik-Backup por email

    Citação Postado originalmente por leomacrosoft Ver Post
    está criando sim mais ele nao vai ... somente o arquivo rsc cai no email (Por Favor me Ajude)

    :global bkpname ([/system identity get name] . "-" . [/system clock get time]);
    :global assunto ("Backup-".[/system identity get name]);
    :global mailde "[email protected]";
    :global mailpara "[email protected]";
    :global ipserver [:resolve "smtp.gmail.com"];
    :global texto ("Arquivo Gerado dia: " . [/system clock get date] . " as: " . [/system clock get time] . "hs");
    :global arquivobkp "yes";
    :global arquivorsc "yes";
    :log info "Iniciando Procedimento de backup automatico por: Leonardo Matera"
    :log info "Efetuando Backup"
    :if ($arquivobkp = "yes") do={/system backup save name=$bkpname}
    :if ($arquivorsc = "yes") do={/export file=$bkpname}
    :delay 10s
    :log info "Configurando e enviando e-mails"
    /tool e-mail set server=$ipserver from="$mailde"
    :if ($arquivobkp = "yes") do={/tool e-mail send to=$mailpara subject="$assunto-bkp" file="$bkpname.backup" body=$texto}
    :if ($arquivorsc = "yes") do={/tool e-mail send to=$mailpara subject="$assunto-rsc" file="$bkpname.rsc" body=$texto}
    :delay 10s
    :log info "E-mails enviado, removendo arquivos de Backup"
    :if ($arquivobkp = "yes") do={/file remove "$bkpname.backup"}
    :if ($arquivorsc = "yes") do={/file remove "$bkpname.rsc"}
    :log info "Backup Concluido"

    # Fim ------------------------------------
    Vou testar esse script pelo Hotmail, para ver se obtenho sucesso rsrs

    Valeu!!!

  8. #8

    Padrão Re: Mikrotik-Backup por email

    fiz o teste e no log aparece a criação do backup o envio e o apagamento dos arquivos de backup, mas da error sending e-mail: abnormal termination (timeout)



  9. #9

    Padrão Re: Mikrotik-Backup por email

    Acompanhando...