+ Responder ao Tópico



  1. #1

    Padrão Como lidar com links assimetricos e unidirecionais

    Decidi fazer este post devido a crescente demanda por links unidirecionais. Os famosos links
    via sátelite que estão com preços bem acessíveis e alta disponibilidade. Entretanto
    existe um grande problema que é o fato dele somente funcionar para o download.
    Abaixo mostrarei como resolver este problema de uma forma bem simples.

    Vou simular um cenário onde possuimos 2 links, sendo:

    O "link A" é bi-direcional de 2MB e o "link B" unidirecional de 4MB.


    ### Primeiramente vamos definir as interfaces que serão usadas ###
    Interface do link A: LinkA
    Interface do link B: LinkB
    Interface dos clientes: Clientes

    ### Não precisaremos efetuar marcações de entrada e saida pois somente um link é bi-direcional ###

    ### Agora precisamos efetuar o balanceamento conforme a capacidade de cada link. Iremos usar a proporção 1/3, pois a soma dos links é 6MB e denominador comun é 2.
    Logo 6/2 = 3. Para isso###
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=Clientes new-connection-mark=A_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=Clientes new-connection-mark=B_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=Clientes new-connection-mark=B_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/2

    ### Neste caso não precisaremos alterar as rotas conforme as marcações das conexões pois somente um link é bi-direcional. ###

    ### Agora precisamos fazer uma correção nas conexões para que elas saiam pelo link A e voltem pelo link B ###
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=LinkA connection-mark=A_conn
    add chain=srcnat action=src-nat to-addresses=IP_do_LinkB out-interface=LinkA connection-mark=B_conn

    ### Por fim as tabelas de rotas ###
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LinkA scope=30 target-scope=10

    Obs.: Neste caso o FAILOVER não será possível, pois somente um dos links é bi-direcional.

    Então é isso ai pessoal. Espero ter ajudado e qualquer dúvida é só perguntar, ok?

    Abs.
    Última edição por guilhermeramires; 07-05-2010 às 15:50.

  2. #2

    Talking Re: Como lidar com links assimetricos e unidirecionais

    Parabéns!!! vai ajudar muita gente aqui....



  3. #3

    Padrão Re: Como lidar com links assimetricos e unidirecionais

    Não sei se aqui seria o lugar ideal para postar isso, mais percebi que você esta usando o loadbalance pcc, aqui tambem uso telefonica com 2 de 4megas, porem a oscilação não é tão grande, tipo 4 mega cai para 3 .. e não passa disso, porem eu adquiri recentemente net, por cable modem, de 20 megas porem ela oscila muito dia tem 20 outro tem 10 outro tem 6, e eu nao sei como devo ligar isso no pcc, tenho medo de colocar na rede e causa lentidão, eu devo considerar o link 20megas ou 4 megas igual aos outros para não cair tanto. obrigado no aguardo

  4. #4

    Padrão Re: Como lidar com links assimetricos e unidirecionais

    Levy,

    O que acontece é que o "net" utiliza um modem roteado. Quando você tem poucas conexões o modem responde bem e você terá um bom desempenho. Porém quando você compartilhar a conexão o modem não suporta tantas requisições e começa a entrar em modo "buffer". Consequentemente ele dropa muitos pedidos e acaba que você tem uma degradação do serviço. Andei lendo um pouco sobre esses modens e descobri que ele responde bem até 40 conexões simultâneas. Então sugiro que você disponibilize esse link somente pra um grupo seleto de clientes, ok?

    Abs.



  5. #5

    Padrão Re: Como lidar com links assimetricos e unidirecionais

    Citação Postado originalmente por guilhermeramires Ver Post
    Levy,

    O que acontece é que o "net" utiliza um modem roteado. Quando você tem poucas conexões o modem responde bem e você terá um bom desempenho. Porém quando você compartilhar a conexão o modem não suporta tantas requisições e começa a entrar em modo "buffer". Consequentemente ele dropa muitos pedidos e acaba que você tem uma degradação do serviço. Andei lendo um pouco sobre esses modens e descobri que ele responde bem até 40 conexões simultâneas. Então sugiro que você disponibilize esse link somente pra um grupo seleto de clientes, ok?

    Abs.
    Muito obrigado pela resposta, eu mesmo não estou satisfeito com o serviço deles a telefonica pelo menos aqui na região da baixada santista ta bem melhor, a net da muita oscilação, estou a procura de link dedicado para baixada santista, voce tem alguem contato para me ajudar?

  6. #6

    Padrão Re: Como lidar com links assimetricos e unidirecionais

    A principio lembrei desses ai. Não conheço sua região, mas fala com a moçada por ai que eles devem ter outras opções melhores pra links dedicados, ok? Essa solução pra links via satelite é pra último caso.

    Amaz
    PrimeNet - Internet Via Satelite para todo Brasil
    Hispamar
    Última edição por guilhermeramires; 07-05-2010 às 15:43.



  7. #7

    Padrão Re: Como lidar com links assimetricos e unidirecionais

    Obrigado Guilherme, mandei um email para PrimeNet, para ver os custo. Obrigado t+

  8. #8

    Padrão Re: Como lidar com links assimetricos e unidirecionais

    Citação Postado originalmente por mktguaruja Ver Post
    Obrigado Guilherme, mandei um email para PrimeNet, para ver os custo. Obrigado t+
    Posta aqui pra gente os valores quando conseguir.



  9. #9

    Padrão Re: Como lidar com links assimetricos e unidirecionais

    Citação Postado originalmente por guilhermeramires Ver Post
    A principio lembrei desses ai. Não conheço sua região, mas fala com a moçada por ai que eles devem ter outras opções melhores pra links dedicados, ok? Essa solução pra links via satelite é pra último caso.

    Amaz
    PrimeNet - Internet Via Satelite para todo Brasil
    Hispamar
    Conhece algumas destas empresas? Se sim, qual seria a melhor?

  10. #10

    Padrão Re: Como lidar com links assimetricos e unidirecionais

    A primenet, 2 megas quase 7mil eu achei um preço muito exagerado hehe
    t+