+ Responder ao Tópico



  1. #1

    Padrão vnc com pcc

    Olá amigos , estou tentando acessar uma maquina da minha rede com vnc,
    tenho dois adsl em uma rb450 com pcc e modens bridge, porém com as regras abaixo nao estou conseguindo,

    IP > Firewall > NAT
    General
    chain: dst-nat
    Dst-address: ip da operadora
    Protocol: tcp
    dst-port: 5800-5900
    In.Interface: por onde entra a internet

    Action
    Action: dst-nat
    To-Address: IP local da maquina
    To-Port: 5800-5900

    minha duvida é: em Dst-address coloquei o ip da operadora, em in-interface setei a ether que esta relacionada com o ip setado em dst-address.

    porem nao estou conseguindo o acesso , o que posso fazer para concertar essa regra, pois eu acho que deve estar errada pelo fato de eu usar o PCC.

  2. #2

    Padrão Re: vnc com pcc

    faz da seguinte forma...cria uma rota padrao sem marcao de conexoes...vai em ip firewall mangle e cria uma regra prerouting com src-address no ip q vc quer acessar action accept...coloca antes das regras de balanceamento...assim esse ip vai sair sempre pela rota padrao...ai assim vc acessa de fora...vc acessa de fora...tem outras formas...mas pra mim essa eh a mais facil...
    Última edição por terencerocha; 24-05-2010 às 16:56. Razão: faltou action



  3. #3

    Padrão Re: vnc com pcc

    Citação Postado originalmente por terencerocha Ver Post
    faz da seguinte forma...cria uma rota padrao sem marcao de conexoes...vai em ip firewall mangle e cria uma regra prerouting com src-address no ip q vc quer acessar action accept...coloca antes das regras de balanceamento...assim esse ip vai sair sempre pela rota padrao...ai assim vc acessa de fora...vc acessa de fora...tem outras formas...mas pra mim essa eh a mais facil...
    Criei a rota padrao mas ainda nao consegui, vc poderia me dar uma luz onde estou errando nessas regras?

    /ip firewall mangle
    add action=accept chain=prerouting comment="" disabled=no in-interface=ether1 src-address=\
    200.140.94.59
    /ip firewall nat
    add action=dst-nat chain=dstnat comment="" disabled=no dst-address=200.140.94.59 dst-port=5800-5900 \
    in-interface=ether1 protocol=tcp to-addresses=10.1.1.2 to-ports=5800-5900

    obrigado.

  4. #4

    Padrão Re: vnc com pcc

    Citação Postado originalmente por wesleydialmeida Ver Post
    Criei a rota padrao mas ainda nao consegui, vc poderia me dar uma luz onde estou errando nessas regras?

    /ip firewall mangle
    add action=accept chain=prerouting comment="" disabled=no in-interface=ether1 src-address=\
    200.140.94.59
    /ip firewall nat
    add action=dst-nat chain=dstnat comment="" disabled=no dst-address=200.140.94.59 dst-port=5800-5900 \
    in-interface=ether1 protocol=tcp to-addresses=10.1.1.2 to-ports=5800-5900

    obrigado.
    na regra do mangle...vc ta dizendo q qdo este ip entrar pela ether1...q deve ser sua interface de saida...na verdade esse ip sai...nao entra...tira a interface...



  5. #5

  6. #6

    Padrão Re: vnc com pcc

    olá terencerocha, eu estou com o mesmo problema... quero accesar a meu RB 450G e a meu servidor Mikrotik desde um ponto remoto, anexo uma imagem para que se aprecie melhor o que se requer... as setas em azul representam o caminho que se deve seguir para poder accesar, agradecere os comentários...

    Clique na imagem para uma versão maior

Nome:	         ACCESO REMOTO A SERVER MIKROTIK CON IP.jpg
Visualizações:	54
Tamanho: 	52,0 KB
ID:      	11765



  7. #7

    Padrão Re: vnc com pcc

    mesma coisa do anterior...so vc tirar o ip do servidor do balanceamento...e um macete...qdo vc tentar acessar aquele ip pela porta 8292...direcionar pra porta 8291 do servidor...assim vc acessa os dois externamente...usando portas diferentes...

  8. #8

    Padrão Re: vnc com pcc

    Citação Postado originalmente por terencerocha Ver Post
    na regra do mangle...vc ta dizendo q qdo este ip entrar pela ether1...q deve ser sua interface de saida...na verdade esse ip sai...nao entra...tira a interface...
    Ola terense, ainda to batendo cabeça para resolver este problema que para muitos e tao simples, mas para min ta muito dificil, eu ate ja coloquei a maquina que eu quero acessar direto no modem excluindo assim o mikrotik, e o vnc acessou legal.

    mas nao to conseguindo encaixar essas regras,

    veja onde eu possa estar errando, para a rota padrao vou aceitar e prerotear os pacotes que tem destino (dst-address) ao ip setado, e nao seto in-interface por onde este link esta entrando.

    ja as regras de direcionamento sao as mesma e nao muda nada, correto?
    Última edição por wesleydialmeida; 26-05-2010 às 16:12.



  9. #9

    Padrão Re: vnc com pcc

    Olá, neste caso que os modem ADSL são ruteados há que fazer uma configuracion especial no router ADSL que é o default?

    A ip publica é dinamica em meu caso, há que usar o script no mikrotik para actualizar a ip publica por exemplo criando uma conta em ip change.com?

    saludos

  10. #10

    Padrão Re: vnc com pcc

    eh so colocar uma regra no route
    /ip route add dst-address=0.0.0.0/0 gateway=interface_do_pppoe_pelo_qual_vc_vai_accessar_o_vnc

    e no mangle colocando ela em primeiro lugar

    /ip firewall mangle add chain=prerouting src-address=ip_da_maquina_que_voce_quer_acessar action=accept

    ps. mais mastigado q isso impossivel...



  11. #11

    Padrão Re: vnc com pcc

    Citação Postado originalmente por terencerocha Ver Post
    eh so colocar uma regra no route
    /ip route add dst-address=0.0.0.0/0 gateway=interface_do_pppoe_pelo_qual_vc_vai_accessar_o_vnc

    e no mangle colocando ela em primeiro lugar

    /ip firewall mangle add chain=prerouting src-address=ip_da_maquina_que_voce_quer_acessar action=accept

    ps. mais mastigado q isso impossivel...
    Ola terense, gostaria de lhe agradecer pela ajuda, agora eu consegui fazer o acesso, a unica coisa que fiz foi criar a ultima regra que vc postou do mangle, mas o engraçado, e que depois que eu consegui o acesso, desativei a regra, e testei novamente o acesso, e o mesmo continuou funcionando. mas e isso ai.

    Obrigado.

  12. #12

    Padrão Re: vnc com pcc

    Posta como ficaram as regras no final.