+ Responder ao Tópico



  1. #1

    Padrão Alternativa para PPPoE + COA no mikrotik

    Pessoal, utilizo pppoe para os clientes,e gostaria de proporcionar uma velocidade maior durante a madrugada, mas pelo que ja pesquisei precisaria utilizar a "extensao" COA do freeradius a qual o mikrotik nao tem suporte.

    Diferentemente das queues normais, os clientes pppoe alem dos que ja estiverem conectados ainda precisarei adicionar valores em queues das novas conexoes que acontecerem durante a madrugada. Pensei em alguns scripts mas nao ajudaram muito.

    Alguem tem alguma dica de uma maneira alternativa de fazer isso?

    Obrigado

  2. #2

    Padrão Re: Alternativa para PPPoE + COA no mikrotik

    E ai amigo, beleza? Rapaz, não é necessário utilizar outra ferramenta além do "script" e do "scheduler" do MK.

    Acesse esste tópipo: https://under-linux.org/f226/control...orario-138822/

    As regras são bem semelhantes.

    Qualquer coisa, posta ai. Fica com Deus.



  3. #3

    Padrão Re: Alternativa para PPPoE + COA no mikrotik

    Então eu li esse tópico, alterar a queue dos usuários já conectados tranquilo, o problema é alterar os que irão conectar durante a madrugada por exemplo, eles já teria que conectar e pegar a queue "aumentada", mas como utilizamos pppoe+radius a configuração nele sempre acaba sendo estática.
    Daí teria que ficar rodando o mesmo script a cada X minutos por exemplo.

  4. #4

    Padrão Re: Alternativa para PPPoE + COA no mikrotik

    Não, o seu queue não é feito pelo MK? Então, ele pode estar conectado, ou desconectado, sem problema, a conexão vai aumentar na hora que o script rodar. Não é necessário desconectar ou fazer qualquer outra coisa. O controle no MK é em tempo real.

    Seu queue é automático ou estático?



  5. #5

    Padrão Re: Alternativa para PPPoE + COA no mikrotik

    A queue é dinâmica.
    O radius informa ao Mikrotik qual valor colocar através dos dicionários do freeradius.

  6. #6

    Padrão Re: Alternativa para PPPoE + COA no mikrotik

    Fácil....

    Vc vai criar 2 sripts por velocidade
    1 Script_Libera Banda

    /ppp profile set [find name="1200klink1"] rate-limit="0k/0k"; :foreach i in=[/ppp secret find profile="1200klink1"] do={/queue simple remove [find name=("<pppoe-" . [/ppp secret get $i name] . ">")]};

    2 Controla Banda

    /ppp profile set [find name="1200klink1"] rate-limit="200k/1200k 0k/0k 0k/0k 0/0 8 0k/0k"; :foreach i in=[/ppp secret find profile="1200klink1"] do={/ppp active remove [find name=[/ppp secret get $i name]]};

    Daí é só agendar a execução de cada script
    eu libero a banda dpois da meia noite
    e controlo dpois das 7 da manhã.
    Detalhe... sempre que ele libera ou bloqueia... ele derruba todo mundo para q já voltem sem controle de banda. e dá pra aumentar a banda mudando de 200k pra 600k ou liberar geral...



  7. #7

    Padrão Re: Alternativa para PPPoE + COA no mikrotik

    Citação Postado originalmente por jamerfay Ver Post
    Fácil....

    Vc vai criar 2 sripts por velocidade
    1 Script_Libera Banda

    /ppp profile set [find name="1200klink1"] rate-limit="0k/0k"; :foreach i in=[/ppp secret find profile="1200klink1"] do={/queue simple remove [find name=("<pppoe-" . [/ppp secret get $i name] . ">")]};

    2 Controla Banda

    /ppp profile set [find name="1200klink1"] rate-limit="200k/1200k 0k/0k 0k/0k 0/0 8 0k/0k"; :foreach i in=[/ppp secret find profile="1200klink1"] do={/ppp active remove [find name=[/ppp secret get $i name]]};

    Daí é só agendar a execução de cada script
    eu libero a banda dpois da meia noite
    e controlo dpois das 7 da manhã.
    Detalhe... sempre que ele libera ou bloqueia... ele derruba todo mundo para q já voltem sem controle de banda. e dá pra aumentar a banda mudando de 200k pra 600k ou liberar geral...
    Muito boa sua solução foi parecido com o que estamos testando aqui, mas por algumas mudanças no sistema precisou ser um pouco diferente vou postar depois aqui.

    Obrigado pela dica.