+ Responder ao Tópico



  1. #1

    Padrão Load Balance a cada IP que conecta, tem com ?

    Bem uso aqui o LB por grupo, mas eu tava querendo fazer o seguinte nao sei se e possivel mas se for por favor postem pra mim, o seguinte a cada novo IP que conectase ou a cada cleinte que entrase ele escolheria um link,

    EX: cliente 1 entra vai para o link 1
    cliente 2 entra vai para o link 2
    cliente 3 entra vai para o link 1
    cliente 4 entra vai para o link 2

    E assim sucessivamente, essa escolhe seria automatica feita pelo mikrotik

    Abraço e bom jogo at+++

  2. #2

    Padrão Re: Load Balance a cada IP que conecta, tem com ?

    Eu usei foi setando manualmente o cliente para o link desejado, que no caso eu segui o tutorial que tem aqui no under.

    link: Tutoriais/Wireless/Load Balance Free - UnderLinux Wiki
    Última edição por mktguaruja; 16-06-2010 às 10:37.



  3. #3

    Padrão Re: Load Balance a cada IP que conecta, tem com ?

    É possível sim....

    /ip firewall address-list
    add address=172.16.0.1 comment="Cliente1" disabled=no list=pppoe-out1
    add address=172.16.0.2 comment="Cliente2" disabled=no list=pppoe-out2
    add address=172.16.0.3 comment="Cliente3" disabled=no list=pppoe-out1
    add address=172.16.0.4 comment="Cliente4" disabled=no list=pppoe-out2
    /ip firewall connection tracking
    set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
    tcp-close-wait-timeout=10s tcp-established-timeout=1d \
    tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
    tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
    /ip firewall filter
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=pppoe-out1 passthrough=no src-address-list=pppoe-out1
    add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=pppoe-out2 passthrough=no src-address-list=pppoe-out2
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    172.16.0.0/16
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    /ip firewall service-port
    set ftp disabled=no ports=21
    set tftp disabled=no ports=69
    set irc disabled=no ports=6667
    set h323 disabled=no
    set sip disabled=no ports=5060,5061
    set pptp disabled=no

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    pppoe-out1 routing-mark=pppoe-out1 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    pppoe-out2 routing-mark=pppoe-out2 scope=30 target-scope=10
    Última edição por kleberbrasil; 16-06-2010 às 08:26.

  4. #4

    Padrão Re: Load Balance a cada IP que conecta, tem com ?

    Muito bom... parabens pela resposta, isso ajuda muito amigão..

    Citação Postado originalmente por kleberbrasil Ver Post
    É possível sim....

    /ip firewall address-list
    add address=172.16.0.1 comment="Cliente1" disabled=no list=pppoe-out1
    add address=172.16.0.2 comment="Cliente2" disabled=no list=pppoe-out2
    add address=172.16.0.3 comment="Cliente3" disabled=no list=pppoe-out1
    add address=172.16.0.4 comment="Cliente4" disabled=no list=pppoe-out2
    /ip firewall connection tracking
    set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
    tcp-close-wait-timeout=10s tcp-established-timeout=1d \
    tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
    tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
    /ip firewall filter
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=pppoe-out1 passthrough=no src-address-list=pppoe-out1
    add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=pppoe-out2 passthrough=no src-address-list=pppoe-out2
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    172.16.0.0/16
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    /ip firewall service-port
    set ftp disabled=no ports=21
    set tftp disabled=no ports=69
    set irc disabled=no ports=6667
    set h323 disabled=no
    set sip disabled=no ports=5060,5061
    set pptp disabled=no

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    pppoe-out1 routing-mark=pppoe-out1 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    pppoe-out2 routing-mark=pppoe-out2 scope=30 target-scope=10



  5. #5

    Padrão Re: Load Balance a cada IP que conecta, tem com ?

    Kleber vlw mesmo, eu vou colocar em teste sempre quiz fazer algo assim mais nunca obtive exito =D.

    vlw mesmo

    Citação Postado originalmente por kleberbrasil Ver Post
    É possível sim....

    /ip firewall address-list
    add address=172.16.0.1 comment="Cliente1" disabled=no list=pppoe-out1
    add address=172.16.0.2 comment="Cliente2" disabled=no list=pppoe-out2
    add address=172.16.0.3 comment="Cliente3" disabled=no list=pppoe-out1
    add address=172.16.0.4 comment="Cliente4" disabled=no list=pppoe-out2
    /ip firewall connection tracking
    set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
    tcp-close-wait-timeout=10s tcp-established-timeout=1d \
    tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
    tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
    /ip firewall filter
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=pppoe-out1 passthrough=no src-address-list=pppoe-out1
    add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=pppoe-out2 passthrough=no src-address-list=pppoe-out2
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    172.16.0.0/16
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    /ip firewall service-port
    set ftp disabled=no ports=21
    set tftp disabled=no ports=69
    set irc disabled=no ports=6667
    set h323 disabled=no
    set sip disabled=no ports=5060,5061
    set pptp disabled=no

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    pppoe-out1 routing-mark=pppoe-out1 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    pppoe-out2 routing-mark=pppoe-out2 scope=30 target-scope=10

  6. #6

    Padrão Re: Load Balance a cada IP que conecta, tem com ?

    Nessas Regras ficaria a escolha automatica ?

    Exemplo:

    cliente 1 entra vai para o link 1
    mas na proxima conexão dele e pode ir para o link 2 ou 3 dependendo de quantos links eu tiver ??
    Última edição por juninhobiuuu; 16-06-2010 às 12:20.



  7. #7

    Padrão Re: Load Balance a cada IP que conecta, tem com ?

    Citação Postado originalmente por juninhobiuuu Ver Post
    Nessas Regras ficaria a escolha automatica ?

    Exemplo:

    cliente 1 entra vai para o link 1
    mas na proxima conexão dele e pode ir para o link 2 ou 3 dependendo de quantos links eu tiver ??
    Vc pode colocar quantos links vc quiser, basta seguir a regra que postei, ai vc cadastra todos os IP`s no address-list e depois gera um pool para eles e configura o DHCP... Simples! cada IP usará o gateway foi atribuidos lah no adress list... Tem que seguir toda regra, adress list é só um detalhe... eu tenho um RB 493 com 5 adsl funcionando assim.

    Abraços.
    Última edição por kleberbrasil; 17-06-2010 às 07:38.

  8. #8

    Padrão Re: Load Balance a cada IP que conecta, tem com ?

    Assim mas ae eu teria que usar DHCP visto que eu uso IP fixo em todos os meus clientes, como ficaria ?



  9. #9
    Eng. Telecomunicações Avatar de pkmc
    Ingresso
    May 2007
    Localização
    Foz do Iguaçu - PR
    Posts
    996
    Posts de Blog
    1

    Red face Re: Load Balance a cada IP que conecta, tem com ?

    Antes de mais nada gostaria de pedir desculpas por estar metendo o nariz nos post's aqui relacionados em MK, mas como o espírito do fórum é compartilhar conhecimentos e soluções, vamos lá

    Balaceamento para até 4 Links sem dor de cabeça
    Para aqueles que tem problemas para balancear sua linhas dedicadas, ou ainda ADSL, até 4 . Indico o balanceador da TP-LINK - TL-R488T, extremamente estável, possui um bom processador interno de 533Mhz, e tambem se ajusta às variações dos link's principalmente ADSL ! Tambem possui inhumeros recursos para redirecionamento de portas à link's, possui DHCP. Excelente produto ja usei em diversas situações e todos até hoje sem problemas !

  10. #10

    Padrão Re: Load Balance a cada IP que conecta, tem com ?

    Citação Postado originalmente por pkmc Ver Post
    Antes de mais nada gostaria de pedir desculpas por estar metendo o nariz nos post's aqui relacionados em MK, mas como o espírito do fórum é compartilhar conhecimentos e soluções, vamos lá

    Balaceamento para até 4 Links sem dor de cabeça
    Para aqueles que tem problemas para balancear sua linhas dedicadas, ou ainda ADSL, até 4 . Indico o balanceador da TP-LINK - TL-R488T, extremamente estável, possui um bom processador interno de 533Mhz, e tambem se ajusta às variações dos link's principalmente ADSL ! Tambem possui inhumeros recursos para redirecionamento de portas à link's, possui DHCP. Excelente produto ja usei em diversas situações e todos até hoje sem problemas !
    Só ouço falar bem desse equipamento.



  11. #11
    Eng. Telecomunicações Avatar de pkmc
    Ingresso
    May 2007
    Localização
    Foz do Iguaçu - PR
    Posts
    996
    Posts de Blog
    1

    Padrão Re: Load Balance a cada IP que conecta, tem com ?

    Citação Postado originalmente por kleberbrasil Ver Post
    Só ouço falar bem desse equipamento.
    Tb gosto muito dele, pena que não tenha com mais portas.
    Vou tentar resolver esse problema ligando em cascata, assim que usar por um período posto os resultados !