+ Responder ao Tópico



  1. #1

    Padrão Definir rotas de saida

    Ola a todos.
    Estou com uma duvida, tenho atualmente um link de 1MB velox e tenho muito acesso a um determinado site, utilizo uma RB 450 com MK4.10 adquiri mais 1 link, e preciso utilizar esse novo link apenas para 3 sites ou seja preciso redirecionar todas as requisicoes para os saite1 site2 e site3 para sair no link2.
    Atualmente utilizo as porta ether5 para o velox(pppoe) ether4 para o novo link ip fixo e a ether3 para a rede interna 192.168.1.254. nao utilizo proxy ainda apenas redirecionamento.
    add action=masquerade chain=srcnat comment=NAT disabled=no out-interface=\
    Velox1.
    Des de já agradeco a todos.

  2. #2

    Padrão Re: Definir rotas de saida

    Olá amigo pesquizando aqui no forum irá encontrar tudo sobre isso...... veja esse topico poder ser que te ajude.. https://under-linux.org/f227/pcc-bal...r-m4d3-131343/



  3. #3

    Padrão Re: Definir rotas de saida

    Muitissimo obrigado pela sua atençao Luspmais.
    Eu procurei e ainda estou procurado no historico do forum, so que nao consegui resolver ainda.
    Nao pretendo fazer balanceamento dos link's, apenas utilizar um segundo link para 3 sites diferentes, caso contrario o link deve ficar ocioso, sempre que for utilizar solicitado um dos 3 sites o MK sair pelo link2. o restante das solicitacoes sair normalmente pelo link1(velox PPPO3).
    caso alguem tenha algum link para indicar, material para leitura ou mesmo uma luz ajudaria muito .
    Obrigado a todos novamente.

  4. #4

    Padrão Re: Definir rotas de saida

    olá,

    amigo no seu caso vc vai ter q marcar os pacotes das requisições para os sites que vc quer que sai por esse link, nesses pacotes vc coloca uma marca de rota para a rota do link, muito simples de ser feito! vc pode fazer tudo pelo mangle.

    espero ter ajudado.



  5. #5

    Padrão Re: Definir rotas de saida

    concordo com o Jaos.

  6. #6

    Padrão Re: Definir rotas de saida

    Como faço isso pelo mangle aqui nao to conseguindo acessar Globo.com nem Yahoo



  7. #7

    Padrão Re: Definir rotas de saida

    tem tres maneiras de fazer isso
    onde estiver vermelho onde vc vai fazer as alterações

    opcao 1:

    abre IP > Route > + > em "destination" coloca o ip do site> e no "Gatway" coloca o gatway do link que vc quer que ele passe, depois so da ok, ja que sao poucos sites eu recomento essa opção, mas se tiver muitos sites vamos pra opção 2 e 3.

    Opcao 2:

    / ip firewall mangle
    add chain=prerouting content=uol action=mark-routing new-routing-mark=sites passthrough=yes comment="" disabled=no
    add chain=prerouting content=globo action=mark-routing new-routing-mark=sites passthrough=yes comment="" disabled=no

    / ip route
    add dst-address=0.0.0.0/0 gateway=SEU GATWAY scope=255 target-scope=10 \
    routing-mark=sites comment="" disabled=no

    Opção 3:
    / ip firewall mangle
    add chain=prerouting dst-address-list=lista_sites action=mark-routing \
    new-routing-mark=sites passthrough=yes comment="" disabled=no

    / ip firewall address-list
    add list=lista_sites address=IP DO SITE1 comment="SITES" disabled=no
    add list=lista_sites address=IP DO SITE2 comment="SITES" disabled=no
    add list=lista_sites address=IP DO SITE3 comment="SITES" disabled=no

    / ip route
    add dst-address=0.0.0.0/0 gateway=SEU GATWAY scope=255 target-scope=10 \
    routing-mark=sites comment="" disabled=no

    qualquer duvida poste ai.

  8. #8

    Padrão Re: Definir rotas de saida

    Amigo nenhuma das opções deu certo.
    Aqui estou usando a seguinte estrutura mk Balance PCC 3.30 com dois links adsl mais RB 433 com hostpost
    Ficando assim

    link1 adsl 4 mbps--
    mk balance--- link ptp --- rb 433 --- clientes
    link2 adsl 4 mbps--

    Obs: O Gataway dos clientes é o ip da RB



  9. #9

    Padrão Re: Definir rotas de saida

    Desculpe pela demora, tive 3 milhoes de problemas.
    Rss mudei algumas coisa mas atualmente tenho a atual estrutura DHCP esta em outro equipamento, nao utilizo proxy no MK apenas mascaramento
    ether1= rede interna 192.168.1.254
    ether2=velox pppoe
    ether3=link com ip. gw e dns de um frame relay para acesso a 3 sites com final extranet.caixa
    os sites seriam site1.extranet.caixa site2.extranet.caixa e site3.extranet.caixa.
    Para esses sites tem que usar o dns da caixa.
    Se puder me indicar algum link com conteudo para ler ajudaria muito.
    Obrigado a todos.

  10. #10

    Padrão Re: Definir rotas de saida

    Ola isacloko
    Parece que sua dica vai servir para mim mas antes mesmo de testar gostaria de tirar uma duvida, como o mk vai saber que para acessar o site1 ou site 2 ele deve utilizar o dns especifico da caixa? pq no meu caso para acessar o site1.extranet.caixa eu devo utilizar o dns deles caso contrario eu nao consigo acessar o site que preciso.
    Muito obrigado pela atenção de todos.



  11. #11

    Padrão Re: Definir rotas de saida

    Apos varias tentativas e tentar as dicas do iscaloko, ainda nao funcionou.
    Chegou proximo foi a 1 opcao, no navegador usando direto o ip do site (nao usando o dns)
    ja segui o artigo
    Linux: Balanceamento de carga com 2 links no MikroTik [Artigo]
    no artigo a cima ele nao menciona configuracoa de dns, que no meu caso nao pode utilizar o mesmo dns da internet ou seja tem que usar o dns da propria caixa.
    vejam minhas configuracoes e se alguem puder dar mais alguma sugestao ajudaria muito

    eth1=rede local ip 192.168.1.254
    eth2=adsl/router ip 192.168.200.250 /gw 192.168.200.254 /dns 192.168.200.254
    eth3=caixa ip 172.23.22.74 /gw 172.23.22.74 /dns 172.16.32.5

    MikroTik RouterOS 4.13 RB 450

    [[email protected]] /ip address> print
    Flags: X - disabled, I - invalid, D - dynamic
    # ADDRESS NETWORK BROADCAST INTERFACE


    0 192.168.1.254/24 192.168.1.0 192.168.1.255 ether1


    1 172.23.22.74/29 172.23.22.72 172.23.22.79 ether3


    2 192.168.200.250/24 192.168.200.0 192.168.200.255 ether2

    [[email protected]] /ip route> print
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    # DST-ADDRESS PREF-SRC GATEWAY DISTANCE
    0 A S ;;; GW Caixa
    0.0.0.0/0 172.23.22.73 1
    1 A S ;;; Internet
    0.0.0.0/0 192.168.200.254 1
    2 ADC 172.23.22.72/29 172.23.22.74 ether3 0
    3 ADC 192.168.1.0/24 192.168.1.254 ether1 0
    4 ADC 192.168.200.0/24 192.168.200.250 ether2 0
    [[email protected]] /ip route> print
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    # DST-ADDRESS PREF-SRC GATEWAY DISTANCE
    0 A S ;;; GW Caixa
    0.0.0.0/0 172.23.22.73 1
    1 A S ;;; Internet
    0.0.0.0/0 192.168.200.254 1
    2 ADC 172.23.22.72/29 172.23.22.74 ether3 0
    3 ADC 192.168.1.0/24 192.168.1.254 ether1 0
    4 ADC 192.168.200.0/24 192.168.200.250 ether2 0
    [[email protected]] /ip route> ..
    [[email protected]] /ip> dns
    [[email protected]] /ip dns> print
    servers: 172.16.32.5,192.168.200.254,8.8.8.8
    allow-remote-requests: yes
    max-udp-packet-size: 512
    cache-size: 4048KiB
    cache-max-ttl: 1w
    cache-used: 29KiB
    [[email protected]] /ip firewall nat> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; Nat Caixa
    chain=srcnat action=masquerade out-interface=ether3

    1 ;;; Nat Internet
    chain=srcnat action=masquerade out-interface=ether2
    [[email protected]] /ip firewall nat> ..
    [[email protected]] /ip firewall> mangle
    [[email protected]] /ip firewall mangle> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; Marcacao ciweb.extranet.caixa
    chain=prerouting action=mark-routing new-routing-mark=ciweb passthrough=yes content=ciweb.extranet.caixa

  12. #12

    Padrão Re: Definir rotas de saida

    Amigo Evite esse Tipo de Post
    se deseja Acompanhar oTopico Assine ele e Faça o Acompanhamento
    em caso de alguma Duvida ai você faz o Post
    ok
    espero que me entenda estamos tentando Organizar essas coisas aqui no Fórum
    t+
    Citação Postado originalmente por agrinfo Ver Post
    concordo com o Jaos.



  13. #13

    Padrão Re: Definir rotas de saida

    concordo!