+ Responder ao Tópico



  1. #1

    Padrão Montar script no mikrotik

    Pessoal,
    Já pesquisei na internet mas não encontrei nada de muito substancial.

    Preciso montar um script de teste de rede (watchdog) para rodar num servidor com mikrotik que tenha as seguintes funções:

    1) Pingar nos ips dos hosts lidos de arquivo txt
    2) Enviar o resultado do teste para um site

    No Linux, eu tenho um script que está programado para ser executado a cada minuto. Ele lê o arquivo texto, executa os pings e accessa uma página php usando o CURL para enviar o resultado dos testes.

    Mas não vi como reproduzir este script no mikrotik.

    Não gostaria de usar o netwath do MK. Queria que ficasse tudo dentro do script.
    Alguém tem alguma idéia ????

  2. #2

    Padrão Re: Montar script no mikrotik

    Olá amigo..
    usa o scheduler para agendar isso que funciona ....


    o script tuh sabe fazer neh??

    dae tuh pega em Scheduler e agenda o tempo que tu quer pra rodar isso..

    espero ter ajudado ...



  3. #3

    Padrão Re: Montar script no mikrotik

    Marcellus,

    Existem processos mais eficientes e mais simples que esses que você tá propondo. Um deles é o The Dude. Ele pode ser instalado em máquina ou RB. Além das estátisticas de ping ele te dá um monte de informação importante via snmp. Existe o Rosinfo também, porém exige mais conhecimento pra ser instalado. Instala o The Dude por esse link: MikroTik Routers and Wireless

    Ele é bem simples de usar e pode ser visualizado via web inclusive, ok?

    Abs.

  4. #4

    Padrão Re: Montar script no mikrotik

    Sim, conheço o The Dude! Ele é bom.

    Mas preciso enviar o resultado destes testes a partir do MK para um banco de dados. No Linux consigo fazer usando curl dentro de um script simples.

    Imagino que temos uma solução com recursos diferenciados e mais simples de implantar para a maioria dos usuários do mikrotik. Nosso sistema já está integrado com as operadoras para enviar alertas por SMS, permite realizar consultas de status por sms e ainda aciona o hardware de Boot Remoto para reiniciar equipamentos a distancia.

    Por isso não posso usar o The Dude!



  5. #5

    Padrão Re: Montar script no mikrotik

    O novo The Dude na versão 4(beta) está rodando em cima de sqlite3. Possivelmente fique mais fácil pra você coletar esses dados. Eu não aconselho muito o uso do netwatch pra essa situação. Ele não tem os "critérios" do Dude e inclusive os recursos pra customização são mínimos. Isso me gerou uma conta de SMS no valor de R$ 400,00 em uma semana de uso.

    Você pode também usar o protocolo snmp, através do linux instalar o snmpwalk e snmpget pra coletar informações via linha de comando. Então você trata conforme sua necessidade e continua fazendo seus envios, ok?

    Abs.

  6. #6

    Padrão Re: Montar script no mikrotik

    Amigos, estou tentando um script para automatizar a mudanda na velocidade dos clientes apo certo período, mas por enquanto sem sucesso...!
    Seguindo +/- o MK wiki, estou tentando algo assim:

    :local myVar
    /queue simple
    :for i from=2 to= 7 do={
    :if ([/queue simple find target-addresses=("176.225.2" . $i)] != "") do={
    set max-limit=320000/640000
    }
    }

    Mas, não esta dando certo.. A versão do MK é a 4.10! Alguem poderia me dar uma força?!
    Última edição por fravin; 04-11-2010 às 14:28.