Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. blz...peguei o script e está assim:


    #!/bin/sh

    LUSCA_BIN="/usr/local/lusca/sbin/squid"
    LUSCA_COREDIR="/usr/local/lusca/var/logs"
    LUSCA_START_FLAGS="-D"

    ulimit -n 65535

    case $1 in
    'start')
    echo "Starting Lusca.."
    cd ${LUSCA_COREDIR} && ${LUSCA_BIN} ${LUSCA_START_FLAGS}
    exit 0
    ;;
    'stop')
    echo "Stopping Lusca.."
    ${LUSCA_BIN} -k shutdown
    sleep 60
    exit 0
    ;;
    'rotate')
    echo "Rotating Lusca Logfiles.."
    ${LUSCA_BIN} -k rotate
    exit 0
    ;;
    'reconfigure')
    echo "Reconfiguring Lusca.."
    ${LUSCA_BIN} -k reconfigure
    exit 0
    ;;
    *)
    echo "$0: {start|stop|rotate|reconfigure}"
    exit 1
    ;;
    esac
    exit 0
    mas no scrip do ./configure acima não tem esse diretório do lusca_bin onde posso achar?

    os diretórios que preciso saber onde estão:


    LUSCA_BIN="/usr/local/lusca/sbin/squid"
    LUSCA_COREDIR="/usr/local/lusca/var/logs"
    LUSCA_START_FLAGS="-D"


    com o nome lusca não achei nenhum...deve tá com algo sobre squid pois só consigo iniciar ele com o comando:


    squid -d 10 -D -N -F -X -f /etc/squid/squid.conf &

  2. Consegui!!!

    consegui...adaptei o script que tem dentro do diretório de compilação:


    #!/bin/sh

    LUSCA_BIN="/usr/sbin/squid"
    LUSCA_COREDIR="/var/log/squid/"
    LUSCA_START_FLAGS="-D"

    ulimit -n 65535




    case $1 in
    'start')
    echo "Starting Lusca.."
    cd ${LUSCA_COREDIR} && ${LUSCA_BIN} ${LUSCA_START_FLAGS}
    exit 0
    ;;
    'stop')
    echo "Stopping Lusca.."
    ${LUSCA_BIN} -k shutdown
    sleep 60
    exit 0
    ;;
    'rotate')
    echo "Rotating Lusca Logfiles.."
    ${LUSCA_BIN} -k rotate
    exit 0
    ;;
    'reconfigure')
    echo "Reconfiguring Lusca.."
    ${LUSCA_BIN} -k reconfigure
    exit 0
    ;;
    *)
    echo "$0: {start|stop|rotate|reconfigure}"
    exit 1
    ;;
    esac
    exit 0


    agora funciona para inicar é uma bala mas para parar demora uns 7 minutos é assim mesmo? estou em testes numa bancada com um servidor dell xeon 2.1ghz 1066mhz/2xhds 500GB 16mb cache raid 1/4GB ddr2 e etc...centos 5.4 64 bits.






Tópicos Similares

  1. Erro de compilação Lusca no ubuntu 64 bits
    Por Rmnet no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-12-2010, 17:16
  2. erro compilacao zaptel
    Por laerciok no fórum Servidores de Rede
    Respostas: 2
    Último Post: 10-03-2007, 21:15
  3. OpenLDAP - erro compilação
    Por spyderlinux no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-03-2006, 12:11
  4. Erro compilacao openmosixview
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-06-2004, 19:00
  5. Erro compilação Sarg 1.4
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 11-09-2003, 16:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L