+ Responder ao Tópico



  1. #1

    Padrão Problemas com Hotmail, megauopload e outros resolvido

    Bem, antes de postar quero dizer que usei algumas regras do amigo kryseck que postou a seguinte conclusão.

    Consegui aqui 50% de sucesso...digo isso pq...

    Adicionei meus IPs públicos na interface internet/public.
    Depois utilei a sequinte regra acima da regra de masquerade:

    add chain=srcnat action=src-nat to-addresses=200.xxx.xxx.xxx to-ports=0-65535 \
    out-interface=public comment="Masquerade to 200.xxx.xxx.xxx" disabled=no

    Dái consegui q a rede saia pelo IP público q eu quiser, claro dos q possuo.
    O problema é q não funciona de jeito algum se eu especificar um IP ou classe de IPs nesta regra em "Src. Address", por exemplo:

    add chain=srcnat action=src-nat to-addresses=200.xxx.xxx.xxx to-ports=0-65535 \
    out-interface=public src-address=172.29.6.29 comment="Masquerade to \
    200.xxx.xxx.xxx" disabled=yes

    Então pergunto: já consegui resolver metade do problema, alguém tem alguma solução para resolver a outra metade?
    Usando os seus pensamento, adicionei umas regras no meu firewall e aparentemente deu certo e queria compartilhar com todos, espero q venha ajudá-los.

    mandarei um export das minhas regras para facilitar o entendimento:

    Obs.: Gostaria de informar que essa regra é valida para quem tem poucos ipś validos e não pode colocá-los para os clientes.

    /ip firewall nat
    add action=src-nat chain=srcnat comment=MEGAUPLOAD disabled=yes dst-address=174.140.0.0/16 protocol=tcp src-address=(range de ips clientes) to-addresses=ip valido 1
    add action=src-nat chain=srcnat comment="" disabled=yes dst-address=174.140.0.0/16 protocol=tcp src-address=(range de ips clientes) to-addresses=ip valido 2
    add action=src-nat chain=srcnat comment="" disabled=yes dst-address=174.140.0.0/16 protocol=tcp src-address=(range de ips clientes) to-addresses=ip valido 3
    add action=src-nat chain=srcnat comment="" disabled=yes dst-address=174.140.0.0/16 protocol=tcp src-address=(range de ips clientes) to-addresses=ip valido 4

    Lembrando: É o essa regra terá q ficar acima do Nat geral.
    dst-address= endereço de ip do servidor (aqui é do servidor MEGAUPLOAD).

    É isso aí, espero que tenha explicado direito e que todos entendam.

    Abraços a todos!!!
    Última edição por cleijean; 30-06-2010 às 22:17.

  2. #2

    Padrão Re: Problemas com Hotmail, megauopload e outros resolvido

    Amigo, continua não funcionando quando é colocado os ips dos clientes em src-address.



  3. #3

    Padrão Re: Problemas com Hotmail, megauopload e outros resolvido

    Faça um teste colocando o ip do site Meu ip - Qual e redireciona para todos os ips validos seu para v se realmente está funcionando a regra.

  4. #4

    Padrão Re: Problemas com Hotmail, megauopload e outros resolvido

    Foi exatamente dessa forma que testei.



  5. #5

    Padrão Re: Problemas com Hotmail, megauopload e outros resolvido

    Me adiciona no msn ai, que irei criar um user temporário no meu servidor para vc olhar as regras, ou para eu mandar um print para vc - [email protected]

  6. #6

    Padrão Re: Problemas com Hotmail, megauopload e outros resolvido

    Fiz, edilsonlsouza((arroba))gmail.com



  7. #7

    Padrão Re: Problemas com Hotmail, megauopload e outros resolvido

    Deu tudo certo!

    Obrigado!

  8. #8

    Padrão Re: Problemas com Hotmail, megauopload e outros resolvido

    não entendi pq n foi postado para todos verem !!!



  9. #9

    Padrão Re: Problemas com Hotmail, megauopload e outros resolvido

    Postado o que amigo? Ta ai as regras! Estas regras funcionam perfeitamente! Só tinha um erro meu e que não observei corretamente na regra do amigo Jean. Costumo compartilhar com os demais o que sei, sera novidade ficar só para mim o que aprendo aqui neste fórum.
    Última edição por EdilsonLSouza; 15-07-2010 às 19:45.

  10. #10

    Padrão Re: Problemas com Hotmail, megauopload e outros resolvido

    Realmente grande mestre Tiago Matias, foi do jeito que o amigo edilson falou, foi somente um problema de interpretação, mas as regras são essas mesmas.

    Abraços!!!
    Vc ja tem o meu msn adicionado, fui eu quem o adicionei [email protected]



  11. #11

    Padrão Re: Problemas com Hotmail, megauopload e outros resolvido

    Citação Postado originalmente por cleijean Ver Post
    Bem, antes de postar quero dizer que usei algumas regras do amigo kryseck que postou a seguinte conclusão.

    Consegui aqui 50% de sucesso...digo isso pq...

    Adicionei meus IPs públicos na interface internet/public.
    Depois utilei a sequinte regra acima da regra de masquerade:

    add chain=srcnat action=src-nat to-addresses=200.xxx.xxx.xxx to-ports=0-65535 \
    out-interface=public comment="Masquerade to 200.xxx.xxx.xxx" disabled=no

    Dái consegui q a rede saia pelo IP público q eu quiser, claro dos q possuo.
    O problema é q não funciona de jeito algum se eu especificar um IP ou classe de IPs nesta regra em "Src. Address", por exemplo:

    add chain=srcnat action=src-nat to-addresses=200.xxx.xxx.xxx to-ports=0-65535 \
    out-interface=public src-address=172.29.6.29 comment="Masquerade to \
    200.xxx.xxx.xxx" disabled=yes

    Então pergunto: já consegui resolver metade do problema, alguém tem alguma solução para resolver a outra metade?
    Usando os seus pensamento, adicionei umas regras no meu firewall e aparentemente deu certo e queria compartilhar com todos, espero q venha ajudá-los.

    mandarei um export das minhas regras para facilitar o entendimento:

    Obs.: Gostaria de informar que essa regra é valida para quem tem poucos ipś validos e não pode colocá-los para os clientes.

    /ip firewall nat
    add action=src-nat chain=srcnat comment=MEGAUPLOAD disabled=yes dst-address=174.140.0.0/16 protocol=tcp src-address=(range de ips clientes) to-addresses=ip valido 1
    add action=src-nat chain=srcnat comment="" disabled=yes dst-address=174.140.0.0/16 protocol=tcp src-address=(range de ips clientes) to-addresses=ip valido 2
    add action=src-nat chain=srcnat comment="" disabled=yes dst-address=174.140.0.0/16 protocol=tcp src-address=(range de ips clientes) to-addresses=ip valido 3
    add action=src-nat chain=srcnat comment="" disabled=yes dst-address=174.140.0.0/16 protocol=tcp src-address=(range de ips clientes) to-addresses=ip valido 4

    Lembrando: É o essa regra terá q ficar acima do Nat geral.
    dst-address= endereço de ip do servidor (aqui é do servidor MEGAUPLOAD).

    É isso aí, espero que tenha explicado direito e que todos entendam.

    Abraços a todos!!!
    Amigo vc está usando apenas as ulitmas regras postadas ? As outras 2 do começo post vc abandonou ?
    Aqui meu NAT não é masquerade.