+ Responder ao Tópico



  1. #1

    Cool Cache Full na Versão 3.30 Usando PPPoE

    Olá Pessoal!

    Alguém sabe me dizer se há alguma coisa que devo implementar para fazer o CACHE FULL na versão 3.30, sendo que uso autenticação por PPPoE.

    Apliquei as regras direto da WIKI do Mikrotik: Queue with Masquerading and Internal Web-Proxy

    Minhas regras estão iguais ao da WIKI (mudando apenas a classe de IPs)

    Código PHP:
    ip firewall nat print 

    Flagsdisabledinvaliddynamic 
     0   
    ;;; Firewall NAT
         chain
    =srcnat action=masquerade src-address=192.168.4.0/24 out-interface=public 

     
    1   chain=dstnat action=redirect to-ports=3128 protocol=tcp src-address=192.168.4.0/24 in-interface=local dst-port=80 
    Código PHP:
    ip firewall mangle print 

    Flagsdisabledinvaliddynamic 
     0   
    ;;; HIT TRAFFIC FROM PROXY
         chain
    =output action=mark-packet new-packet-mark=proxy-hit passthrough=no out-interface=local dscp=

     1   
    ;;; UP TRAFFIC
         chain
    =prerouting action=mark-packet new-packet-mark=test-up passthrough=no src-address=192.168.4.0/24 in-interface=local 

     2   
    ;;; CONN-MARK
         chain
    =forward action=mark-connection new-connection-mark=test-conn passthrough=yes src-address=192.168.4.0/24 

     3   
    ;;; DOWN-DIRECT CONNECTION
         chain
    =forward action=mark-packet new-packet-mark=test-down passthrough=no in-interface=public connection-mark=test-conn 

     4   
    ;;; DOWN-VIA PROXY
         chain
    =output action=mark-packet new-packet-mark=test-down passthrough=no dst-address=192.168.4.0/24 out-interface=local 
    Código PHP:
    queue tree print 
    Flagsdisabledinvalid 
     0   name
    ="downstream" parent=local packet-mark=test-down limit-at=100M queue=default priority=8 max-limit=100M burst-limit=
         burst
    -threshold=0 burst-time=0s 

     1   name
    ="upstream" parent=global-in packet-mark=test-up limit-at=100M queue=default priority=8 max-limit=100M burst-limit=
         burst
    -threshold=0 burst-time=0s 
    Código PHP:
    ip proxy print 
                     
    enabledyes
                 src
    -address0.0.0.0
                        port
    3128
                parent
    -proxy0.0.0.0
           parent
    -proxy-port0
         cache
    -administrator"webmaster"
              
    max-cache-sizenone
               cache
    -on-diskyes
      max
    -client-connections600
      max
    -server-connections600
              max
    -fresh-time3d
       serialize
    -connectionsno
           always
    -from-cacheno
              cache
    -hit-dscp4
                 cache
    -drivesata1 
    Clique na imagem para uma versão maior

Nome:	         proxy.PNG
Visualizações:	576
Tamanho: 	21,0 KB
ID:      	13477
    Alguém pode me dizer o que poderia ser?

  2. #2

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    ninguém ?
    pessoal, quem conseguiu, basta postar as regras do firewall nat, mangle, web-proxy e queue que eu já me viro só!

    pois as regras que eu encontrei aqui no forum não estão funcionando!
    Lembrando que para a versão 2.9.x eu consegui legal! Funcionou perfeito, só não estou conseguindo na versão 3.x.

    obrigado!



  3. #3

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    Estava usando estas regras aqui com cache no próprio MK, não é em paralelo:
    add action=mark-connection chain=output comment="PROXY FULL" disabled=no new-connection-mark=proxyfull passthrough=yes protocol=tcp src-port=5128
    add action=mark-packet chain=output comment="" connection-mark=proxyfull disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output comment="" connection-mark=proxyfull disabled=no

    Ivan Galves

  4. #4

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    Consegui pessoal!!

    /ip firewall nat
    add action=masquerade chain=srcnat comment=nat disabled=no \
    out-interface=public src-address=192.168.4.0/24
    add action=redirect chain=dstnat comment="redirect port 80 to 3128" \
    disabled=no dst-port=80 protocol=tcp src-address=192.168.4.0/24 \
    to-ports=3128


    /ip firewall mangle
    add action=mark-connection chain=output comment=\
    "mark connection *conn_squid-up*" content="X-Cache: HIT" disabled=\
    no new-connection-mark=conn_squid-up passthrough=yes protocol=tcp \
    src-port=3128
    add action=mark-packet chain=output comment=\
    "mark packet *pacotes_squid-up*" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment=\
    "mark connection *conn_squid-down*" disabled=no dst-port=3128 \
    new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment=\
    "mark packet *pacotes_squid-down*" connection-mark=conn_squid-down \
    disabled=no new-packet-mark=pacotes_squid-down passthrough=yes


    /ip firewall filter
    add action=drop chain=input comment="block external proxy" disabled=no \
    dst-port=3128 in-interface=public protocol=tcp
    add action=accept chain=input comment="accept connections from proxy" \
    disabled=no dst-port=3128 protocol=tcp


    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=\
    0 max-limit=150M name=downstream packet-mark=pacotes_squid-down \
    parent=global-in priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=\
    0 max-limit=150M name=upstream packet-mark=pacotes_squid-up parent=\
    global-out priority=1 queue=default


    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=408555000KiB \
    max-client-connections=600 max-fresh-time=3d \
    max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 \
    port=3128 serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=deny comment="block telnet & spam e-mail relaying" disabled=\
    no dst-port=23-25
    add action=allow comment=web-proxy disabled=no src-address=\
    192.168.4.0/24
    add action=deny comment=web-proxy disabled=no



  5. #5

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    Citação Postado originalmente por JorgeAldo Ver Post
    Não existe cache full. Isso é lenda. O nome é "misleading".

    Não entendi, pode até existir diferentes nomes, mas todos sabendo o que é.

  6. #6

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    Mas o "FULL" da cache, para mim, não está relacionado a "guardar" tudo, e sim, "tudo" quer for quardado enviar na velocidade FULL que a rede do provedor/lan suportar.

    Para mim, é isso. Mas entendi sua opnião, isso realmente acontece.



  7. #7
    Avatar de Aredeprovedor
    Ingresso
    Jan 2009
    Localização
    Pôrto Das Caixas, Rio De Janeiro, Brazil, Brazil
    Posts
    79

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    Citação Postado originalmente por BraZuky Ver Post
    Consegui pessoal!!

    Caros amigos,

    Essa regra que o amigo postou funciona bem onde o cache é no cartão de memoria que está no mikrotik e onde minhas portas estão todas ligadas por uma bridge??? essa interface public seria a interface da rede dos cliente, correto?
    Pelo que eu entendi so precisaria mudar o ip da minha rede e o nome das portas.

  8. #8

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    Citação Postado originalmente por Aredeprovedor Ver Post
    Caros amigos,

    Essa regra que o amigo postou funciona bem onde o cache é no cartão de memoria que está no mikrotik e onde minhas portas estão todas ligadas por uma bridge??? essa interface public seria a interface da rede dos cliente, correto?
    Pelo que eu entendi so precisaria mudar o ip da minha rede e o nome das portas.

    Isso amigo.



  9. #9

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    Citação Postado originalmente por BraZuky Ver Post
    Consegui pessoal!!
    Fala amigão, blz?... achei seu post interessante, so tenho 1 duvida que acho que foi a sua tb, olha só, meu MK (Placa Clientes tem o IP 10.1.1.1/24 - e se eu copiar esse seu codigo eu iria apenas mudar os ips do seu para o meu?...aguardo ansioso... valeu!)... Uso Hotspot com IP fixo nos clientes...e não PPPoe.. Valeu!..,
    Última edição por simplification; 04-09-2010 às 23:14.

  10. #10

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    isso mesmo amigo....mude a faixa de ip de acordo com a sua rede



  11. #11
    Avatar de Aredeprovedor
    Ingresso
    Jan 2009
    Localização
    Pôrto Das Caixas, Rio De Janeiro, Brazil, Brazil
    Posts
    79

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    Olá,

    Coloquei em uso o script acima mas não funcionou legal, alguns cliente ficaram com a conexão lenta e alguns sites estavam abrindo paginas antigas como a da globo.com, se eu não me engano eu vi algum comentário informando um script que colocava sites como da globo.com como exeção.
    Será que a lentidão é pq eu uso um microSD na placa? e alguém saberia informa qual é esse script?
    E eu acho que o cache esta sendo guardado na memoria da placa não do cartão!!

  12. #12

    Padrão re: Cache Full na Versão 3.30 Usando PPPoE

    esse ip que ta na sua config é o ip do pppoe server (Clientes) ou da rede normal?
    pergunto pq aqui uso 172.xxx.xxx.xxx para dhcp-server e 192.xxx.xxx.xxx para cliente pppoe...



  13. #13

    Padrão Re: Cache Full na Versão 3.30 Usando PPPoE (RESOLVIDO)

    tive que mudar a resposta pois ha um erro no seu código:

    /ip firewall nat
    add action=masquerade chain=srcnat comment=nat disabled=no out-interface=\
    public src-address=xxx.xxx.xxx.0/24
    mudei de public para pppoe-out1 e funcionou todos sites inclusive https:// ...

    Citação Postado originalmente por darkorion Ver Post
    esse ip que ta na sua config é o ip do pppoe server (Clientes) ou da rede normal?
    pergunto pq aqui uso 172.xxx.xxx.xxx para dhcp-server e 192.xxx.xxx.xxx para cliente pppoe...
    mudei umas coisinhas até conseguir, para quem quiser testar, siga a legenda no final, esta explicadinho aqui:

    (ja alterado para o que funcionou aqui)

    /ip firewall nat
    add action=masquerade chain=srcnat comment=nat disabled=no out-interface=\
    pppoe-out1 src-address=xxx.xxx.xxx.0/24
    add action=redirect chain=dstnat comment="redirect port 80 to 3128" disabled=\
    no dst-port=80 protocol=tcp src-address=xxx.xxx.xxx.0/24 to-ports=3128

    /ip firewall mangle
    add action=mark-connection chain=output comment=\
    "mark connection *conn_squid-up*" content="X-Cache: HIT" disabled=no \
    new-connection-mark=conn_squid-up passthrough=yes protocol=tcp src-port=\
    3128
    add action=mark-packet chain=output comment="mark packet *pacotes_squid-up*" \
    connection-mark=conn_squid-up disabled=no new-packet-mark=\
    pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment=\
    "mark connection *conn_squid-down*" disabled=no dst-port=3128 \
    new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment=\
    "mark packet *pacotes_squid-down*" connection-mark=conn_squid-down \
    disabled=no new-packet-mark=pacotes_squid-down passthrough=yes

    /ip firewall filter
    add action=drop chain=input comment="block external proxy" disabled=no \
    dst-port=3128 in-interface=public protocol=tcp
    add action=accept chain=input comment="accept connections from proxy" \
    disabled=no dst-port=3128 protocol=tcp

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=150M name=downstream packet-mark=pacotes_squid-down parent=\
    global-in priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=150M name=upstream packet-mark=pacotes_squid-up parent=\
    global-out priority=1 queue=default

    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 serialize-connections=\
    no src-address=0.0.0.0

    /ip proxy access
    add action=deny comment="block telnet & spam e-mail relaying" disabled=no \
    dst-port=23-25
    add action=allow comment=web-proxy disabled=no src-address=xxx.xxx.xxx.0/24
    add action=deny comment=web-proxy disabled=no

    LEGENDA:
    network > interface onde estão os clientes pppoe
    xxx.xxx.xxx.0/24 > faixa de ip dos clientes pppoe (não da rede local e sim do pppoe server)
    unlimited > espaço que podera ser ocupado no disco com o cache (hd80gb deixe unlimited ou 75000000 para 75gb por exemplo)
    pppoe-out1 > pppoe-client (quando modem em bridge)

    ja vi varios posts aqui no under porem não funcionaram não sei pq, hoje testei este do zero como sempre e funcionou 90% com cache full, só não deu 100% pq não esta abrindo paginas do hotmail e nem https: ...não sei pq... se alguem souber ajude-nos... plz...

    como este post não é meu peço ao amigo BraZuKy que copie minha resposta e modifique seu post, pois os códigos postados aqui foi ele quem postou... eu apenas legendei o mesmo...
    Última edição por darkorion; 10-01-2012 às 13:33.

  14. #14
    Avatar de ShiFT
    Ingresso
    Sep 2010
    Localização
    Francisco Beltrão - PR
    Posts
    113

    Padrão Re: Cache Full na Versão 3.30 Usando PPPoE

    Acompanhando o tópico, tenho estrutura seguinte. ModemRoteado->EtherInternet(10.10.10.2)-EtherCliente(192.168.251.0/24)



  15. #15

    Padrão Re: Cache Full na Versão 3.30 Usando PPPoE

    Pessoal boa noite, sou iniciante, estou tentando fazer um cache full com mikrotik versão 2.9.27 level 6 , mas não estou conseguindo sera que alguem poderia me ajudar...

    Obrigado

    Lucas,

  16. #16

    Padrão Re: Cache Full na Versão 3.30 Usando PPPoE

    Citação Postado originalmente por labme Ver Post
    Pessoal boa noite, sou iniciante, estou tentando fazer um cache full com mikrotik versão 2.9.27 level 6 , mas não estou conseguindo sera que alguem poderia me ajudar...

    Obrigado

    Lucas,

    Volte para o começo e leia muito, pesquise aqui no fórum e em outros, pq assim vc está fazendo tudo errado.



  17. #17

    Padrão Re: Cache Full na Versão 3.30 Usando PPPoE

    Amigo, ja uso ele a algum tempo, mas onde tenho provedor estamos com link um pouco limitado, o basico eu faço, mas agora surgiu esta ideia ja pesquisei em varios lugar, fiz varios códigos sera que podem me ajudar ?

  18. #18

    Padrão Re: Cache Full na Versão 3.30 Usando PPPoE

    Quanto de link vc tem? Quantos clientes? E cache no mikrotik pode esquecer, não rola.



  19. #19

    Padrão

    Se tiver mais de 10 clientes já passou a hora de trocar esse pc com mikrotik crackeado por uma Rb 450g pelo menos, já que vc espera crescer e colocar mais clientes em sua rede.