Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Qual a versao do Mk ?

  2. Citação Postado originalmente por interhome Ver Post
    Qual a versao do Mk ?
    valeu ai amigo eu ja consegui aki

    a versão do meu mikrotik é 3.29

    minha RB é uma 750
    vou postar o script aki.



  3. Citação Postado originalmente por parreira13 Ver Post
    segue o script que estou usando que pegei aqui mesmo no forum:

    :log info "DDNS: Begin"
    :global ddns-user "meu usuario"
    :global ddns-pass "minha senha"
    :global ddns-host "meu domínio"
    :global ddns-interface "pppoe-out"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [/tool dns-update name=$ddns-host address=[http://static3.under-linux.net/image...ies/tongue.pngick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"
    uso este no mk 2.xx mas desde que implantei o 3.13 não quer mais funcionar, alguem poderia me ajudar?

  4. Citação Postado originalmente por netuai Ver Post
    uso este no mk 2.xx mas desde que implantei o 3.13 não quer mais funcionar, alguem poderia me ajudar?
    Se for para DynDNS funciona esse aki

    Código PHP:
    :local ddnsuser "logindyndns"
    :local ddnspass "senhadyndns"
    :local theinterface "nome da interface pppoe"
    :local ddnshost "nome do host que vai ser o seu ip fixo"
    :local ipddns [:resolve $ddnshost];
    :
    local ipfresh [ /ip address get [/ip address find interface=$theinterface address ]
    :if ([ :
    typeof $ipfresh ] = nil ) do={
       :
    log info ("DynDNS: No ip address on $theinterface .")
    } else={
       :for 
    i from=( [:len $ipfresh] - 1to=do={ 
          :if ( [:
    pick $ipfresh $i] = "/") do={ 
        :
    set ipfresh [:pick $ipfresh 0 $i];
          } 
    }
     
    :if (
    $ipddns != $ipfresh) do={
        :
    log info ("DynDNS: IP-DynDNS = $ipddns")
        :
    log info ("DynDNS: IP-Fresh = $ipfresh")
       :
    log info "DynDNS: Update IP needed, Sending UPDATE...!"
        
    :local str "/nic/update?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
        
    /tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
        :
    delay 1
        
    :local str [/file find name="DynDNS.$ddnshost"];
        /
    file remove $str
        
    :global ipddns $ipfresh
      
    :log info "DynDNS: IP alterado para $ipfresh!"
        
    } else={
         :
    log info "DynDNS: Atualizado";
        }




  5. eu uso o change ip






Tópicos Similares

  1. Respostas: 6
    Último Post: 20-02-2015, 01:28
  2. Respostas: 4
    Último Post: 12-08-2014, 14:17
  3. Fechar Enlace, alguém me ajuda por favor?!
    Por klemensonleal no fórum Redes
    Respostas: 9
    Último Post: 28-01-2007, 19:33
  4. Por favor alguém me ajuda com meu dhcp?
    Por fisiconuclear18 no fórum Servidores de Rede
    Respostas: 5
    Último Post: 28-10-2005, 08:38
  5. Instalar pacote rpm por linha de comando? alguem me ajuda?
    Por criativo no fórum Servidores de Rede
    Respostas: 9
    Último Post: 11-11-2004, 15:35

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L