+ Responder ao Tópico



  1. #1

    Question Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    Pessoal tipo fikei sabendo que um moden rotiado ele perde 15 % da sua ecifiencia dai então eu deixei ele como bridge e colokei o mikrotik para rotiar, dai agora eu quero que ele atualize o meu ip no dyn dns :S

    alguem ai me ajuda

  2. #2

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    Se o ip é fixo não precisa disso amigo... Agora se o ip for dinamico, aqui no forum tem varios scripts para isso, é so perder um pouco o seu tempo e dar uma vasculhada...



  3. #3

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    segue o script que estou usando que pegei aqui mesmo no forum:

    :log info "DDNS: Begin"
    :global ddns-user "meu usuario"
    :global ddns-pass "minha senha"
    :global ddns-host "meu domínio"
    :global ddns-interface "pppoe-out"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [/tool dns-update name=$ddns-host address=[http://static3.under-linux.net/image...ies/tongue.pngick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

  4. #4

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    Citação Postado originalmente por rogeriodj Ver Post
    Se o ip é fixo não precisa disso amigo... Agora se o ip for dinamico, aqui no forum tem varios scripts para isso, é so perder um pouco o seu tempo e dar uma vasculhada...
    kkkkk' vc não entendeu fi, o atraves do dyn dns voce tem um ip fixo num é ?
    então eu quero um script para o dyn dns pra min coloka na minha rb pra quando muda o ip eu num precisa fika entrando no site do dyn dns para atualizar



  5. #5
    Avatar de ultralaser
    Ingresso
    May 2007
    Localização
    Presidente Prudente
    Posts
    176
    Posts de Blog
    1

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    Pega no meu blog q tem ai

  6. #6
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    Qual a versao do Mk ?



  7. #7

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    Citação Postado originalmente por interhome Ver Post
    Qual a versao do Mk ?
    valeu ai amigo eu ja consegui aki

    a versão do meu mikrotik é 3.29

    minha RB é uma 750
    vou postar o script aki.

  8. #8

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    Citação Postado originalmente por parreira13 Ver Post
    segue o script que estou usando que pegei aqui mesmo no forum:

    :log info "DDNS: Begin"
    :global ddns-user "meu usuario"
    :global ddns-pass "minha senha"
    :global ddns-host "meu domínio"
    :global ddns-interface "pppoe-out"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [/tool dns-update name=$ddns-host address=[http://static3.under-linux.net/image...ies/tongue.pngick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"
    uso este no mk 2.xx mas desde que implantei o 3.13 não quer mais funcionar, alguem poderia me ajudar?



  9. #9

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    Citação Postado originalmente por netuai Ver Post
    uso este no mk 2.xx mas desde que implantei o 3.13 não quer mais funcionar, alguem poderia me ajudar?
    Se for para DynDNS funciona esse aki

    Código PHP:
    :local ddnsuser "logindyndns"
    :local ddnspass "senhadyndns"
    :local theinterface "nome da interface pppoe"
    :local ddnshost "nome do host que vai ser o seu ip fixo"
    :local ipddns [:resolve $ddnshost];
    :
    local ipfresh [ /ip address get [/ip address find interface=$theinterface address ]
    :if ([ :
    typeof $ipfresh ] = nil ) do={
       :
    log info ("DynDNS: No ip address on $theinterface .")
    } else={
       :for 
    i from=( [:len $ipfresh] - 1to=do={ 
          :if ( [:
    pick $ipfresh $i] = "/") do={ 
        :
    set ipfresh [:pick $ipfresh 0 $i];
          } 
    }
     
    :if (
    $ipddns != $ipfresh) do={
        :
    log info ("DynDNS: IP-DynDNS = $ipddns")
        :
    log info ("DynDNS: IP-Fresh = $ipfresh")
       :
    log info "DynDNS: Update IP needed, Sending UPDATE...!"
        
    :local str "/nic/update?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
        
    /tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
        :
    delay 1
        
    :local str [/file find name="DynDNS.$ddnshost"];
        /
    file remove $str
        
    :global ipddns $ipfresh
      
    :log info "DynDNS: IP alterado para $ipfresh!"
        
    } else={
         :
    log info "DynDNS: Atualizado";
        }


  10. #10

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    eu uso o change ip



  11. #11

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    Citação Postado originalmente por netuai Ver Post
    eu uso o change ip
    hum sim, então o meu ai num da mas procura no forum que voce acha, esse ai eu achei aki no forum foi dificil mas achei um que funcionace

  12. #12

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    devo estar fazendo alguma coisa errada, copiei o script do dyndns e criei uma conta la, dai setei no servidor e nada fez rodar, ja olhei minhas outras regras
    parece que meu servidor nao esta atualizando o ip la no dyndns, o mesmo ocorre com o changeip



  13. #13

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    Citação Postado originalmente por netuai Ver Post
    devo estar fazendo alguma coisa errada, copiei o script do dyndns e criei uma conta la, dai setei no servidor e nada fez rodar, ja olhei minhas outras regras
    parece que meu servidor nao esta atualizando o ip la no dyndns, o mesmo ocorre com o changeip
    olha cara, tipo o moden tem que ta em bridge tu sakas né ?
    aki eu configuei deu certo cara.

  14. #14

    Padrão Re: Alguem me ajuda por favor a coloka um SCRIPT que funcione para atualiza o ip fixo DYN DNS :2in1:

    para versao 3.x ou superior usa esse aki

    /tool dns-update name=nome do host address=127.0.0.255 key-name=logindyndns key="senhadyndns"