+ Responder ao Tópico



  1. #1

    Padrão Scriot ACK HELP!!

    Boa Tarde Galera do fórum..
    é o seguinte..
    não estou conseguindo fazer o script de ack do alexandre rodar...
    como faço?!
    pego o arquivo.txt e jogo dentro do menu file?!
    to precisando muito de rodar esse script....só naum sei como fazer....
    quem puder.....dá uma ajuda aew!!!!!PLEASE!!
    fikem na paz!!

  2. #2

    Padrão Re: Scriot ACK HELP!!

    Amigo Siga os passos desse LINK que você vai conceguir rodar o script
    Valeu
    se ajudei não custa nada agradecer

    qualquer coisa estamos ae



  3. #3

    Padrão Re: Scriot ACK HELP!!

    Então meu amigo..
    como assim criar um novo script...
    sou novo nessa parte..
    onde add esse script?!
    nisso q to me embolando!
    me desculpe minha ignorancia!!
    abraços...

  4. #4

    Cool Re: Scriot ACK HELP!!

    Citação Postado originalmente por Lucas1985 Ver Post
    Então meu amigo..
    como assim criar um novo script...
    sou novo nessa parte..
    onde add esse script?!
    nisso q to me embolando!
    me desculpe minha ignorancia!!
    abraços...
    Amigo Entre na RB
    em seguida click em New Terminal

    e cole o Codigo abaixo Fonte do Script
    Código :
    /system script
     
    add name=CONTROLE_ACK policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="#Script ACK-Check v0.1\r\
        \n#\r\
        \n#Lista as estacoes que estao com ACK acima do limite com opcao para desconecta-las\r\
        \n#\r\
        \n# Autor: Alexandre Jeronimo Correa <[email protected]>\r\
        \n# 20/11/2009 - 01:03am\r\
        \n#\r\
        \n#Instrucoes de uso:\r\
        \n#     -- Adicionar o codigo completo em SYSTEM >> SCRIPTS\r\
        \n#     -- Por padrao o script nao vai derrubar nenhuma estacao, rode o script padrao antes de\r\
        \n#         configurar a variavel cut para 1, tendo certeza que o script esta OK.\r\
        \n#     -- O script pode ser executado pelo botao \"run script\" ou via linha de comando.\r\
        \n#        \"/ system script run <nome do script>\r\
        \n#     -- O script so funciona em interfaces que o modo de operacao seja AP-BRIDGE\r\
        \n#     -- Testado nas versoes 3.25 at\E9 3.30\r\
        \n#\r\
        \n#Informacoes:\r\
        \n#\r\
        \n#Variavel ack -> deve ter o valor do ack MAXIMO permitido.\r\
        \n#Variavel cut ->  deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconecta a estacao.\r\
        \n##################################################################\r\
        \n#Configuracoes das variaveis\r\
        \n:local ack 50;\r\
        \n:local cut 0;\r\
        \n\r\
        \n############ Script - NAO ALTERAR #####################################\r\
        \n:local mac \"\";\r\
        \n:local uack \"\";\r\
        \n:local removido \"\";\r\
        \n:log warning (\"[ackchk] Procurando clientes com ACK maior que \" . \$ack);\r\
        \n#pega a lista de interfaces AP wireless ativas, e que tenham ack dinamico\r\
        \n:foreach i in=[ / interface wireless find mode=\"ap-bridge\" ack-timeout=\"dynamic\" running] do={\r\
        \n          :local intname [ / interface wireless get \$i name ];\r\
        \n          :log warning (\"     Interface: \" . \$intname);\r\
        \n          :foreach x in=[/interface wireless registration-table find interface=\$intname] do={\r\
        \n                    :set uack [/interface wireless registration-table get \$x ack-timeout];\r\
        \n                    :set removido \"\";\r\
        \n                    :if (\$uack > \$ack) do={\r\
        \n                         :set mac [ / interface wireless registration-table get \$x mac-address];                         \r\
        \n                         :if (\$cut = 1) do= {\r\
        \n                              :set removido \" removido...\";\r\
        \n                              / interface wireless registration-table remove \$x;\r\
        \n                         };\r\
        \n                    :log warning (\"          mac: \" . \$mac . \"@\" . \$intname . \" [\" . \$uack . \"]\" . \$removido);\r\
        \n                    };                    \r\
        \n          };\r\
        \n};\r\
        \n############ FIM #####################################"
     
     
    /system scheduler
    add comment="" disabled=no interval=50s name=CONTROLE_ACK on-event=CONTROLE_ACK start-time=startup

    Pronto feito isso o Script vai estar Funcionando
    vc só tem que alterar Depois o Tempo de Intervalo que o Script vai Ficar Sendo utilizado ao seu Gosto
    eu configurei pra ele rodar a cada 50 Segundos
    mas si vc quiser e só alterar em System Scheduler
    blz

    se ajudei não Custa nada Clicar na estrela do Roda pé desse post

    Vlw


    qualquer coisa tamo ae
    Última edição por tonflatland; 17-08-2010 às 20:47. Razão: Correção



  5. #5

    Padrão Re: Scriot ACK HELP!!

    vlw amigo!!!!!!
    muito obrigado!!
    o que precisar...
    estaremos aew...
    fik na paz brother!!!

  6. #6

    Padrão Re: Scriot ACK HELP!!

    Outra Coisa Corrige o Titulo do Post ae
    você colocou Scriot o correto e script
    corrige ae pra facilitar a Vida de outras pessoas que tiverem a mesma Duvida amigo
    vlw...

    De onde você e ?
    Última edição por tonflatland; 17-08-2010 às 00:35. Razão: Correção



  7. #7

    Padrão Re: Scriot ACK HELP!!

    Amigo Tomflatland............estava precisando de mais uma ajuda sua.....
    tenho uma rb 800 com 3 cartões xr2, tudo com as devidas configurações...mais nela c encontra um xr5, fazendo o enlace....qua quando mando colar o script, só entra a parte de scheduler, já o script naum vai.....terei q dizer em quais cartões rodem os scripts... c for.....como faço....pode me dar uma ajuda...desde já grato!!!

  8. #8

    Padrão Re: Scriot ACK HELP!!

    Pow Amigo.........resolveu meu problema de ack....
    show,............
    só q na outa rb. só entra o scheduler, já o script naum vai....dá erro..
    será q é pq tenho na mesma rb uma xr5 q faz enlace para outra torre.....
    vou ter q especificar em quasi interfaces vai rodar o script?!
    c for......como faço isso?!
    abraços amigo...
    fik na paz!!



  9. #9

    Padrão Re: Scriot ACK HELP!!

    1º si poder Agradecer Fico Grato pois minha reputação agradeçe hehehehe
    já que foi util o tempo dedicado e a informação repassada
    2 º Qual versão vc esta usando em Ambas as RB's

    Aguardo Resposta

  10. #10

    Padrão Re: Scriot ACK HELP!!

    Pow uso a 4.5.........
    em ambas!!!
    num é só tem pc ap 4 cartões tods em ap bridge, ack dinamyc.
    já em outra
    tem 3 xr2, e uma xr5....q recebe o link....tudo na mesma rb 800...
    será q é isso?!
    ajuda aew brother!!!!Tem me ajudado muito.....ahhhhhhhh!!!!
    cliquei já a um tempão pra agradecer.....e ainda deixei resposta no forum.....rsrsrsrs..
    fik na paz brother!!



  11. #11

    Padrão Re: Scriot ACK HELP!!

    Citação Postado originalmente por Lucas1985 Ver Post
    Pow uso a 4.5.........
    em ambas!!!
    num é só tem pc ap 4 cartões tods em ap bridge, ack dinamyc.
    já em outra
    tem 3 xr2, e uma xr5....q recebe o link....tudo na mesma rb 800...
    será q é isso?!
    ajuda aew brother!!!!Tem me ajudado muito.....ahhhhhhhh!!!!
    cliquei já a um tempão pra agradecer.....e ainda deixei resposta no forum.....rsrsrsrs..
    fik na paz brother!!
    Aqui no meu MK v 4.10 funcionou perfeitamente... segue abaixo como dexei no meu mk.
    /system script
    add name=CONTROLE_ACK policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="#Script ACK-Check v0.1\r\
    \n#\r\
    \n#Lista as estacoes que estao com ACK acima do limite com opcao para desconecta-las\r\
    \n#\r\
    \n# Autor: Alexandre Jeronimo Correa <[email protected]>\r\
    \n# 20/11/2009 - 01:03am\r\
    \n#\r\
    \n#Instrucoes de uso:\r\
    \n# -- Adicionar o codigo completo em SYSTEM >> SCRIPTS\r\
    \n# -- Por padrao o script nao vai derrubar nenhuma estacao, rode o script padrao antes de\r\
    \n# configurar a variavel cut para 1, tendo certeza que o script esta OK.\r\
    \n# -- O script pode ser executado pelo botao \"run script\" ou via linha de comando.\r\
    \n# \"/ system script run <nome do script>\r\
    \n# -- O script so funciona em interfaces que o modo de operacao seja AP-BRIDGE\r\
    \n# -- Testado nas versoes 3.25 at\E9 3.30\r\
    \n#\r\
    \n#Informacoes:\r\
    \n#\r\
    \n#Variavel ack -> deve ter o valor do ack MAXIMO permitido.\r\
    \n#Variavel cut -> deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconecta a estacao.\r\
    \n##################################################################\r\
    \n#Configuracoes das variaveis\r\
    \n:local ack 50;\r\
    \n:local cut 1;\r\
    \n\r\
    \n############ Script - NAO ALTERAR #####################################\r\
    \n:local mac \"\";\r\
    \n:local uack \"\";\r\
    \n:local removido \"\";\r\
    \n:log warning (\"[ackchk] Procurando clientes com ACK maior que \" . \$ack);\r\
    \n#pega a lista de interfaces AP wireless ativas, e que tenham ack dinamico\r\
    \n:foreach i in=[ / interface wireless find mode=\"ap-bridge\" ack-timeout=\"dynamic\" running] do={\r\
    \n :local intname [ / interface wireless get \$i name ];\r\
    \n :log warning (\" Interface: \" . \$intname);\r\
    \n :foreach x in=[/interface wireless registration-table find interface=\$intname] do={\r\
    \n :set uack [/interface wireless registration-table get \$x ack-timeout];\r\
    \n :set removido \"\";\r\
    \n :if (\$uack > \$ack) do={\r\
    \n :set mac [ / interface wireless registration-table get \$x mac-address]; \r\
    \n :if (\$cut = 1) do= {\r\
    \n :set removido \" removido...\";\r\
    \n / interface wireless registration-table remove \$x;\r\
    \n };\r\
    \n :log warning (\" mac: \" . \$mac . \"@\" . \$intname . \" [\" . \$uack . \"]\" . \$removido);\r\
    \n }; \r\
    \n };\r\
    \n};\r\
    \n############ FIM #####################################"


    /system scheduler
    add comment="" disabled=no interval=1m name=CONTROLE_ACK on-event=CONTROLE_ACK policy=reboot,read,write,policy,test,password,sniff,sensitive start-time=\
    startup