+ Responder ao Tópico



  1. #1

    Padrão Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    Olá pessoal é o seguinte, consegui fazer o cache full com hotspot usando o webproxy 4.11 do MK na mesma máquina, mas tem algo esquisito que queria compartilhar com os amigos para acharmos uma solução viável. O problema está em Simple Queues, quando faço a regra


    Código :
    /queue simple
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=\    8M/8M name=cachefull packet-marks=proxy-hit parent=none priority=1 queue=ethernet-default/ethernet-default total-queue=default-small
    ele deve ficar sempre na posição zero (0), mas como o profile do hotspot é dinâmico sempre que o usuário se conecta a queue do cache full é jogada para posição abaixo, tipo do 0 vai para 1 e os clientes que ficam acima da queue do cache full não fazem o download do cache full.

    Teria como por esse queue sempre na posião 0?

    ---------------------------------------------------------
    Resolvido:

    Tire a marcação do Simple queues e ponha no Queue Tree

    Código :
     
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=4M name="Cache Full" packet-mark=proxy-hit parent=global-out \
        priority=4 queue=ethernet-default

    Abraços
    Última edição por DSSS; 03-09-2010 às 16:11.

  2. #2

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    quantos clientes vc tem
    acho que essa maquina vai ficar sobrecarregada



  3. #3

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    Citação Postado originalmente por quissanet Ver Post
    quantos clientes vc tem
    acho que essa maquina vai ficar sobrecarregada
    Só 80 clientes

  4. #4

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    Você consegui resolver seu problema de cache full meu MSN: [email protected]



  5. #5

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    To tentando ativar esse webproxy mais nao to conseguindo ele marca os pacotes mais nao pega do cache.

  6. #6

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    Aqui está funcionando perfeitamente, se quiserem posso postar os comando aqui.

    ABraços



  7. #7

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    bom dia amigo DSSS,

    pode postar o comando.
    uma pergunta a todos do forum mais experientes no mk, o webproxy está melhor nessa versao? é melhor proxy paralelo ou webproxy na mesma makina do mk?

    até mais

  8. #8

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    Eu to querendo deixar na mesma maquina que o MK, quero so ativar o WEBPROXY tipo hd de 10gb... quando ativar o webproxy tem q tirar todas regras de firewall que ja estao feitas? para q ele posso redirecionar as portas?



  9. #9

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    Aproveito para peguntar como saber se o cache esta funcionando? Uso a versão 3.30.
    Grato.

  10. #10

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    Citação Postado originalmente por amilton Ver Post
    Aproveito para peguntar como saber se o cache esta funcionando? Uso a versão 3.30.
    Grato.
    /ip firewall mangle
    add action=mark-connection chain=postrouting comment="CACHE FULL" content="X-Cache: HIT" disabled=no new-connection-mark=forward-hits passthrough=yes
    add action=mark-packet chain=postrouting comment="" connection-mark=forward-hits disabled=no new-packet-mark=cache-hits passthrough=yes
    add action=mark-packet chain=postrouting comment="" connection-mark=proxy-hits disabled=no new-packet-mark=proxy-squid31 passthrough=yes
    add action=mark-connection chain=output comment="PROXY FULL" content="X-Cache: HIT" disabled=no new-connection-mark=proxy passthrough=yes protocol=tcp \
    src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=proxy disabled=no new-packet-mark="Proxy Full" passthrough=yes

    Indo em IP - Webpeoxy - verifique se em ((hits)) está mudando...
    Com essa regra aqui funcionou o WEBPROXY do MK 4.10, mais sobrecarregou o servidor ai tive que desativar. Estou comprando um servidor para trabalhar apenas no proxy.
    Última edição por peritinaicos; 04-10-2010 às 14:39.



  11. #11

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    Alguem ja tentou webproxy com Load Balance?
    Gostaria de informções sobre instabilidade nessa configuração.

  12. #12

    Padrão Re: Cache Full (webproxy 4.x) com hotspot - Na mesma máquina

    Boa pergunta viu, pq se for em maquinas separadas acho que nao tem problema, mais proxy + cache deve gerar alguma coisa errada se na mesma maquina