+ Responder ao Tópico



  1. #1

    Padrão Switch

    Olá amigos, gostaria que me tirassem uma dúvida o mais rápido possível. Tenho Link Full Embratel de 4 MB. Tô querendo colocar mais um servidor, ficando assim com dois. O que ocorre é que quando coloco 1 Switch depois do roteador para mandar o link pra ambos os servidores, noto que há perda no desempenho e não consegue passar os 4 MB completos mesmo desligando um dos servidores. Será que o Switch não aguenta? Qual seria a solução? Não quero dividir o link com controle de banda, quero que os 4 MB fiquem a disposição dos dois servidores. Tô usando um Switch 8 portas da Level One.

    Abraço.
    Última edição por Hernesto; 10-09-2010 às 15:37.

  2. #2

    Padrão Re: Switch

    Pode ser o switch coloca um dlink de 8 portas eles para trabalhar em local interno funciona legal ja usei um desse nun link de 8mb sem problema



  3. #3

    Padrão Re: Switch

    Bom dia, Utiliza o 3Com ( 3cgsu08)......Amigo..ele tem 8 portas e é gigabit...show de bola. Abraço.

  4. #4

    Padrão Re: Switch

    Amigos, obrigado pelas respostas. Antes de trocar o switch vou testar da seguinte forma: Conectar um servidor direto no roteador (dessa forma funciona normalmente) colocando + uma placa de rede neste servidor. Faço uma bridge com a placa que recebe o link vindo do roteador + essa outra que vou adicionar e nela conecto o outro servidor. Creio que seja uma solução sem necessidade de switch. Da forma que está, com o switch, passa em média, apenas 2 Mb de link pra os servidores. Empaca mesmo. Que acham?
    Última edição por Hernesto; 11-09-2010 às 11:41.



  5. #5

    Padrão Re: Switch

    Pô gurizada, é claro que é este switch que é o problema, esta na hora de colocar um switch gerenciavel ai, nunca mais vai ter este tipo de problema é um pouco mais caro mais vale a pena..

  6. #6

    Padrão Re: Switch

    Mas com relação a minha sugestão:

    Conectar um servidor direto no roteador (dessa forma funciona normalmente) colocando + uma placa de rede neste servidor. Faço uma bridge com a placa que recebe o link vindo do roteador + essa outra que vou adicionar e nela conecto o outro servidor.

    Creio que seja uma solução sem necessidade de switch. Da forma que está, com o switch, passa em média, apenas 2 Mb de link pra os servidores e uma lentidão terrível. Empaca mesmo. Que acham?



  7. #7

    Padrão Re: Switch

    Funciona sim, faz o teste para ver..
    Mas já vai pensando em gastar um pouco para colocar um switch gerenciavel, vai ser inevitável..

  8. #8

    Padrão Re: Switch

    Fiz o teste. Não mudou muita coisa não. No servidor que está recebendo o link fica normal, agora no outro, o problema volta a ocorrer. Fiz assim: Criei uma bridge entre as duas placas, uma recebe o link e a outra manda pra o outro servidor. Coloquei 1 IP válido da Embratel pra o primeiro servidor nessa bridge. E no outro servidor coloquei outro IP válido (tenho 16 ips). Só que noto o mesmo problema, o link não flui normalmente. Fica na barreira dos 2 Mega. Tem + alguma configuração a fazer? Pretendo colocar um switch gerenciavel + gostaria de deixar funcionando enquanto recebo ele.



  9. #9

    Padrão Re: Switch

    Amigo...seguinte...quando voce coloca o link neste outro servidor seu...flui normalmente os 4mb?
    outra coisa...qual sistema voce esta utilizando?..ja tentou desabilitar os firewall..ta utilizando iptables?...abraço!

  10. #10

    Padrão Re: Switch

    Flui sim. Quando coloco o cabo que vem do roteador direto no servidor, flui normalmente. Só vem a dar o problema quando coloco o switch enviando pra os 2 servidores ou no caso como fiz: O link entrando no servidor 01 (flui normalmente) e saindo pra o servidor 2 em outra placa que está numa bridge com a que recebe o link do roteador. Neste caso, o link flui normalmente no Servidor 01, mas no 02 fica ruim. Fiz apenas a bridge entre as duas placas (A que recebe o link e a que manda pra o servidor 02). Estou usando Mikrotik.



  11. #11

    Padrão Re: Switch

    Cara este teu segundo servidor a placa de rede esta boa, voce já fez um teste com o segundo server direto no router?? pode ser a placa de rede deste teu server que esta com problema..

  12. #12

    Padrão Re: Switch

    Ainda não fiz esse teste das placas não. Mas irei fazer. Mas também pode ser a do primeiro servidor não é? Tenho que testar isso. Quer dizer que usando dessa forma que falei, as placas estando boas, não é pra ocorrer esse problema? Mais uma dúvida: Usando dessa forma o link fica igualmente a disposição de ambos os servidores ou o Servidor 01 (Que recebe o link) terá mais prioridade no consumo? E como as placas estão em bridge, o link passará pra o Servidor 2 fora de qualquer regra do servidor 01 neh isso?

    Abraço e obrigado pelas respostas.
    Última edição por Hernesto; 12-09-2010 às 18:39.



  13. #13

    Padrão Re: Switch

    Olá amigos. Gostaria que avaliassem essas ligações e se existe alguma regra para essa bridge que citei, evitar colisões? Fiz de acordo com a imagem. Pode funcionar dessa forma sem maiores problemas? Colisões, latência... Agradeço pela ajuda. Está funcionando assim, mas percebo o desempenho melhor da navegação no servidor 1. Será que falta algo?
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         TOPOLOGIA.jpg
Visualizações:	43
Tamanho: 	69,8 KB
ID:      	14589  

  14. #14

    Padrão Re: Switch

    Citação Postado originalmente por Hernesto Ver Post
    Ainda não fiz esse teste das placas não. Mas irei fazer. Mas também pode ser a do primeiro servidor não é? Tenho que testar isso. Quer dizer que usando dessa forma que falei, as placas estando boas, não é pra ocorrer esse problema? Mais uma dúvida: Usando dessa forma o link fica igualmente a disposição de ambos os servidores ou o Servidor 01 (Que recebe o link) terá mais prioridade no consumo? E como as placas estão em bridge, o link passará pra o Servidor 2 fora de qualquer regra do servidor 01 neh isso?

    Abraço e obrigado pelas respostas.
    Amigo coloque um switch... mas enquanto isso, sete seu ip valido na eth1 do server 1, não precisa deixar na bridge.



  15. #15

    Padrão Re: Switch

    Tranquilo. Já fiz. Setei o ip direto na eth1. Então dessa forma que está não é necessário colocar regras não né? O link passará tranquilamente não é isso? Porque não quero controle de banda, só que o link flua entre os dois normalmente.