+ Responder ao Tópico



  1. #1

    Padrão regras para guando o link cair, ajuda!!!

    peguei essas regras la no orkut:

    Código :
    / tool netwatch 
    add host=200.154.56.80 timeout=1s interval=20s up-script=on \
    down-script=off comment="Link" disabled=no 
     
     
    / system script
     
    add name="Linkoff" source="/ip firewall nat set [/ip firewall nat find comment=Aviso_sem_link] disabled=no" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
     
     
    add name="Linkon" source="/ ip firewall nat set [/ip firewall nat find comment=Aviso_sem_link] disabled=yes" \
    policy=ftp,reboot,read,write,policy,test,winbox,password 
     
    / system script 
    add name="off" source="/ip firewall nat find comment=Aviso_sem_link disabled=no" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
     
     
    add name="on" source="[/ip firewall nat find comment=Aviso_sem_link disabled=yes" \
    policy=ftp,reboot,read,write,policy,test,winbox,password 
     
    / ip firewall nat 
     
    add chain=dstnat src-address=[Range de IP Cliente] protocol=tcp dst-port=80 action=dst-nat to-addresses=[IP do servidor web] to-ports=0-65535 comment="Aviso_sem_link" \
    disabled=no

    mais não funcionou comigo, guando desligo o modem aparece essa tela:
    http://uploaddeimagens.com.br/imagem/ver/77tela.JPG

  2. #2

    Padrão Re: regras para guando o link cair, ajuda!!!

    Essas regras servem para avisar a quem estiver conectado sobre a queda do link. E está funcionando corretamente.



  3. #3

    Padrão Re: regras para guando o link cair, ajuda!!!

    Citação Postado originalmente por bjaraujo Ver Post
    Essas regras servem para avisar a quem estiver conectado sobre a queda do link. E está funcionando corretamente.
    amigão mais aonde fica a pagina que e mostrada que esta em manutenção...

  4. #4

    Padrão Re: regras para guando o link cair, ajuda!!!

    A únicar forma que conheco é você instalar um apache noutro servidor e redirecionar para o ip deste servidor, a página é o arquivo index.htm, ou outro equivalente. Você também tem que redirecionar no apache o erro 404 para esta página home, de outro modo, se alguém acessar: www.google.com/linux a mensagem não aparece mas sim erro 404.
    Última edição por bjaraujo; 26-09-2010 às 23:36.



  5. #5

    Padrão Re: regras para guando o link cair, ajuda!!!

    Esses ctrl+c e ctrl+v acabam com tudo meu velho!!!

    Faz o seguinte...
    faz um netwatch pingando externamente e cria scripts para habilitar ou desabilitar as tuas opções de mensagem..
    em caso de hotspot tela de aviso, em outros casos server linux fazendo algum tipo de captive portal!

  6. #6

    Padrão Re: regras para guando o link cair, ajuda!!!

    Citação Postado originalmente por tmelooliveira Ver Post
    Esses ctrl+c e ctrl+v acabam com tudo meu velho!!!

    Faz o seguinte...
    faz um netwatch pingando externamente e cria scripts para habilitar ou desabilitar as tuas opções de mensagem..
    em caso de hotspot tela de aviso, em outros casos server linux fazendo algum tipo de captive portal!
    Estava por aqui e encontrei algumas respostas suas a dúvidas do pessoal, e em todas, as respostas se parecem muito.(rsssssss)

    Alivia ai com o pessoal rapaz...Abraço.



  7. #7

    Padrão Re: regras para guando o link cair, ajuda!!!

    Citação Postado originalmente por tmelooliveira Ver Post
    Esses ctrl+c e ctrl+v acabam com tudo meu velho!!!

    Faz o seguinte...
    faz um netwatch pingando externamente e cria scripts para habilitar ou desabilitar as tuas opções de mensagem..
    em caso de hotspot tela de aviso, em outros casos server linux fazendo algum tipo de captive portal!
    amigo obrigado pela ajuda, tentei também com as regras do catvbrasil e não consegui, lendo o fórum
    vi que um amigo disse que conseguiu fazendo o netwatch trocar o profile do hotspot para o segundo perfil, fui a luta pra tentar fazer mais não consegui teria como voce da uma olhada nessas regra para min desde ja agradeço.

    Código :
    /tool netwatch
    add comment=Link disabled=no down-script="/ip hotspot active ]remove find\r\
        \nname=hotspot1] profile=sem_link\r\
        \n:log error \"SERVIDOR ESTA SEM LINK\":" host=200.154.56.80 interval=5s timeout=\
        1s up-script="/ip hotspot set [/ip hotspot find\r\
        \nname=hotspot1] profile=hsprof1"

  8. #8

    Padrão Re: regras para guando o link cair, ajuda!!!

    Estava por aqui e encontrei algumas respostas suas a dúvidas do pessoal, e em todas, as respostas se parecem muito.(rsssssss)

    Alivia ai com o pessoal rapaz...Abraço.
    To falando alguma asneira velho??
    Primeiro disse que o copiar e colar acaba com o servidor dele.. e é verdade.. tem que ver cada caso.. nesse caso ele foi nas pilha de um cara que vendeu solução errada para ele..
    Em segundo lugar eu dei a solução para o problema dele!

    Em relação a como fazer, varia da sua estrutura..

    Eu posso dar como exemplo meu caso aqui.. onde faço rota estatica de alguns serviços por um link específici..
    Fiz um netwatch pingando o gateway deste link, quando cai, ele habilita ou desabilita a rota...

    Em relação ao criar o script para modificar perfil do hotspot, com certeza dá pra fazer, mas nunca fiz.. so testando aqui..
    abraços



  9. #9

    Padrão Re: regras para guando o link cair, ajuda!!!

    Citação Postado originalmente por amilton Ver Post
    Acompanando. Abs.
    da uma olhada nesse aqui https://under-linux.org/f210/pagina-...xterno-142204/

  10. #10

    Padrão Re: regras para guando o link cair, ajuda!!!

    segui as confg e não vai nem q a vaca tussa,lembrando q tenho um server aqui separado ,e nao redireciona pra lá 172.31.255.2:89