Página 6 de 6 PrimeiroPrimeiro ... 23456
+ Responder ao Tópico



  1. #101

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Olá pessoal! eu esteve ocupado com outros projetos, mais agora estou de volta, observei que esse tópico cresceu juntamente com o forum, e essa minha ideia ajudou a muitos por aqui, fico feliz por isso! eu vi que teve até gente que postou em outros foruns, youtube até no orkut, e alguns não lembraram de dar os créditos ao autor, mais isso não importa!
    o importante é saber que o trabalho que eu tive em algumas noites até, para desenvolver os scripts e testa-los teve um resultado positivo, obrigado aqueles que me prestigiaram com mensagens, desde já deixo um forte abraço para todos!
    estamos aqui para ajudar e ser ajudados, aprender com as experiência dos amigos!

  2. #102

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por FoxLive Ver Post
    Ola pessoal!!! Acho que descobri porque muitos não tão acertando de primeira essa solução maravilhosa que nosso amigo RFjonas postou ai, pelo menos foi o meu caso e acho que a maioria que não conseguiu por causa do mesmo problema

    Percebi que na pasta manutencao do pacote do nosso amigo RFjonas os arquivos login e status estão com a extensão HTML em maiúsculo login.HTML e Status.HTML, resolvi abrindo os arquivos no dreamweaver e salvando novamente em html sem alterar nada na pagina ai a extensão ficou minúsculo login.html e status.html e foi só colocar no mikrotik e katapimba funfo na hora.

    Não sei se isso tem algum fundamento porque sou leigo em HTML e to arranhando o mikrotik mas aqui resolveu.

    Se isso resolver o problema de mais alguém por gentileza posta ai uma resposta pra nós e nossos amigos ai que ainda não conseguirão, e se não resolver posta também. Valeu ai e um prazer ta participando pela primeira vez do fórum abraços a todos.

    Olá FoxLive! não tinha percebido esse detalhe, corrigido ok!



  3. #103

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Olá amigo RFJonas ... obrigado por esse belissimo e sensacional post.. ta de parabenz...
    será q junto com o amigo Jnf00 disponibilizarem os arkivos atualizados com todas as coreções de regas e etc.. sitadas aki nesse post... todos iriam agradecer mas aindah...
    li o post completo do começo ao fim e vi q tem varias modificações e qweria q vc RFJonas postasse aii os arkivos todos atualizados com as modificações citadas aki ...
    pra os mais leigos como euu...
    o amigo Jnf00 citou a criação de um DOC.. para ser postado aki ....
    será q em parceriaa com ele vc pudesse colocar a pra jente vlww desde ja agadeçoo .. suaa jentileza e de todos q ajudaramm ate agorah... parabenz RFJonas

  4. #104

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Funciona com ppoe??



  5. #105

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    jonas otima configuração só não acho a pagina manutenção que vc colocou aki preciso dela para colocar no meu provedor se puder ajudar agradeço vlw

  6. #106

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Uma pequena contribuição...

    Fiz uma pequena modificação no código para que o mesmo pudesse funcionar.

    Eis o meu cenário de teste, PC-MK 3.22 - Hotspot testado com e sem cookies

    No seguinte trecho do codigo em vermelho: Deverá ser removida as barras invertidas, deixando somente entre os Parenteses
    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=manutencao\r\
    \n/ip dns static set [/ip dns static find name=hotspot.seuhotspot.com] address=8.8.8.8\
    comment=\"\" disabled=no name=.* ttl=5s"
    Faça o mesmo em DOWN-LNIK E LINK-UP no Diretório SYSTEM > SCRIPTS > SCRIPT LIST

    Com esse procedimento a regra do Nat abaixo especificada funcionara a contento.
    /ip firewall nat
    add action=redirect chain=dstnat comment=manutencao disabled=yes dst-port=80 protocol=tcp to-ports=64873
    Boa sorte!



  7. #107

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por RFjonas Ver Post
    Tizedosal, eu já estava preocupado com as configurações do seu hotspot! graças a DEUS funfou!

    ATENÇÃO A TODOS!
    o que acontece é que se você não ler o script com atenção antes de colocar em seu MK, não vai perceber uma coisa básica!
    quando você criar o hotspot no MK pela 1ª vez, ele é nomeado em servers como "hotspot1" e em server profiles como "hsprof1"
    -assim como esta no script!
    se você criar o hotspot pela 2ª vez e não excluiu o primeiro completamente antes, oque acontece?
    ele vai ser nomeado em servers como "hotspot2" e em server profiles "hsprof2" e assim sucessivamente,
    agora me diga, porque o script não funciona com o servers "hotspot2"?

    resp: porque o script está procurando o servers "hotspot1" e server profiles "hsprof1"
    o jeito é ou editar o script para seu hotspot ou o seu hotspot para o script!

    espero que assim resolva as duvidas dos demais amigos!
    Tive de ler uma porção de vezes para entender tudo, mais agora está 100%

  8. #108

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por RFjonas Ver Post
    olá pessoal!
    Estou dispondo em anexo todo o tutorial em pdf com as imagens, os scripts em .txt, outra página de manutenção, para aqueles que não tem conhecimento, uma dica onde vão alterar o código HTML para os dados do seu provedor! Há! Vamos clicar na estrelinha ai né!!! Um abraço a todos!
    Há muito tempo não conseguia colocar para funcionar isso. Agora foi.

    O meu erro:

    Não tinham todas as páginas dentro da pasta manutenção, tinha deixado a login.html, assim não funciona, tem que ter todas as outras, alogin.html, redirect.html, etc....

    Valeu,

    Hayttle



  9. #109

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Aqui funcionou 1x só e parou!!!

  10. #110

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por peritinaicos Ver Post
    Aqui funcionou 1x só e parou!!!
    Aqui tb funciona 1 vez e parou
    Deve ser algum detalhe minimo



  11. #111

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Resolvi assim


    ===========================================================
    linkup
    /ip firewall nat disable [find comment="MANUTENCAO"]
    /ip hotspot set [/ip hotspot find name=hotspot1] profile=hsprof1
    ---------------------------------------------------------------------
    linkdown
    /ip firewall nat enable [find comment="MANUTENCAO"]
    /ip hotspot set [/ip hotspot find name=hotspot1] profile=default
    log error "Servidor Sem Link"

    ==============================================================

    /ip firewall nat
    add action=redirect chain=dstnat comment=MANUTENCAO disabled=yes dst-port=80 hotspot="" \
    protocol=tcp to-ports=64873
    add action=masquerade chain=srcnat comment="masquerade hotspot network" disabled=no src-address=\
    172.16.0.0/24 to-addresses=0.0.0.0

    ==============================================================


    Só tem de editar o profile=default com a pasta manutanção onde o LOGIN.HTML e o STATUS.HTML são as páginas de manutenção
    Última edição por icebox; 10-10-2012 às 08:56. Razão: detalhe

  12. #112

    Unhappy Re: Página de manutenção no Mikrotik sem usar servidor

    kd os arquivos para download? pagina de manutencao?