+ Responder ao Tópico



  1. #41

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por RFjonas Ver Post
    ok! faça um teste ai dessa forma, não é o profile que vai mudar e sim o diretorio html, faça manualmente, em ip/hotspot/server profile em html directory mude para o diretorio manutencao e teste ai, há! post ai como esta o seu hotspot, eu testei com web proxy aqui e funfou redondinho! vamos colocar esse negocio p funfar!!!!rsrsrs
    /ip hotspot export
    RFjonas, se coloco manualmente vai sem problema, e pra postar o hotspot tudo, porque e muito grande..

  2. #42

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Aqui também manualmente vai mas na hora que o link cai, nada acontece, os scripts não ativam o nat e nem o diretório manutencao. Digitei os comandos do script no New Terminal e ativou e desativou o nat e o diretório, ou seja, algo esta impedindo o disparo dos scripts. Estou postando os scripts como estão aqui:

    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall na\
    t enable [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=manutencao\r\
    \n/ip dns static set [/ip dns static find name=abgsinformatica.com.br] add\
    ress=8.8.4.4 comment=\"\" disabled=no name=.* ttl=5s"
    add name=LINK-UP policy=ftp,reboot,read,write,winbox source="/ip firewa\
    ll nat disable [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=hotspot\r\
    \n/ip dns static set [/ip dns static find name=.*] address=192.168.0.1 com\
    ment=\"\" disabled=no name=abgsinformatica.com.br ttl=5s\r\
    \n\r\
    \n"
    add name=REMOVER-DNS-DINAMICO policy=ftp,read,write,winbox source="/ip dns sta\
    tic remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinam\
    ico]"


    Será que tem algo errado ai? Lembrando que na versão do MK que uso (3.30) não tem a opção "ftp" em script.
    Última edição por amilton; 18-10-2010 às 17:57.



  3. #43

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por amilton Ver Post
    Aqui também manualmente vai mas na hora que o link cai, nada acontece, os scripts não ativam o nat e nem o diretório manutencao. Digitei os comandos do script no New Terminal e ativou e desativou o nat e o diretório, ou seja, algo esta impedindo o disparo dos scripts. Estou postando os scripts como estão aqui:

    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall na\
    t enable [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=manutencao\r\
    \n/ip dns static set [/ip dns static find name=abgsinformatica.com.br] add\
    ress=8.8.4.4 comment=\"\" disabled=no name=.* ttl=5s"
    add name=LINK-UP policy=ftp,reboot,read,write,winbox source="/ip firewa\
    ll nat disable [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=hotspot\r\
    \n/ip dns static set [/ip dns static find name=.*] address=192.168.0.1 com\
    ment=\"\" disabled=no name=abgsinformatica.com.br ttl=5s\r\
    \n\r\
    \n"
    add name=REMOVER-DNS-DINAMICO policy=ftp,read,write,winbox source="/ip dns sta\
    tic remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinam\
    ico]"


    Será que tem algo errado ai? Lembrando que na versão do MK que uso (3.30) não tem a opção "ftp" em script.
    Amilton o script esta certo, se não esta funcionando então o problema esta no hotspot.
    o script não esta indentificando as configurações que nele esta setadas por isso não executa corretamente.
    - verifica se o seu hotspot na aba SERVERS está = hotspot1 e em profile = hsprof1
    - em SERVER PROFILES = hsprof1
    - veja tambem IP/DNS STATIC tem que criar um dns static com address = 192.168.0.1
    e name = abgsinformatica.com.br .
    se tudo isso estiver ok e não funfar post as cofigurações do seu hotspot que eu te ajudo a verificar.
    outra coisa! não é problema da versão do seu MK! esqueça esse ftp do system script!
    o erro esta na cofiguraração do seu hotspot que não está igual a do script, só isso! depois vou explicar por que isso acontece!
    Última edição por RFjonas; 19-10-2010 às 16:25.

  4. #44

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por tizedosal Ver Post
    RFjonas, se coloco manualmente vai sem problema, e pra postar o hotspot tudo, porque e muito grande..
    olá tizedosal!
    o erro esta no seu hotspot que não esta igual ao script!
    - verifica se o seu hotspot na aba SERVERS está = hotspot1 e em profile = hsprof1
    - em SERVER PROFILES = hsprof1
    - veja tambem IP/DNS STATIC tem que criar um dns static com name = que você usa no seu hotspot em dns-name e com address = o ip do seu hotspot.
    se poder post as cofigurações do seu hotspot so a parte servers e server profile.
    Última edição por RFjonas; 19-10-2010 às 16:30.



  5. #45

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    RFjonas, vc é o cara, irmão. O problema aqui era o nome do SERVERS, troquei e funfou. Algumas vezes, acontece do servidor 8.8.8.8 ficar down e apenas ele. Teria por acaso outro server pra gente ficar pingando, que não saisse do ar ? Agradeço por toda a sua paciência e ajuda e fique com DEUS.
    PS. vou já clicar na estrelinha.

  6. #46

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por amilton Ver Post
    RFjonas, vc é o cara, irmão. O problema aqui era o nome do SERVERS, troquei e funfou. Algumas vezes, acontece do servidor 8.8.8.8 ficar down e apenas ele. Teria por acaso outro server pra gente ficar pingando, que não saisse do ar ? Agradeço por toda a sua paciência e ajuda e fique com DEUS.
    PS. vou já clicar na estrelinha.
    Valeu Amilton!
    a questão do host estável que o netwatch vai monitorar é individual de cada um, por que depende muito do seu link com sua operadora, por exemplo aqui esse host 8.8.8.8 dns do google varia de 40ms a 50ms e é um host confiável, não sai do ar assim tão facilmente.
    você pode testar alguns ai e ver qual o mais estável exemplo:
    - globo.com = 201.7.176.59
    - terra.com.br = 200.154.56.80
    - uol.com.br = 200.221.2.45 ou até mesmo o dns de sua operadora!
    você pode até digitar o nome do host que seu MK resolve os "numeros"!
    outra coisa você pode tambem alterar no netwatch o timeout, por ex: de 1000ms 2000ms ... 5000ms ...
    que significa o tempo de resposta do host.
    ok! um abraço, qualquer coisa estamos ai!
    Última edição por RFjonas; 12-02-2011 às 09:09.



  7. #47

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Pessoal estou desenvolvendo outro metodo para quem trabalha com RB em BRIDGE!
    vai ser "página de manutenção no mikrotik em bridge sem usar servidor externo e tal... e tal..."
    aguardem, já esta funfando, estou preparando o tuto...!

  8. #48
    Não Registrado(s)
    Visitante

    Thumbs up Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por RFjonas Ver Post
    Pessoal estou desenvolvendo outro metodo para quem trabalha com RB em BRIDGE!
    vai ser "página de manutenção no mikrotik em bridge sem usar servidor externo e tal... e tal..."
    aguardem, já esta funfando, estou preparando o tuto...!
    essa eu quero ver! estou procurando algo desse tipo a muito tempo, a fiz de tudo mais não deu certo.
    se de certo aqui ai VOCÊ É O CARA MESMO!



  9. #49

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por Não Registrado(s) Ver Post
    essa eu quero ver! estou procurando algo desse tipo a muito tempo, a fiz de tudo mais não deu certo.
    se de certo aqui ai VOCÊ É O CARA MESMO!
    Será um fantasma ???
    estou preparando o tutorial, quando estiver pronto posto aqui!
    se você tiver dificuldade para configurar agente te ajuda!
    Há! registre-se, participe do fórum é gratuito!
    um abraço!
    Última edição por RFjonas; 21-10-2010 às 00:36.

  10. #50

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Gasparzinho (no bom sentido), pode crer no amigo RFjonas que ele consegue sim e é mesmo "o cara". Parabéns mais uma vez RFjonas amigão. Mudei o server no netwatch e aumentei o timeout pra 5000 e até agora 100% de eficiência.



  11. #51

    Thumbs up Re: Página de manutenção no Mikrotik sem usar servidor

    RFjonas, vou ser sincero ja tinha desistido, de colocar essa tela, não conseguia de jeito algum, dei uma vasculhada no site e comecei a usar essa regra:
    Código :
    /tool netwatch add host=8.8.8.8 timeout=100 interval=5s down-script="/ip dns static add name=".*" address=192.168.0.1" up-script="/ip dns static remove [/ip dns static find dynamic=no]"
    funciona legal mais a galera perde a pagina de status, ai fica sem se desconectar, porque a pagina de manutenção fica como pagina de status quando o link cai.
    mais aqui a galera gosta de se desconectar pra ver filme ou baixar programa na rede, o telefone não parou de tanta reclamação, como sou brasileiro e nunca desisto tentei mais uma vez refiz tudo do zero e não é que consegui, ficou uma beleza, desde ja agradeço a ajuda da galera e do nosso amigo RFjonas valeu mesmo............brigadãoooooooooooooo

  12. #52

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por amilton Ver Post
    Gasparzinho (no bom sentido), pode crer no amigo RFjonas que ele consegue sim e é mesmo "o cara". Parabéns mais uma vez RFjonas amigão. Mudei o server no netwatch e aumentei o timeout pra 5000 e até agora 100% de eficiência.
    Amilton muito obrigado pelo prestígio!
    precisando pode contar comigo!



  13. #53

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por tizedosal Ver Post
    RFjonas, vou ser sincero ja tinha desistido, de colocar essa tela, não conseguia de jeito algum, dei uma vasculhada no site e comecei a usar essa regra:
    Código :
    /tool netwatch add host=8.8.8.8 timeout=100 interval=5s down-script="/ip dns static add name=".*" address=192.168.0.1" up-script="/ip dns static remove [/ip dns static find dynamic=no]"
    funciona legal mais a galera perde a pagina de status, ai fica sem se desconectar, porque a pagina de manutenção fica como pagina de status quando o link cai.
    mais aqui a galera gosta de se desconectar pra ver filme ou baixar programa na rede, o telefone não parou de tanta reclamação, como sou brasileiro e nunca desisto tentei mais uma vez refiz tudo do zero e não é que consegui, ficou uma beleza, desde ja agradeço a ajuda da galera e do nosso amigo RFjonas valeu mesmo............brigadãoooooooooooooo
    Tizedosal, eu já estava preocupado com as configurações do seu hotspot! graças a DEUS funfou!

    ATENÇÃO A TODOS!
    o que acontece é que se você não ler o script com atenção antes de colocar em seu MK, não vai perceber uma coisa básica!
    quando você criar o hotspot no MK pela 1ª vez, ele é nomeado em servers como "hotspot1" e em server profiles como "hsprof1"
    -assim como esta no script!
    se você criar o hotspot pela 2ª vez e não excluiu o primeiro completamente antes, oque acontece?
    ele vai ser nomeado em servers como "hotspot2" e em server profiles "hsprof2" e assim sucessivamente,
    agora me diga, porque o script não funciona com o servers "hotspot2"?

    resp: porque o script está procurando o servers "hotspot1" e server profiles "hsprof1"
    o jeito é ou editar o script para seu hotspot ou o seu hotspot para o script!

    espero que assim resolva as duvidas dos demais amigos!
    Última edição por RFjonas; 22-10-2010 às 01:56.

  14. #54

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Foi isso mesmo que ocorreu comigo. Pura falta de atenção,



  15. #55
    Luiz Paulo
    Visitante

    Cool Re: Página de manutenção no Mikrotik sem usar servidor

    Ao amigo RFJonas... Mais uma vez parabens.... aqui ta funcioando perfeitamente dessa forma.....

    Consegui com essas alterações aqui óóóó...

    /ip dns static
    add address=IP DO MK disabled=no name=MEU DNS ttl=5s


    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set default html-directory=manutencao\r\
    \n/ip hotspot active remove [/ip hotspot active find]\r\
    \n/ip hotspot cookie remove [/ip hotspot cookie find]\r\
    \n/ip hotspot host remove [/ip hotspot host find]\r\
    \n\r\
    \n"
    add name=LINK-UP policy=ftp,read,write,winbox source="/ip firewall nat disable\
    \_[find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set default html-directory=hotspot\r\
    \n"
    add name=REMOVER-DNS-DINAMICO policy=ftp,read,write,winbox source="/ip dns sta\
    tic remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinam\
    ico]"


    /system scheduler
    add comment="" disabled=yes interval=5s name=remover_dns_dinamico on-event=\
    REMOVER-DNS-DINAMICO policy=\
    reboot,read,write,policy,test, password,sniff,sensitive start-date=\
    jan/01/1970 start-time=00:00:00


    /tool netwatch
    add comment="MONITORAR LINK" disabled=no down-script=\
    "/ system script run DOWN-LINK\r\
    \n" host=8.8.8.8 interval=5s timeout=1s up-script="/system scheduler enabl\
    e [/system scheduler find name=remover_dns_dinamico]\r\
    \n/ system script run LINK-UP\r\
    \n"

    com esse ficou 100% AQUI NO MEU server... (com clientes que usam login e senha)

    mais ainda estou com uma duvida... para clientes que estao configurados para logar automaticamente (AUTENTICAÇÃO POR MAC) não funciona... acredito eu.... que seja pelo fato desse tipo de autenticão nao ser redirecionado para pagina de login..... se eu estiver errado por favor me digam...

    então fica a pergunta....

    Tem como redirecionar esses tipos de clientes tambem...para essa pagina de manutenção quando solicitarem a pagina e nao houver link ?

    Aguardo e desde ja agradeço.....

    Abração...

    Att.
    Luiz Paulo

  16. #56

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por Luiz Paulo Ver Post
    Ao amigo RFJonas... Mais uma vez parabens.... aqui ta funcioando perfeitamente dessa forma.....

    Consegui com essas alterações aqui óóóó...

    /ip dns static
    add address=IP DO MK disabled=no name=MEU DNS ttl=5s


    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set default html-directory=manutencao\r\
    \n/ip hotspot active remove [/ip hotspot active find]\r\
    \n/ip hotspot cookie remove [/ip hotspot cookie find]\r\
    \n/ip hotspot host remove [/ip hotspot host find]\r\
    \n\r\
    \n"
    add name=LINK-UP policy=ftp,read,write,winbox source="/ip firewall nat disable\
    \_[find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set default html-directory=hotspot\r\
    \n"
    add name=REMOVER-DNS-DINAMICO policy=ftp,read,write,winbox source="/ip dns sta\
    tic remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinam\
    ico]"


    /system scheduler
    add comment="" disabled=yes interval=5s name=remover_dns_dinamico on-event=\
    REMOVER-DNS-DINAMICO policy=\
    reboot,read,write,policy,test, password,sniff,sensitive start-date=\
    jan/01/1970 start-time=00:00:00


    /tool netwatch
    add comment="MONITORAR LINK" disabled=no down-script=\
    "/ system script run DOWN-LINK\r\
    \n" host=8.8.8.8 interval=5s timeout=1s up-script="/system scheduler enabl\
    e [/system scheduler find name=remover_dns_dinamico]\r\
    \n/ system script run LINK-UP\r\
    \n"

    com esse ficou 100% AQUI NO MEU server... (com clientes que usam login e senha)

    mais ainda estou com uma duvida... para clientes que estao configurados para logar automaticamente (AUTENTICAÇÃO POR MAC) não funciona... acredito eu.... que seja pelo fato desse tipo de autenticão nao ser redirecionado para pagina de login..... se eu estiver errado por favor me digam...

    então fica a pergunta....

    Tem como redirecionar esses tipos de clientes tambem...para essa pagina de manutenção quando solicitarem a pagina e nao houver link ?

    Aguardo e desde ja agradeço.....

    Abração...

    Att.
    Luiz Paulo
    Aqui cadastrei os clientes que não passam pelo hotspot no IP Binding e a página de queda do link aparece normal. Faz esse teste ai e vê se funfa.



  17. #57

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    amigo RFJonas eu tow batendo cabeça aqui em um MK PC-AP com o 2.9.27

    fiz umas mudanças no Script mais ainda não consegui entender umas partes

    tipo essa parte

    /ip dns static
    add address=IP DO MK disabled=no name=MEU DNS ttl=5s esse MEUS DNS e isso que ta me confundindo e alguem testow em um Mk 2.9.27 ?

    agradeço a vc por abrir esse topico e tar ajudando a galera

  18. #58

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    No add address=Aqui é o IP do seu MK e onde esta name=É o nome da sua rede.com.br ouseja o nome pra onde o ip vai apontar.
    Aqui o ip do meu MK é 192.168.0.1 e o nome da rede tá abgsinformatica.com.br e lembrando que não é um endereço de internet válido, pois o mk tem que apontar pro ip interno, se não colocar nome, vai aparecer somente o ip quando for solicitado pelo navegador.
    Espero ter ajudado e fique com DEUS.



  19. #59

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    ok vlw amigo ta ficando mais claro pra mim
    mais alguem ja testow aqui em um Mk PC-AP 2.9.27

    mudei aqui mais quando passo pelo new terminal da uns erros

    ai fui fazendo passo a passo mesmo mais ainda sem sucesso

    qq coisa eu posto aqui no forum

    mais tudo bem

  20. #60

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Caro amigo RFJonas , estou tentando de todas as formas ja revi o script e não encontro o erro, vou postar aqui como estar meu hotspot e o script como esta, se pode me ajudar a resolver , agradeço muito pela ajuda.


    /ip hotspot profile
    set default dns-name="" hotspot-address=0.0.0.0 html-directory=hotspot \
    http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=cookie,http-chap \
    name=default rate-limit="" smtp-server=0.0.0.0 split-user-domain=no \
    use-radius=no
    add dns-name=cyber.speednetbc.com.br hotspot-address=192.168.251.254 \
    html-directory="hotspot speednet_01" http-cookie-lifetime=1d http-proxy=\
    0.0.0.0:0 login-by=cookie,http-chap name=hotspot-cyber rate-limit="" \
    smtp-server=0.0.0.0 split-user-domain=no use-radius=no
    add dns-name=speednetbc.com.br hotspot-address=192.168.254.254 \
    html-directory="hotspot speednet_01" http-cookie-lifetime=5h http-proxy=\
    0.0.0.0:0 login-by=cookie,http-chap name=hotspot-wireless rate-limit="" \
    smtp-server=0.0.0.0 split-user-domain=no use-radius=no
    /ip hotspot
    add disabled=no idle-timeout=5m interface=WIRELESS keepalive-timeout=none \
    name=Hotspot-Wireless profile=hotspot-wireless
    add disabled=no idle-timeout=5m interface=CYBER keepalive-timeout=none name=\
    Hotspot-Cyber profile=hotspot-cyber




    e o script esta assim......

    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hotspot-wireless html-directory=manutencao\r\
    \n/ip dns static set [/ip dns static find name=speednetbc.com.br] address=8.8.4\
    .4 comment=\"\" disabled=no name=.* ttl=5s"
    add name=LINK-UP policy=ftp,reboot,read,write,winbox source="/ip firewall nat \
    disable [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hotspot-wireless html-directory=hotspot\r\
    \n/ip dns static set [/ip dns static find name=.*] address=192.168.254.254 comm\
    ent=\"\" disabled=no name=speednetbc.com.br ttl=5s\r\
    \n\r\
    \n"
    add name=REMOVER-DNS-DINAMICO policy=ftp,read,write,winbox source="/ip dns sta\
    tic remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinam\
    ico]"

    /system scheduler
    add comment="" disabled=yes interval=5s name=remover_dns_dinamico on-event=\
    "/ system script run REMOVER-DNS-DINAMICO" policy=read,write start-time=\
    startup

    /ip firewall nat
    add action=redirect chain=dstnat comment=MANUTENCAO disabled=yes dst-port=80 \
    protocol=tcp to-ports=64873

    /ip dns static
    add address=192.168.254.254 comment="" disabled=no name=speednetbc.com.br ttl=5s

    /tool netwatch
    add comment="MONITORAR LINK" disabled=no down-script=\
    "/ system script run DOWN-LINK\r\
    \n" host=8.8.8.8 interval=5s timeout=1s up-script="/system scheduler enabl\
    e [/system scheduler find name=remover_dns_dinamico]\r\
    \n/ system script run LINK-UP\r\
    \n/ queue simple remove hs-<hotspot1>"