+ Responder ao Tópico



  1. #1

    Padrão Cache Full em Mikrotik v3.30

    Olá boa Noite a Todos.

    Não sei como montar meu Cache Full na versão 3.30, montei o PC recente mente somente para o cache full. Já está instalado o Software, Encontrei o Wiki mas a minha versão é diferente, alguem pode me ajudar ? Meu senario é:

    Modem adsl como router. - 192.168.1.0/24
    RB433AH - 192.168.1.2/24 com Cartão Wireless 192.168.2.0/24
    Pc Intel Celeron Dual Core 1Gb ram / HD 160GB C/ 2 Interfaces de rede 10/100

    Des de já Agradeço.

  2. #2

    Padrão Re: Cache Full em Mikrotik v3.30

    Tb estou tentado fazer aqui na versão 3.30, mas ate agora não funfou nada.
    Alguem ai tem un sclipt com web proxy e cache full na versão 3.30 pra gente da uma analizada melhor...



  3. #3

    Padrão Re: Cache Full em Mikrotik v3.30

    /ip firewall nat
    add action=redirect chain=dstnat comment="redirect port 80 to 8080" \
    disabled=no dst-port=80 protocol=tcp src-address=192.168.1.0/24 \
    to-ports=8080

    /ip firewall mangle
    add action=mark-connection chain=output comment=\
    "mark connection *conn_squid-up*" content="X-Cache: HIT" disabled=\
    no new-connection-mark=conn_squid-up passthrough=yes protocol=tcp \
    src-port=8080
    add action=mark-packet chain=output comment=\
    "mark packet *pacotes_squid-up*" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment=\
    "mark connection *conn_squid-down*" disabled=no dst-port=8080 \
    new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment=\
    "mark packet *pacotes_squid-down*" connection-mark=conn_squid-down \
    disabled=no new-packet-mark=pacotes_squid-down passthrough=yes

    /ip firewall filter
    add action=drop chain=input comment="Bloqueio de Proxy Externo" disabled=no \
    dst-port=8080 in-interface=public protocol=tcp
    add action=accept chain=input comment="Aceita Conexao Proxy" \
    disabled=no dst-port=8080 protocol=tcp

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=\
    0 max-limit=150M name=downstream packet-mark=pacotes_squid-down \
    parent=global-in priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=\
    0 max-limit=150M name=upstream packet-mark=pacotes_squid-up parent=\
    global-out priority=1 queue=default

    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=800000000KiB \
    max-client-connections=600 max-fresh-time=3d \
    max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 \
    port=8080 serialize-connections=no src-address=0.0.0.0

    /ip proxy access
    add action=deny comment="block telnet & spam e-mail relaying" disabled=\
    no dst-port=23-25

    Ps: Não esqueça de mudar a faixa de IP para o da sua REDE. Depois é só copiar e colar no NEW TERMINAL.

    >> Se foi últil AGRADEÇA!. <<
    Última edição por Sloth; 20-10-2010 às 12:53.

  4. #4

    Padrão Re: Cache Full em Mikrotik v3.30

    in-interface=public no seu caso e a porta lan ou a wan?



  5. #5

    Padrão Re: Cache Full em Mikrotik v3.30

    Boa Tarde...

    Opa aqui deu certiho, testei e ele ta fazendo Cache e liberando tudo certin.
    Tenho apenas mais 1 duvida.

    Senario:

    1 Modem adsl Thomson 8MB Config. Router.
    1 PC Intel Celeron DC - 1Gb RAM - 160GB HD - 2 Interf. Ethernet.
    1 RB433AH
    1 Cartão Wireless MiniPCI

    Como disse configurei um servidor proxy paralelo a RB onde estão conectados os Clientes.

    Agora com o Servidor, quem faz o Controle de Banda é o Servidor de Cache ou a RB ?
    Devo Alterar alguma coisa na RB?

    Valew Amigo!

  6. #6

    Padrão Re: Cache Full em Mikrotik v3.30

    Sombra! Porta WAN (Link)






    >> Se foi Util Agradeça <<
    Última edição por Sloth; 20-10-2010 às 18:22.



  7. #7

    Padrão Re: Cache Full em Mikrotik v3.30

    BRparra, faz no servidor mesmo!

  8. #8

    Padrão Re: Cache Full em Mikrotik v3.30

    Então eu fiz a Alteração na RB.

    Alterei a Rota de Saida e IP.
    A RB entende que o Gateway dela é o Servidor Cache.

    Ai que tá, la fizemos o roteamento da porta 80 para 8080, para o usar o proxy, e este redirecionamento não precisa ser feito na RB tbm ?

    O proxy funciono legal, mas testei agora dinovo de um arquivo que já tinha baixado e ele fez o download normal, limitando a velocidade, ou seja não funciono!

    valew !