+ Responder ao Tópico



  1. #1

    Padrão Relatório acesso ao proxy do Debian em paralelo com mikrotik não mostra ip da rede.

    Sou administrador de redes e sempre trabalhei com debian, mas depois de conhecer o mikrotik migrei para o mesmo, no entanto como sabemos o cache do MK possui limitações e fiz um Cache em paralelo com debian.

    minha extrutura está assim então:

    Link --- MK - Debian (cache)
    |
    Rede local

    Meu problema com o proxy do mikrotik é que não consegui encontrar um programa que me auxilie nos log's de acesso dos usuários às páginas, por isso resolvi migrar o proxy para o debian... no entanto no SARG (gerador de relatórios do proxy do Debian) aparece somente o IP do Mikrotik. Como faço para no relatório do sarg que tiro do proxy aparecer os IP's dos terminais da minha rede. tentei fazer a regra postada acima, mas continua aparecendo somente o ip do mk..

  2. #2
    Visitante

    Padrão Re: Relatório Acesso ao Proxy do Debian em parelelo com mikrotik não mostra ip da rede.

    Boa noite

    O segredo e fazer um NAT na rede do seu proxy antes do redirecionamento para o proxy



  3. #3

    Padrão Re: Relatório Acesso ao Proxy do Debian em parelelo com mikrotik não mostra ip da rede.

    Acompanhando...

  4. #4

    Padrão Re: Relatório Acesso ao Proxy do Debian em parelelo com mikrotik não mostra ip da rede.

    Isto ai vai depender das suas confs no seu MK, tanto do nat como no dst nat para o seu server.

    Ivan Galves



  5. #5

    Padrão Re: Relatório Acesso ao Proxy do Debian em parelelo com mikrotik não mostra ip da rede.

    Boa Tarde amigo, minhas regras no mk estão o mais simples possível, somente para funcionar o cache paralelo por enquanto.

    /ip firewall nat
    add action=masquerade chain=srcnat comment="Mascarate para Clientes" \
    disabled=no src-address=172.16.1.0/24
    add action=masquerade chain=srcnat comment="Mascarate para Linux" disabled=no \
    src-address=10.10.10.0/24


    Aguardo.

  6. #6

    Padrão Re: Relatório Acesso ao Proxy do Debian em parelelo com mikrotik não mostra ip da rede.




  7. #7

    Padrão Re: Relatório Acesso ao Proxy do Debian em parelelo com mikrotik não mostra ip da rede.

    Boa Tarde amigo, vc. pode me falar quais são essas regras.?

  8. #8

    Padrão Re: Relatório Acesso ao Proxy do Debian em parelelo com mikrotik não mostra ip da rede.

    No Debian Proxy:

    nano /etc/network/interfaces
    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 172.31.255.3
    netmask 255.255.255.248
    network 172.31.255.0
    broadcast 172.31.255.7
    gateway 172.31.255.1
    dns-nameservers 8.8.8.8
    -----------------------------------------------------------------------------------------------------------------------------
    no rc.local fica as regras de firewall:
    nano /etc/rc.local

    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT --to-port 3128

    # route add -net [rede dos clientes] gw [ip do mikrotik que conversa com o cache]
    route add -net 192.168.0/24 gw 172.31.255.1
    ------------------------------------------------------------------------------------------------

    No Mikrotik:

    Internet: 200.200.200.200/24
    Proxy: 172.31.255.1/29
    RedeLocal: 192.168.0.1/24
    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração das placas e dos IP's
    interface set ether1 name=Internet
    interface set ether2 name=Proxy
    interface set ether3 name=Clientes

    ip address add address=200.200.200.200/24 interface=Internet
    ip address add address=172.31.255.1/29 interface=Proxy
    ip address add address=192.168.0.1/24 interface=Clientes

    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de DNS
    # ip dns static add address=[gateway da rede dos clientes] name=192.168.0.1
    ip dns static add address=192.168.0.1 name=192.168.0.1

    ip dns set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de Gateway
    ip route add gateway=200.200.200.1

    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de Radius
    # radius add address=[IP do MK-Auth] service=hotspot secret=123456
    radius add address=172.31.255.2 service=hotspot secret=123456

    obs: Estou usando Mikrotik v4.11 para setar dns em versões antigas é diferente.

    -----------------------------------------------------------------------------------------------------------------------------
    no mikrotik regras de nat:

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no src-address=172.31.255.0/29
    add action=masquerade chain=srcnat comment="Conectividade Social" disabled=no dst-address=200.201.160.0/24
    add action=masquerade chain=srcnat comment="" disabled=no dst-address=200.201.166.0/24
    add action=masquerade chain=srcnat comment="" disabled=no dst-address=200.201.173.0/24
    add action=masquerade chain=srcnat comment="" disabled=no dst-address=200.201.174.0/24
    add action=dst-nat chain=dstnat comment="Redireciona a porta 80 para o proxy" disabled=no dst-port=80 in-interface=Clientes protocol=tcp src-address=!172.31.255.0/29 to-addresses=172.31.255.3
    add action=masquerade chain=srcnat comment="" disabled=no dst-port=!80 protocol=tcp
    add action=masquerade chain=srcnat comment="" disabled=no dst-port=!80 protocol=udp
    add action=masquerade chain=srcnat comment="" disabled=no protocol=icmp
    add action=masquerade chain=srcnat comment="Mascaramento Geral" disabled=yes

    -----------------------------------------------------------------------------------------------------------------------------
    Para acesso Externo ao Servidor:
    /ip firewall nat
    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=1880 protocol=tcp to-addresses=172.31.255.2 to-ports=80

    Tenha como base essas regras... Qualquer duvida é so falar... Olha fiz as regras de nat aqui agora de acordo com o que eu penso que vai te servir, qualquer duvida posta ai...
    Última edição por wilkerpaz; 03-01-2011 às 21:11.



  9. #9

    Padrão Re: Relatório Acesso ao Proxy do Debian em parelelo com mikrotik não mostra ip da rede.

    Bom dia amigo, fico mto grato por sua ajuda. fiz todos os procedimentos citados e o cache e o proxy estão funcionando perfeitamente, no entanto no sarg ainda não aparece os ip's dos clientes da rede mas somente o ip do mikrotik. ficarei mto grato se conseguir me passar quais regras devo adicionar para que isso ocorra.

  10. #10

    Padrão Re: Relatório acesso ao proxy do Debian em paralelo com mikrotik não mostra ip da rede.

    Amigo as regras estão ai olha direirinho no tutorial não esquece de clicar na estrelinha pra agradecer rss:

    # route add -net [rede dos clientes] gw [ip do mikrotik que conversa com o cache]
    route add -net 192.168.0/24 gw 172.31.255.1



  11. #11

    Padrão Re: Relatório acesso ao proxy do Debian em paralelo com mikrotik não mostra ip da rede.

    Nas regras de mascaramento, você adiciona em src-address a range que vai mascarar e na out-interface a interface do seu link de internet. Apartir desse momento os ips mascarados passam a ser reconhecidos individualmente no seu servidor de proxy/cache.

  12. #12

    Padrão Re: Relatório acesso ao proxy do Debian em paralelo com mikrotik não mostra ip da rede.

    Acompanhando.



  13. #13

    Wink Re: Relatório acesso ao proxy do Debian em paralelo com mikrotik não mostra ip da rede.

    Já resolveu amigo? Isso é bastante simples de se fazer....

    Basta vc adicionar no Nat Masquerade da sua rede local (clientes) a interface da sua internet em out.Interface

    EX :
    /ip firewall nat
    add chain=masquerade src-address=IP DOS SEUS CLIENTES action=srcnat comment="NAT - CLIENTES" disabled=no Out. Interface= link da internet .

    Só isso e ja resolve. Tenho funcionando aqui.
    =)