+ Responder ao Tópico



  1. #1

    Padrão Web proxy em RB 750 sem cache

    Amigos, gostaria de ativar o web proxy numa rb 750 (versão mk 4.11), mas não queria fazer cache de páginas, pois meu objetivo era simplemente fazer filtro de conteúdo e redirecionamento de propaganda do orkut, google, msn e afins.
    Utilizo esta rb para simplesmente fazer load balance, o restante é feito por um pc rodando MK 2.9.51.
    Alguém porderia me ajudar nesta empreitada ?, grato desde já.

  2. #2

    Padrão Re: Web proxy em RB 750 sem cache

    Aqui:
    Mikrotik - Under-Linux.Org Wiki

    No Mk 4.11 muda o nome de algumas opções mas nada dificil.

    Para não fazer cache no HD, desmarque a opção "Cache on Disk" nas configuracoes iniciais do webproxy.



  3. #3

    Padrão Re: Web proxy em RB 750 sem cache

    Amigo, veja ai minhas regras por favor, o problema é que quando ativo o redirecionamento da porta 80 para 3128 para de navegar, quando desativo volta a navegar novamente.

    /ip firewall filter
    add action=accept chain=input comment="ACEITAR CONEXOES PROXY" disabled=no dst-port=3128 in-interface=SAIDA protocol=tcp
    /ip firewall nat
    add action=redirect chain=dstnat comment="redirect port 80 to 3128" disabled=yes dst-port=80 protocol=tcp to-ports=3128
    add action=masquerade chain=srcnat comment="MASCARAMENTO DAS INTERFACES DOS MODENS" disabled=no out-interface=DISK2
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=DISK1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=SAIDA
    /ip proxy
    set always-from-cache=no cache-administrator=ADMINISTRADOR cache-hit-dscp=4 cache-on-disk=no enabled=yes max-cache-size=none max-client-connections=200 \ max-fresh-time=3d max-server-connections=200 parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=deny comment="block telnet & spam e-mail relaying" disabled=no dst-port=23-25
    /ip proxy cache
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\\\?"
    add action=deny comment="" disabled=no dst-host=caixa.gov.br
    add action=deny comment="" disabled=no dst-host=bb.gov.br
    add action=deny comment="" disabled=no dst-host=https://

  4. #4

    Padrão Re: Web proxy em RB 750 sem cache

    Vc ativou o webproxy?
    Conferiu se está configurado na porta 3128?



  5. #5

    Padrão Re: Web proxy em RB 750 sem cache

    Tá desta forma
    Clique na imagem para uma versão maior

Nome:	         PROXY.JPG
Visualizações:	1028
Tamanho: 	36,8 KB
ID:      	17640
    Clique na imagem para uma versão maior

Nome:	         PROXY.JPG
Visualizações:	1028
Tamanho: 	36,8 KB
ID:      	17640Clique na imagem para uma versão maior

Nome:	         PROXY.JPG
Visualizações:	1028
Tamanho: 	36,8 KB
ID:      	17640Clique na imagem para uma versão maior

Nome:	         NAT2.jpg
Visualizações:	686
Tamanho: 	39,9 KB
ID:      	17641Clique na imagem para uma versão maior

Nome:	         NAT1.jpg
Visualizações:	648
Tamanho: 	75,1 KB
ID:      	17642

  6. #6

    Padrão Re: Web proxy em RB 750 sem cache

    Ao criar a regra de direcionamento, especifique IN INTERFACE, coloque a interface que está ligado aos clientes e teste.

    Se nao funcionar, poste as tela Access em IP/Webproxy.



  7. #7

  8. #8

    Padrão Re: Web proxy em RB 750 sem cache

    Olá Amigos, estou ressuscitando este POST pois estou no mesmo dilema, já li e reli todas as dicas sobre o weproxy que eu encontrei, minha RB750 foi comprada para ser usada em uma rede interna aqui na empresa com no máximo 6 máquinas, quero apenas bloquear alguns endereços, mais nada, e tudo isso SEM CACHE, pois sei que ela é bem limitada e não queria por mais uma máquina com LINUX só para fazer isso.

    Fiz tudo conforme ensinado em vários post e artigos, ativei o webproxy, escolhi a porta que ele irá escutar, só não encontrei a opção de proxy transparente nele, fui no firewal fiz a regra nat dstnat na interface interna redirecionando para a porta do webproxy, mas aí ele para de navegar geral. Ele está funcionando normalmente para navegação com o firewall masquerade, só não funciona quanto tento usar o webproxy, outra observação, nenhum dos PCs está precisando se autenticar em nada, eles simplesmente estão navegando normalmente com a Rb750. Alguma dica de alguém que já usou uma RB750 para estes fins?

    Obrigado pela Atenção!!