+ Responder ao Tópico



  1. #1

    Padrão Cache Full...

    alguem sabe me dizer se consegui colocar o cache full com hotspot com thunder em paralelo? sem hotspot vai de boa...qdo ativa o hotspot nao vai...segue as regras ai...

    /ip firewall nat
    add action=dst-nat chain=pre-hotspot comment=CONLINUX content=!https \
    disabled=no dst-address-list=!sem_cache dst-port=80 hotspot=auth port=\
    !443 protocol=tcp src-address=!192.168.100.250 src-address-list=\
    !sem_cache_src to-addresses=192.168.100.250 to-ports=3128
    add action=dst-nat chain=dstnat comment=CONLINUX4 content=!https disabled=no \
    dst-address-list=!sem_cache dst-port=80 protocol=tcp src-address=\
    !192.168.100.250 to-addresses=192.168.100.250 to-ports=3128

    /ip firewall mangle
    add action=mark-connection chain=postrouting comment="## THUNDER 5 ##" \
    content="X-Cache: HIT from Thunder" disabled=no new-connection-mark=\
    cache-full passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=postrouting comment="" connection-mark=\
    cache-full disabled=no new-packet-mark=Cache-HIT passthrough=yes

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M \
    max-limit=1M name=THUNDER5 packet-mark=Cache-HIT parent=global-out \
    priority=2 queue=wireless-default

  2. #2
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Cache Full...

    Uso aki com o thudner e lusca em maquina paralela com hotspot e ta perfeito a meses

    172.31.255.2 Proxy
    10.25.10.1 mk hotspot

    /ip firewall filter
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=no
    add action=drop chain=forward comment=\
    "Limite de 15 conexoes simultaneas por cliente" connection-limit=15,32 \
    disabled=no dst-address=!172.31.255.0/30 protocol=tcp src-address=\
    10.25.10.0/24 tcp-flags=syn
    /ip firewall mangle
    add action=mark-connection chain=forward comment="Cache Full" content="X-Cache: HIT" disabled=no new-connection-mark=forward-hits passthrough=yes protocol=\
    tcp
    add action=mark-packet chain=forward comment="" connection-mark=forward-hits disabled=no new-packet-mark=cache-hits passthrough=yes
    add action=mark-connection chain=postrouting comment="" disabled=no dscp=12 new-connection-mark=proxy-hits passthrough=yes
    add action=mark-packet chain=postrouting comment="" connection-mark=proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=yes
    add action=mark-connection chain=forward comment="Thunder - Cache Full" disabled=no dst-address=172.31.255.2 dst-port=80 new-connection-mark=\
    thunder-connection passthrough=yes protocol=tcp
    /ip firwall nat
    add action=masquerade chain=srcnat comment=Debian disabled=yes src-address=172.31.255.0/30
    add action=dst-nat chain=dstnat comment=Thunder disabled=no dst-address=!172.31.255.2 dst-port=80 in-interface=bridge1 protocol=tcp src-address=10.25.10.0/24 \
    to-addresses=172.31.255.2 to-ports=3128
    add action=masquerade chain=srcnat comment=Thunder-1 disabled=no
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=3M name=2ThunderCache3 packet-mark=thunder3-packs parent=global-out \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=3M name="1Cache squid Thunder cache" packet-mark=cache-hits parent=\
    global-out priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=8M max-limit=10M name=Cache-Hits packet-mark=proxy-squid parent=global-out priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=7M max-limit=10M name=Cache-Old packet-mark=cache-hits parent=global-out priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2M max-limit=3M name=ThunderCache packet-mark=thunder3-packs parent=global-out \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=1M name=ORKUT packet-mark=ORKUT-PCKT parent=global-out priority=8 queue=\
    default
    Última edição por Acronimo; 15-12-2010 às 03:22.



  3. #3

    Padrão Re: Cache Full...

    amigo, uso aqui hotspot + thunder3 em paralelo perfeitamente. (com cache full)

    o erro em relação ao "full" esta na sua regra de queues tree, vc definiu somente 1 mega para arquivos do cache, para os arquivos passarem a "full" defina 100 megas.

    testa ai e posta o resultado

  4. #4

    Padrão Re: Cache Full...

    Olá terencerocha,
    Tenho uma ferramenta web para fazer esse tipo de configuração, se tiver afim de testar, entre em contato comigo.

    Até mais.



  5. #5
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Cache Full...

    Amigo farias, posta no forum para conhecimento de todos, se caso for algo que o snehor cobra por isso, todos irao saber, e entrar em contato, mas se nao for, vai ser de grande ajuda a muitos usarios aqui,

  6. #6
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: Cache Full...

    Terence ja olhou se no user profiles se esta desmarcado a opçao transparent proxy ?

    Tive um caso assim e era isso oks.

    Abraços e boa sorte.



  7. #7

    Padrão Re: Cache Full...

    Olá Acronimo, cara essa ferramenta foi desenvolvida apenas para ajudar meus clientes, não pensei em cobrar o serviço, ou seja vende-la.

    Como ela está disponível e não surgiu a necessidade do uso em hotspot, o mesmo nunca foi implementado, olhando aqui no forum que me surgiu de testar, claro se nosso amigo terencerocha estiver afim de faze-lo.

    E também não postei nada no forum por que não está totalmente pronta, apenas utilizável.... rsrsrs


    Citação Postado originalmente por Acronimo Ver Post
    Amigo farias, posta no forum para conhecimento de todos, se caso for algo que o snehor cobra por isso, todos irao saber, e entrar em contato, mas se nao for, vai ser de grande ajuda a muitos usarios aqui,

  8. #8

    Padrão Re: Cache Full...

    na versao 3 funcionava perfeitamente...na 4 q nao vai mais...acho q ate a 4.5 ia...vc estao usando em qual versao?



  9. #9
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Cache Full...

    Amigo acho que vc não entendeu minhas palavras,
    eu disse que é pra vc dar uma pesquisada melhor, assim não ira depender muito de outras pessoas, falo por experiência própria, a alguns anos atraz, um cara fez um sistema simples de cache, rodou uns 5 meses no dia que deu pau, fiquei 3 ou 4 dias sem conexão, pois nao sabia trabalhar nisso, e nao encontrava quem fez, foi ai que eu decidir pesquisar, logo depois hoje eu monto meus sistemas, e adpto a minha rede, claro que os amigos aqui do fórum me ajudam bastante (se não fosse eles eu nao saberia nada) mas uma vez o Minelli me disse, "um técnico nao vai ensinar a receita de bolo, vai ensinar vc a pesquisar) e tomei isso como pessoal, e absorvi isso de tal forma, que se eu nao sei, eu pesquiso e so coloco em produção no dia que eu souber e entender o que estou fazendo, vc nao tem ideia que é parar 4 dias, clitnes ligando, e vc escutando coisa que nao queria

  10. #10

    Padrão Re: Cache Full...

    Eu testo Farias...ja te add no msn...



  11. #11
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: Cache Full...

    Citação Postado originalmente por terencerocha Ver Post
    na versao 3 funcionava perfeitamente...na 4 q nao vai mais...acho q ate a 4.5 ia...vc estao usando em qual versao?
    Versao 4.10, em outros lugares 5rc5, em outros 3.30.

    Funciona em todos.

  12. #12

    Padrão Re: Cache Full...

    Citação Postado originalmente por edcomrocha Ver Post
    Versao 4.10, em outros lugares 5rc5, em outros 3.30.

    Funciona em todos.
    Tem como vc postar suas regras para comparacao?



  13. #13
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: Cache Full...

    Redirecionamento para o Thunder
    add action=mark-routing chain=prerouting comment="ROTAS PARA MIM" disabled=yes dst-address=201.xx.xxx.0/24 in-interface=!PROXY-CACHE new-routing-mark=thunder-route passthrough=yes port=80 protocol=tcp
    add action=mark-routing chain=prerouting comment="Rotas para o Thunder" disabled=yes in-interface=bridge1 new-routing-mark=thunder-route passthrough=yes port=80 protocol=tcp src-address=201.xx.xxx.0/24
    Marcaçao de pacotes
    add action=mark-connection chain=prerouting comment="MARCA CONEXAO COM HIT DO THUNDER" disabled=no dscp=18 in-interface=PROXY-CACHE new-connection-mark=thunder-conn-HIT passthrough=yes protocol=tcp src-port=80
    add action=mark-packet chain=postrouting comment="MARCA PACOTES COM HIT DO THUNDER" connection-mark=thunder-conn-HIT disabled=no new-packet-mark=thunder-packet-HIT passthrough=yes
    Queue Tree

    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=80000000 max-limit=100000000 name="LIMITA CACHE FULL" packet-mark=thunder-packet-HIT parent=global-out priority=8 queue=default
    /ip hotspot user profile

    add idle-timeout=30m keepalive-timeout=30m name=200/512 rate-limit=200k/512k shared-users=1 status-autorefresh=10s transparent-proxy=no
    Lembrado que essas regras sao para o tc5, se for 3.x nao usa dscp, se for 4.x acima acerta no painel da bm.

    Uma coisa interessante, é que teve alguns lugares que so funcionou o cache full quando reiniciei os servidores.

    Abraços
    Última edição por edcomrocha; 19-12-2010 às 20:10.