+ Responder ao Tópico



  1. #1

    Padrão Script MK

    Feliz ano novo a todo aqui do Under.

    Estou precisando montar um script no Mikrotik que faça testes de ping.
    Caso ele perca X pacotes, ativará um ether de backup.
    Minha duvida é somente como fazer com que faça os pings e os calculos de perca.

    Ja adiantando, o netwatch nao me ajuda nesse caso. Por ser 2 link de rádio.
    Se der timeout na hora que o netwatch verifica ele ja roda o script que ativa o backup.
    O que preciso é que verifique que o link está realmente down.


    vleu
    Última edição por 4l3x4ndr3; 31-12-2010 às 08:26.

  2. #2

    Padrão Re: Script MK

    O ping é justamente pra isso amigo, se der timeout é pq o link caiu e ai o script roda, não conheço outro metodo...



  3. #3

    Padrão Re: Script MK

    Citação Postado originalmente por rogeriodj Ver Post
    O ping é justamente pra isso amigo, se der timeout é pq o link caiu e ai o script roda, não conheço outro metodo...
    Em rede rádio com trafego, é comum perde 1 pacote a cada 1000 (exemplo). Não sende necessario que o link caiu.

  4. #4

    Padrão Re: Script MK

    Citação Postado originalmente por 4l3x4ndr3 Ver Post
    Em rede rádio com trafego, é comum perde 1 pacote a cada 1000 (exemplo). Não sende necessario que o link caiu.
    Entaum na ferramenta netwatch, tem como configurar o timeout, coloque um valor alto!!!



  5. #5

    Padrão Re: Script MK

    O link que você quer monitorar é Dedicado ou Adsl? Eu tenho um load aqui com 1 dedicado e 2 adsl e estava tentando um script para monitorar o status da Adsl desativando ou ativando as regras de router se o pppoe estivesse desconectado. O comando ping eu acho falho porque depende do outro host, a não ser que consiga monitorar vários hosts aumentando assim a eficiência. O script não está funcionando ainda más pode te ajudar em alguma coisa.
    Código :
    :local pppoe ([/interface pppoe-client get [/interface find comment="ADSL01"] running])
    :if ($pppoe = false) do={:put []} 
    :delay 60s;
    :if ($pppoe = false) do={ :put [/ip route enable find comment="ModemOff"]}
    :delay 60s;
    :if ($pppoe = false) do={ :put [/ip route disable find comment="ModemOk"]}
    :delay 60s;
    :if ($pppoe = true) do={ :put [/ip route disable find comment="ModemOff"]}
    :delay 60s;
    :if ($pppoe = true) do={ :put [/ip route enable find comment="ModemOk"]}
    :delay 60s;
    Última edição por osmano807; 31-12-2010 às 11:01.

  6. #6

    Padrão Re: Script MK

    #set variaveis
    :local pingresultA [/ping 200.147.67.142 count=2]

    :if ($pingresultA=2) do={
    :beep frequency=660 length=100ms
    }
    :if ($pingresultA=0) do={
    :beep frequency=860 length=100ms
    }



  7. #7

    Padrão Re: Script MK

    Consegui um resultado bom com o seguinte script, estou fazendo alguns testes, mas por enquanto esta ok.


    :local i 0; {:do {:set i ($i + 1)} while (($i < 40) && ([/ping 0.0.0.0 interval=3 count=1]=0))};
    :if ($i=40 ) do={:log info "Link Principal Down";

    (comandos habilitados qnd 40 pacotes são perdidos)
    };

    Onde a variavel $I é a quantidade de pacotes enviados.
    O 0.0.0.0 é o ip desejado para os testes de ping.
    Crie um scheduler para que esse script rode a cada X tempo.

    É isso.