+ Responder ao Tópico



  1. #1

    Padrão PPPoE service

    Pessoal é o seguinte, estou com um problema em meu pppoe service, uso conexões pppoes interligadas em um servidor radius, e quando duas pessoas tentam se conectar ao mesmo tempo com o mesmo usuario, a autenticação é aceita, e essas duas pessoas conseguem acesso a internet, o que posso fazer para que isso não aconteça ??
    Previamente fiz alguns Scripts, para derrubar alguns usuarios que conseguem se conectar, porem surjiu outra duvida, quando faço um Sheduler e indico o Script no On Event, so consigo colocar um de cada vez. Como faço para separar uma ação( ex: , . ; ) ?

    Grato desde já.

  2. #2

    Padrão Re: PPPOE SERVICE

    Acompanhando...



  3. #3
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão Re: PPPOE SERVICE

    Bom dia,

    no servidor PPPoE interno do Mikrotik tem a opção de apenas uma autenticação por nome de usuário. Precisa marcá-la. Com essa opção marcada apenas um cliente autenticará, evitando que dois usuários entrem com o mesmo nome e senha.

  4. #4

    Padrão Re: PPPOE SERVICE

    Bom dia. quando a autenticação efeita usando radius essa opçao do mikrotik nao funciona.
    So vale o controle do radius de conexao simultanea. cmo nosso amigo disse: Simultaneous-Use := 1
    vc coloca na tabela radcheck, cada login vc coloca essa linha.
    Última edição por brunosamuel; 05-01-2011 às 10:10.



  5. #5

    Padrão Re: PPPOE SERVICE

    Ha tem esse script q funciona na versão 2.9.27, vc coloca para checar acada 2segundos.
    Código :
    :local userX;
    :local userY;
    :local i;
    :local u;
    :local clogged 0;
    :local addr [ :resolve "www.maxfava.com" ];
    :local addr2 [ :resolve "www.maxfava.com" ];
     
    :foreach i in=[/ppp active find] do={
    :set userX [/ppp active get $i name];
    :set clogged 0;
     
    :foreach u in=[/ppp active find name=$userX ] do={
    :set clogged ($clogged+1);
     
    :if ($clogged>1)  do={
    :set userY [/ppp active get $u name];
    :set addr [/ppp active get $u caller-id];
    :set addr2 [/ppp active get $i caller-id];
     
    :if ($addr != $addr2)  do={
    /ppp active remove $u;
    } 
     
    }
    }
    }
    Última edição por osmano807; 05-01-2011 às 10:52.

  6. #6

    Padrão Re: PPPoE service

    Na tabela radcheck inclua a seguinte linha:
    id GroupName Attribute op Value
    Plano 128K Mikrotik-Rate-Limit := 64k/128k



  7. #7

    Padrão Re: PPPoE service

    Citação Postado originalmente por pitagoras Ver Post
    Na tabela radcheck inclua a seguinte linha:
    id GroupName Attribute op Value
    Plano 128K Mikrotik-Rate-Limit := 64k/128k
    Isso e para controle de banda e colocada em radusergroup tem nada a v radcheck.

  8. #8

    Padrão Re: PPPoE service

    kkkk, realmente! Use a tabela radgroupcheck, troque o valor do atributo para Simultaneous-Use e Value para 1, isso deve resolver.

    Obs: Dessa maneira todos os clientes que estiverem cadastrados no grupo "Plano 128K" passarão a ter a quantidade de conexões simultâneas igual a 1. Dessa forma não precisará incluir na radcheck uma linha para cada UserName.
    Última edição por pitagoras; 05-01-2011 às 18:25. Razão: Corrigir erro



  9. #9

    Padrão Re: PPPoE service

    Ok, eu ja usei esse comando Simultaneous porem eu tenho que colocar o nome do usuario do cliente, mais estou falando de uma rede grande, para ficar monitroando leva tempo, eu queria algo mais eficaz, que funcione para todos os usarios, e não uma regra para um usario em especifico.

  10. #10

    Padrão Re: PPPoE service

    Caro, eu uso essa regra em na tabela radgroupreply;

    GroupName, Attribute, op, Value,
    basico Service-Type == Framed-User
    basico Framed-Protocol == PPP
    basico Framed-Pool == pool1
    basico Framed-Compression == Van-Jacobsen-TCP-IP
    basico Mikrotik-Rate-Limit == 256k/350k
    basico Port-Limit == 1

    Tenho varios roteadores na rede e apenas 1 servidor radius, nenhum cliente consegue conectar simultanet com essa regra: "Port-Limit == 1 "



  11. #11

    Padrão Re: PPPoE service

    Aqui funciona... já a mais de 1 ano tenho 8 roteadores autenticando numa unica base de dados... leia o manual:

    Port-Limit - número máximo de conexões simultâneas utilizando o mesmo nome de usuário

    http://wiki.mikrotik.com/wiki/Manual:RADIUS_Client
    Última edição por pabloferretti; 06-01-2011 às 19:41.

  12. #12

    Padrão Re: PPPoE service

    Mais alguma sugestão ???



  13. #13

    Padrão Re: PPPoE service

    Cadê os resultados??? Tem usuário que é assim... acende a bomba e desaparece. kkkkkkkkkkk