+ Responder ao Tópico



  1. #1

    Padrão Script ChangeIp.com nao atualiza

    Galera ja tentei de tudo na minha RB 433 AH 4.11 nenhuma ferramenta de atualização dinamica atuliza o ip... tenho 2 rb funcionando com versores 4.1 e roda blzinha......

    estou até aprendendo programar em MIKROTIK rsrssr..

    estou colando essa linha no New Terminal

    // link é a ether3 que troquei o nome para link
    {:log info [ /ip address get [/ip address find interface="link"] address ]}

    nas outras rbs quando rodo esse codigo de verificação aparece o ip agora na versão 4.11 aparece invalid internal item number....

    alguem ja viu esse erro...
    Abraços
    Marco

  2. #2
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Re: Script ChangeIp.com nao atualiza

    Que tal:
    Código :
    /system script
    add name=MeuDDNS policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=\
    "/tool dns-update name=seuddns.changeip.org address=127.0.0.255 key-name=seuuser key=\"suasenha\""
     
    /system scheduler
    add comment="" disabled=no interval=1m name=InstallAPP on-event="/ system script run MeuDDNS" policy=\
        reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/1970 start-time=00:00:00
    Gostou ? Deu certo?
    Estrelinha ai por favor.



  3. #3

    Padrão Re: Script ChangeIp.com nao atualiza

    ESTE SCRIPT EU INSIRO AONDE?

    Citação Postado originalmente por minelli Ver Post
    Que tal:
    Código :
    /system script
    add name=MeuDDNS policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=\
    "/tool dns-update name=seuddns.changeip.org address=127.0.0.255 key-name=seuuser key=\"suasenha\""
     
    /system scheduler
    add comment="" disabled=no interval=1m name=InstallAPP on-event="/ system script run MeuDDNS" policy=\
        reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/1970 start-time=00:00:00
    Gostou ? Deu certo?
    Estrelinha ai por favor.

  4. #4
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Re: Script ChangeIp.com nao atualiza

    abra o new terminal e cole.



  5. #5

    Padrão Re: Script ChangeIp.com nao atualiza

    Funcionou perfeito.. me ajudou.. abs e obrigado, Rodrigo.

  6. #6

    Padrão Re: Script ChangeIp.com nao atualiza

    vlw minelli, fazia muito tempo que procura um Script e nenhum funcionava, mas o seu funcionou de boa, o meu MK ta com a versão 5.2 e ta tranquilo. vlw mesmo, abraços ai



  7. #7

    Padrão Re: Script ChangeIp.com nao atualiza

    Minellu aqui comigo é assim, mas notei que as vezes ele não não atuzliza de jeito nenhum! e não entra no winbox nem nada! o que deve ser?

    desde já agradeço!



    Citação Postado originalmente por minelli Ver Post
    Que tal:
    Código :
    /system script
    add name=MeuDDNS policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=\
    "/tool dns-update name=seuddns.changeip.org address=127.0.0.255 key-name=seuuser key=\"suasenha\""
     
    /system scheduler
    add comment="" disabled=no interval=1m name=InstallAPP on-event="/ system script run MeuDDNS" policy=\
        reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/1970 start-time=00:00:00
    Gostou ? Deu certo?
    Estrelinha ai por favor.

  8. #8
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Re: Script ChangeIp.com nao atualiza

    Verifique o log para ver se não está sendo bloqueado por causa do tempo de atualização.



  9. #9

    Padrão Re: Script ChangeIp.com nao atualiza

    não olhei não está dando nada não! olhei no log no site do change e nada tbm!

    ele faz normal, depois ele como se travasse! sei lá! agora mesmoe está normal! mas as vezes ele não roda de jeito nenhum!

    o script que estou usando é esse aqui:
    Código :
     
    /system script add name=MeuDDNS policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=\ "/tool dns-update name=seuddns.changeip.org address=127.0.0.255 key-name=seuuser key=\"suasenha\""   /system scheduler add comment="" disabled=no interval=1m name=InstallAPP on-event="/ system script run MeuDDNS" policy=\     reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/1970 start-time=00:00:00


    Citação Postado originalmente por minelli Ver Post
    Verifique o log para ver se não está sendo bloqueado por causa do tempo de atualização.

  10. #10
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Re: Script ChangeIp.com nao atualiza

    O bloqueio é pelo excesso de execução em pequeno tempo.
    Aumente o tempo de execução no scheduler do script para 10 minutos.



  11. #11

    Padrão Re: Script ChangeIp.com nao atualiza

    vou fazer isso, porq um cara disse que não era legal , que o certo era deixar de 5 em 5
    Citação Postado originalmente por minelli Ver Post
    O bloqueio é pelo excesso de execução em pequeno tempo.
    Aumente o tempo de execução no scheduler do script para 10 minutos.

  12. #12
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Re: Script ChangeIp.com nao atualiza

    O tempo você que estipula o problema e que como o serviço e gratuito eles limitam a X vezes por minuto e se exceder eles bloqueiam.
    Já conta ddns paga não tem esse problema.



  13. #13

    Thumbs up Re: Script ChangeIp.com nao atualiza

    Muito Obrigado pelo Script era isso que eu estava precisando.
    1000 estrelas pra vc.
    Flw Brother