Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    Ficou tranaquilo, mas somente quando não vinculo o pool ao hotspot server, caso contrario continua dando o mesmo erro... será que fiz alguma coisa errada?

  2. #22

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    Eu tenho vinculado e nao da erro nenhum, verifica o script.



  3. #23
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Thumbs up Re: Script para amarrar ip + mac e colocar o ip como estático

    Pessoal por ser um assunto interessante e para não alongar o post o coloquei no meu blog:
    https://under-linux.org/entry.php?b=2471

    Se for útil agradeça aqui.
    Última edição por minelli; 02-09-2011 às 09:38. Razão: Ajustes no Link e Conteúdo

  4. #24

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    Ola amigos o Celso tinha feito para mim auto mac para pppoe versão 3x, so que pelo azar do destino perdi ai estudei um pouquinho e consegui adaptrar segue o script e com creditos ao Celso e tbm Rodrigo Minelli tbm pela ajuda.


    ##################################################
    ## Automac_HotSpot By Int21 - No Right Reserved ##
    ## Automac_PPPoe By Rodriog Minelli.´. ##
    ##==============================================##
    # Nome: AutoMac_PPPoe #
    # Objetivo: Capturar IP + Mac do cliente e #
    # deixa-lo fixo para que não mude. #
    # Agendamento: Use a cada 30 segundos #
    ##################################################
    :foreach x in=[/ppp active find] do={
    :global address [/ppp active get $x address];
    :global user [/ppp active get $x name];
    :global mac [/ppp active get $x caller-id];
    /ppp secret set $user caller-id=$mac remote-address=$address;
    }


    Esse script pega tanto o mac quando o ip do cliente conectado. somente.
    faça o agendamento para executar a cada 50 segundos t+ obrigado.



  5. #25

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    isso ta ficando showwwwwwwwwwwwwwww.

  6. #26

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    Sou iniciando no mikrotik e estou tentando implementar o hotspot porém não estou conseguindo resolver o seguinte problema: determino o IP para o cliente em DHCP amarrando o MAC; coloco o mesmo IP e MAC no HOTSPOT, até ai tudo ok, o cliente pega o IP que determinei, mas quando faço o login aparece outro IP em /HOTSPOT/ACTIVE e em /HOTSPOT/HOSTS, fica ADDRESS um IP (o que determinei) e TO ADDRES outro IP (o mesmo de ACTIVE). Alguém sabe o que estou fazendo errado? Desde já agradeço.



  7. #27

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    Seu hotspot esta mal configurado. posta as conf para olharmos e poder ajudar. Mas o ideal seria abrir um topico pedindo ajuda.
    Última edição por fronteirams; 31-08-2011 às 16:06.

  8. #28
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    Pessoal para não virar bagunça e ficar um forum organizado vamos nos atentar ao titulo do tópico.



  9. #29

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    oi amigo eu usei essa regra ficou show de bola porem tenho todos os meus clientes comentados e os mesmo quando seto ela fica com o mesmo nome do login
    exemplo 01
    login infornet
    comentario " infornet rua tal casa tal tel 88888888" esse seria o comentario de cada clientes mais quando ativo a regra ela muda o comentario para o mesmo nome de usuario
    exemplo 02
    login infornet
    comentario "infornet" isso com todos os login

    o que eu posso fazer para melhorar so pegar o ip mec e deixar estatico agradeco desde ja obrigado

  10. #30

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    aumenta o tempo do dhcp serven leaser time para 3000d



  11. #31
    tonho
    Visitante

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    Não estou conseguindo faser este script executar de 3 em 3 minutos

  12. #32
    tonho
    Visitante

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    bestera minha, oi so olhar o print que..(esqueci o nome mandou) e deu certo. vlw!



  13. #33

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    Testado e Comprovado Realmente Funcionou Redondinho Vlw Parceiro.!

  14. #34

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    eai blz pessoal nao posso ajudar sou muito iniciante no mikrotik vlw



  15. #35

    Padrão Re: Script para amarrar ip + mac e colocar o ip como estático

    bom dia Amigo, sou novo aqui e quero tirar uma duvida estou com um WiFi free em uma comunidade |Rural da minha cidade Parintins AM, e quero tirar umas duvidas sobro o tempo que cada usuário vai ficar conectado e com ip salvo no Lease Timer, tenho duvidas de como fazer a melhor configuração do dhcp server para que se renove os ips pelo menus de 3 em 3 horas de forma automática.