+ Responder ao Tópico



  1. #1

    Padrão Cache Full limitado pelo link de internet !? BUG?

    O Cache full não vem a full se o link de internet estiver sobrecarregado ..

    Explicando :
    O cenário é hotspot ,

    Me parece q o mikrotik balanceia o link de internet entre os usuários logados no hotspot quando a banda do link de internet disponível não é suficiente para suprir a velocidade do profile de todos usuários logados.. acho até aceitável no momento q não se tem pra todo mundo se divida o q tem.

    Porém quando essa situação ocorre, e o "problema" só ocorre nessa situação.. O cache entra na dança do balanço e para de ir a full..

    Ou seja :
    Quando se tem banda de internet sobrando o cache vem a full obedecendo a queue tree direitinho.. perfeito.

    Problema é quando mikrotik começa a balancear a internet que não está suprindo a demanda, ignora a queue tree do cache, para de sair a full conforme a regra , sai balanceada pela regra de divisão de link q não esta suprindo.. como se o objeto estivesse vindo da internet ...

    o cache sai mais lento do q poderia sair quando a internet esta sobrecarregada.

    Adianto q sei ,

    não é problema de estourar a banda das interfaces...

    as regras estão ok :
    Redir para o Proxy ok,.. Mangle marcando conexao e pacote ok,... regra na queue tree ok...

    Acompanho os hits no cache e sei o q ta vindo do cache e da internet..
    mas o cache vem capado quando ocorre sobrecarga da internet.. situação q não deveria.

    É No Mikrotik 3.14 , Cache em paralelo, squid , thunder 3.1
    será isso um bug? alguma coisa q eu nao to sabendo ainda?..
    Última edição por sputnick; 23-03-2011 às 03:47.

  2. #2

    Padrão Re: Cache Full limitado pelo link de internet !? BUG?

    na verdade ja que vc diz que esta tudo bem configurado, o que poderia estar acontecendo eh que a sua internet e/ou conexoes esta totalmente sendo usada
    sendo assim, nem a internet nem os arquivos que estao na cache nao conseguem acessar os sites e verificar os conteudos para poder repassar para as maquinas, solucao,
    limite as conexoes por clientes
    Mikrotik - Under-Linux.Org Wiki

    ponha prioridade de trafegos por tipo de conteudo
    Basic traffic shaping based on layer-7 protocols - MikroTik Wiki

    e controle o P2P da sua rede..
    se mesmo assim nao funcionar revise as suas configuracoes...



  3. #3

    Padrão Re: Cache Full limitado pelo link de internet !? BUG?

    sim, entendo o q vc falou ... mas a questão é nos objetos, o conteudo vindo do cache .. os que estão no cache! local..
    o trafego da rede local não esta sobrecarregado para esse conteudo !... o q esta sobrecarregado é a banda de internet .. como o que está no cache nao vem da internet .. e a banda da rede local esta disponivel para ele ...
    o cache nao era pra vim capado como o q vem da internet..

    A não ser um detalhe importante q vc falou ai ..pode estar pesando no cenário... os objetos em cache antes de sair para a rede local acessem novamrnte a internet(sobrecarregada).. por algum motivo.. mas isso nao é muito lógico.. se o cache é para acelerar a navegação com os arquivos q já estao localmente .. e se ele for buscar novamente na internet um objeto q já esta armazenado no cache.. o idéia de cache some... de modo que os objetos já locais vao ser baixados(ocupar a bandinha de internet) mesmo estando em cache?? idéia de cache perde o sentido !

    VLW pela atenção.. Tem mais alguma idéia ae ? eu estou errado.. ?
    Última edição por sputnick; 23-03-2011 às 21:17.

  4. #4

    Padrão Re: Cache Full limitado pelo link de internet !? BUG?

    a ideia da cache nao perde sentido nao, se por exemplo o Logo do Google estiver cacheada e guardada
    no outro dia o mesmo link da imagem, tiver sido mudada no servidor da google, a cache nao iria te repasar um conteudo antigo, ela nao baixa a imagem de novo, soh faz uma comparacao do arquivo, se o arquivo nao mudou senao ele te repassa, se mudou ele baixa novamente e borra o arquivo antigo com o mesmo link..



  5. #5

    Padrão Re: Cache Full limitado pelo link de internet !? BUG?

    certo.. concordo com vc em partes..

    por ex.. ele verifica se a logo é a mais recente , essa verificação pode demorar um ano..ou o tempo q for necessário ..por causa da lentidão da internet...mas depois q o cache decide se o q já está armazenada é o mais atual no cache.. a mesmo não tinha q sair a full ? ..respeitando as regras queue tree.. só ta indo a full quanto a internet nâo está sobrecarregada..

    to me batendo com isso já... viu outros post´s aki falando sobre problema de queue tree na 3.14..

    outro exemplo , é um vídeo do youtube q está no cache ..
    ele pode demorar o tempo q for para fazer verificação do vídeo no cache.. mas na hora q o video sair do cache , tem q sair a full.. ta vindo do cache!!... reparei q quando o mikrotik não está balanceando a internet q nao supriu os usuários on-line... ele vem a full...
    Última edição por sputnick; 24-03-2011 às 03:52.

  6. #6

    Padrão Re: Cache Full limitado pelo link de internet !? BUG?

    com certeza eh a sua configuracao entao..



  7. #7

    Padrão Re: Cache Full limitado pelo link de internet !? BUG?

    Minhas Regras Pertinentes ao caso :

    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.1.0/24
    add action=masquerade chain=srcnat comment=\
    "masquerade servidores proxycache/web" disabled=no src-address=\
    192.168.10.0/24
    add action=dst-nat chain=dstnat comment=Redireciona_webproxy disabled=no \
    dst-port=80 in-interface=InterfacesClientes protocol=tcp src-address=\
    192.168.1.0/24 to-addresses=192.168.10.2 to-ports=5128

    _______________________________

    /ip firewall filter

    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    add action=drop chain=forward comment="" connection-limit=10,24 disabled=no \
    protocol=tcp src-address=192.168.1.0 tcp-flags=syn
    add action=drop chain=input comment="" disabled=no dst-port=5128 \
    in-interface=CABOlink protocol=tcp
    ______________________________________________

    /ip firewall mangle
    add action=mark-connection chain=postrouting comment=\
    "Marcando conection Para Cache Full" content="X-Cache: HIT" disabled=no \
    new-connection-mark=do-cache passthrough=yes protocol=tcp src-port=5128
    add action=mark-packet chain=postrouting comment=\
    "Marca Pacote para Cahe FULL" connection-mark=do-cache disabled=no \
    new-packet-mark=cache-packet passthrough=no
    add action=mark-connection chain=postrouting comment=\
    "Marcando conection para limite P2P" disabled=no new-connection-mark=\
    conexaop2p p2p=all-p2p passthrough=yes
    add action=mark-packet chain=prerouting comment=\
    "Marca Paconte para limitar P2P" connection-mark=conexaop2p disabled=no \
    new-packet-mark=pacotesp2p passthrough=yes

    ________________________________
    /ip hotspot ip-binding
    add address=192.168.10.2 comment="Servidor Preto " disabled=no \
    mac-address=00:1B:B9:62:B3:26 type=bypassed

    _______________________________

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=60000 name=p2p-in packet-mark=pacotesp2p parent=global-in \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=110000 name=p2p-out packet-mark=pacotesp2p parent=global-out \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="Liberando Cache Full" packet-mark=cache-packet parent=\
    global-out priority=8 queue=cache

  8. #8

    Padrão Re: Cache Full limitado pelo link de internet !? BUG?

    Atualizei o mikrotik para 4.7 .. continua tudo na mesma.. sem solucao...



  9. #9

    Padrão Re: Cache Full limitado pelo link de internet !? BUG?

    descobri meu problema.. canal q eu usava ficou poluido, algum sábio detonou o canal com aplificador.. mudei de canal.. tudo ok..
    Última edição por sputnick; 29-03-2011 às 05:52.