+ Responder ao Tópico



  1. #1

    Padrão Load Balance RB750 Link 4mb + ADSL 2MB

    Boa tarde pessoal, hoje chegou uns equipamentos pra mim e um RB750 e preciso fazer um load balance, tentei com um programa para gerar mais só está saindo por 1link quando desligo o primeiro o segundo funciona, mais nada de funcionar os dois juntos... Alguém pode me dar uma mãozinha nisso? Segue minha configuração:
    # ip address --------------------------
    /ip address add address=10.50.0.1/24 interface=saida
    /ip address add address=192.168.1.100/24 interface=link
    /ip address add address=10.0.0.2/24 interface=adsl
    # interface pppoe-client ---------------
    # ip dns --------------------------------
    /ip dns set primary-dns=8.8.8.8
    /ip dns set secondary-dns=8.8.4.4
    /ip dns set allow-remote-requests=yes
    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=velox.user.com.br disabled=no
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=speed.user.com.br disabled=no
    /ip firewall filter add action=accept chain=input disabled=no in-interface=!link src-address=10.50.0.1/24
    /ip firewall filter add action=accept chain=input disabled=no in-interface=!adsl src-address=10.50.0.1/24
    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=link
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl
    # ip firewall mangle------------------------
    # LoopBack por link-------------------------
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK0 in-interface=saida new-connection-mark=Sites0 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites0 disabled=no in-interface=saida new-routing-mark=Rota0 passthrough=no
    / ip route add gateway=192.168.1.1 routing-mark=Rota0
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK1 in-interface=saida new-connection-mark=Sites1 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites1 disabled=no in-interface=saida new-routing-mark=Rota1 passthrough=no
    / ip route add gateway=10.0.0.1 routing-mark=Rota1
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment="BRADESCO" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.186.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.178.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1
    # Fim LoopBack por link----------------------
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=link new-connection-mark=link_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl new-connection-mark=adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=link_conn disabled=no new-routing-mark=to_link passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_conn disabled=no new-routing-mark=to_adsl passthrough=yes
    /ip firewall mangle add action=accept chain=prerouting disabled=no dst-address=192.168.1.0/24 in-interface=saida
    /ip firewall mangle add action=accept chain=prerouting disabled=no dst-address=10.0.0.0/24 in-interface=saida
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=saida new-connection-mark=link_conn passthrough=yes per-connection-classifier=:2/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=saida new-connection-mark=adsl_conn passthrough=yes per-connection-classifier=:2/1
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=link_conn disabled=no in-interface=saida new-routing-mark=to_link passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_conn disabled=no in-interface=saida new-routing-mark=to_adsl passthrough=yes
    # ip route----------------------------------
    /ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_link comment="Link0"
    /ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.0.0.1 routing-mark=to_adsl comment="Link1"
    /ip route add check-gateway=ping comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=30 target-scope=10
    /ip route add check-gateway=ping comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.0.0.1 scope=30 target-scope=10
    Última edição por peritinaicos; 12-04-2011 às 22:12.

  2. #2

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Nunca usei uma RB como LB, nem sei te dizer também dizer sobre o desempenho, porem aqui uso o BFW, que tem todas as funções, e mais algumas tem interface web de fácil configuração onde você controla peso do link, tem o BIND entregado, tem algumas inúmeras vantagens fora à praticidade de se aumentar memoria e processador conforme necessidade, o único contra é o tamanho afinal é um PC.



  3. #3

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Citação Postado originalmente por peritinaicos Ver Post
    Boa tarde pessoal, hoje chegou uns equipamentos pra mim e um RB750 e preciso fazer um load balance, tentei com um programa para gerar mais só está saindo por 1link quando desligo o primeiro o segundo funciona, mais nada de funcionar os dois juntos... Alguém pode me dar uma mãozinha nisso? Segue minha configuração:
    # ip address --------------------------
    /ip address add address=10.50.0.1/24 interface=saida
    /ip address add address=192.168.1.100/24 interface=link
    /ip address add address=10.0.0.2/24 interface=adsl
    # interface pppoe-client ---------------
    # ip dns --------------------------------
    /ip dns set primary-dns=8.8.8.8
    /ip dns set secondary-dns=8.8.4.4
    /ip dns set allow-remote-requests=yes
    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=velox.user.com.br disabled=no
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=speed.user.com.br disabled=no
    /ip firewall filter add action=accept chain=input disabled=no in-interface=!link src-address=10.50.0.1/24
    /ip firewall filter add action=accept chain=input disabled=no in-interface=!adsl src-address=10.50.0.1/24
    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=link
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl
    # ip firewall mangle------------------------
    # LoopBack por link-------------------------
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK0 in-interface=saida new-connection-mark=Sites0 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites0 disabled=no in-interface=saida new-routing-mark=Rota0 passthrough=no
    / ip route add gateway=192.168.1.1 routing-mark=Rota0
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK1 in-interface=saida new-connection-mark=Sites1 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites1 disabled=no in-interface=saida new-routing-mark=Rota1 passthrough=no
    / ip route add gateway=10.0.0.1 routing-mark=Rota1
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment="BRADESCO" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.186.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.178.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1
    # Fim LoopBack por link----------------------
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=link new-connection-mark=link_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl new-connection-mark=adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=link_conn disabled=no new-routing-mark=to_link passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_conn disabled=no new-routing-mark=to_adsl passthrough=yes
    /ip firewall mangle add action=accept chain=prerouting disabled=no dst-address=192.168.1.0/24 in-interface=saida
    /ip firewall mangle add action=accept chain=prerouting disabled=no dst-address=10.0.0.0/24 in-interface=saida
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=saida new-connection-mark=link_conn passthrough=yes per-connection-classifier=:2/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=saida new-connection-mark=adsl_conn passthrough=yes per-connection-classifier=:2/1

    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=link_conn disabled=no in-interface=saida new-routing-mark=to_link passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_conn disabled=no in-interface=saida new-routing-mark=to_adsl passthrough=yes
    # ip route----------------------------------
    /ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_link comment="Link0"
    /ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.0.0.1 routing-mark=to_adsl comment="Link1"
    /ip route add check-gateway=ping comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=30 target-scope=10
    /ip route add check-gateway=ping comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.0.0.1 scope=30 target-scope=10

    Amigao usei esse mesmo programa essa semana para balancear 1 dedicado de 4 megas e + 5 links adsl com velocidades diferentes!

    nao vou nem ler as configuraçoes que postou! tente configurar novamente pelo programa vc colocou alguma coisa errada na configuracao pois aonde destaquei la em cima deveriam exister 2 regras para link dedicado e 1 para adsl!

    pois essas regras usam uma coisa basica que aprendi essa semana
    soma o total do link ou seja no seu caso 6 megas divide pela quantidade de links no seu caso 2

    ou seja 3, ai teriam que ter 3 regras destas 3/0 link dedicado 3/1 link dedicado 3/2 adsl

    onde a primeira e segunda requisicoes vao pro link dedicado, e a 3 pro adsl!
    outra dica coloque seu modem em bridge!
    qualquer coisa me add no msn que te ajudo a configurar o programinha que funciona 100% [email protected]

  4. #4

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Citação Postado originalmente por cls7007 Ver Post
    Amigao usei esse mesmo programa essa semana para balancear 1 dedicado de 4 megas e + 5 links adsl com velocidades diferentes!

    nao vou nem ler as configuraçoes que postou! tente configurar novamente pelo programa vc colocou alguma coisa errada na configuracao pois aonde destaquei la em cima deveriam exister 2 regras para link dedicado e 1 para adsl!

    pois essas regras usam uma coisa basica que aprendi essa semana
    soma o total do link ou seja no seu caso 6 megas divide pela quantidade de links no seu caso 2

    ou seja 3, ai teriam que ter 3 regras destas 3/0 link dedicado 3/1 link dedicado 3/2 adsl

    onde a primeira e segunda requisicoes vao pro link dedicado, e a 3 pro adsl!
    outra dica coloque seu modem em bridge!
    qualquer coisa me add no msn que te ajudo a configurar o programinha que funciona 100% [email protected]
    Blz amigo, tentei algumas vezes, mais não consegui... Já add vc.



  5. #5

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Citação Postado originalmente por peritinaicos Ver Post
    Blz amigo, tentei algumas vezes, mais não consegui... Já add vc.
    nao apareceu no meu msn nao

  6. #6

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Citação Postado originalmente por cls7007 Ver Post
    nao apareceu no meu msn nao
    add vc hj sim [email protected] vlw



  7. #7

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    O grande barato dos fóruns é a troca de experiência, amigo até 15 dias atrás usava a mesma config que você está procurando, 02 adsl, uma de 4 M e uma de 2 M balançeadas por uma rb750g, vou postar minhas regras, so vc copiar e colar. ( créditos da regra do Luciano da PC Ram) Este é o famoso PCC balance, agora estou usando 02 links de 04 mega, dica deixe o link de 4 mega como "nra"

    substitua pelo seus ips
    aqui uso :
    link 01: 192.168.0.1
    link 02: 192.168.5.1

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.0.1 routing-mark=to_nra scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.5.1 routing-mark=to_nrb scope=30 target-scope=10
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
    192.168.0.1 scope=30 target-scope=10
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=\
    192.168.5.1 scope=30 target-scope=10


    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list=sem_balance in-interface=Saida
    add action=mark-routing chain=output comment="" connection-mark=conn_na \
    disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb \
    disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Saida new-connection-mark=conn_ma0 \
    passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Saida new-connection-mark=conn_mb1 \
    passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 \
    disabled=no in-interface=Saida new-routing-mark=to_nra passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 \
    disabled=no in-interface=Saida new-routing-mark=to_nrb passthrough=no

    /ip firewall nat
    add action=masquerade chain=srcnat comment="LIBERA NET PARA O MK" disabled=no \
    out-interface=Link1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=Link2

  8. #8

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Vo testar agora, jaja eu mando resultado... vlw



  9. #9

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Citação Postado originalmente por Claudio Ver Post
    O grande barato dos fóruns é a troca de experiência, amigo até 15 dias atrás usava a mesma config que você está procurando, 02 adsl, uma de 4 M e uma de 2 M balançeadas por uma rb750g, vou postar minhas regras, so vc copiar e colar. ( créditos da regra do Luciano da PC Ram) Este é o famoso PCC balance, agora estou usando 02 links de 04 mega, dica deixe o link de 4 mega como "nra"

    substitua pelo seus ips
    aqui uso :
    link 01: 192.168.0.1
    link 02: 192.168.5.1

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.0.1 routing-mark=to_nra scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.5.1 routing-mark=to_nrb scope=30 target-scope=10
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
    192.168.0.1 scope=30 target-scope=10
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=\
    192.168.5.1 scope=30 target-scope=10


    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list=sem_balance in-interface=Saida
    add action=mark-routing chain=output comment="" connection-mark=conn_na \
    disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb \
    disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Saida new-connection-mark=conn_ma0 \
    passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Saida new-connection-mark=conn_mb1 \
    passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 \
    disabled=no in-interface=Saida new-routing-mark=to_nra passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 \
    disabled=no in-interface=Saida new-routing-mark=to_nrb passthrough=no

    /ip firewall nat
    add action=masquerade chain=srcnat comment="LIBERA NET PARA O MK" disabled=no \
    out-interface=Link1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=Link2
    Aqui nao rodou os 2links...

  10. #10

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    vc usa seu modem em bridge ou router



  11. #11

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Aqui tenho um modem em router 192.168.1.1 e link dedicado no roteador 10.0.0.1... Até o momento testei mais 2 tipos de balancin que achei no forum e nada...

  12. #12

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Ola peritinaicos...

    Conseguiu ajustar seu PCC ?

    Caso não, add ae [email protected] que lhe ajudo aqui pelo forum...

    Abr...



  13. #13

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Bom dia, bom amigo consegui fazer um load balanced com o LINK + ADSL, nao consegui executar por aquele programa pcc 1.3, dai peguei uma outra solucao aqui mesmo no site editei e implantei na minha rede, ate o momento esta funcionando. Parece que site de bancos nao abre e msn cai em tempos em tempos... Estou procurando agora a solucao pra isso... direcionamento dos pedidos https dos bancos e 443 do msn... jaja posto o resultado ai para todos... vlw

  14. #14

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Citação Postado originalmente por peritinaicos Ver Post
    Bom dia, bom amigo consegui fazer um load balanced com o LINK + ADSL, nao consegui executar por aquele programa pcc 1.3, dai peguei uma outra solucao aqui mesmo no site editei e implantei na minha rede, ate o momento esta funcionando. Parece que site de bancos nao abre e msn cai em tempos em tempos... Estou procurando agora a solucao pra isso... direcionamento dos pedidos https dos bancos e 443 do msn... jaja posto o resultado ai para todos... vlw
    vc usa o modem rotiado ou em bridge



  15. #15

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Já solucionei o problema, mais respondendo uso bridge e link

  16. #16

    Padrão Re: Load Balance RB750 Link 4mb + ADSL 2MB

    Citação Postado originalmente por peritinaicos Ver Post
    Já solucionei o problema, mais respondendo uso bridge e link
    pode me passa ae as regras so pra me analisa as minhas aqui irmao te agradeço