+ Responder ao Tópico



  1. #1

    Padrão Link Down - O que fazer quando cai o link

    Amigos passei por umas horas terríveis ^^, meu link caiu fiquei sem sinal de telefone, foi punk,

    eu uso hotspot, os clientes ja logando ficam preso, os que não nao conseguem se logar ficam sem saber o que esta acontecendo, o que eu queria era um opção que qndo caísse o link, ele ao menos abrisse a pagina do hotspot e os que estivessem logado fossem redirecionado para uma pagina de manutenção.

  2. #2
    tecnico chefe Avatar de naldo864
    Ingresso
    May 2010
    Localização
    Carapicuíba, Brazil, Brazil
    Posts
    3.104
    Posts de Blog
    1

    Padrão Re: Link Down - O que fazer quando cai o link

    não fique com raiva vou te dar um conselho e se conselho fosse bom se vendia .
    use o myauth 3 quando cai eu posso praticamente esplicar para os clientes a dificuldade do momento e meu telefone praticamente não toca por que quem esta na minha rede ve na hora a mensagem .
    as vezes sou escomungado neste forum mas eu não troco o myauth pelo mikrotik apesar de achar o mk muito bom mas o myauth e mas pratico huahuahauhauha



  3. #3

    Padrão Re: Link Down - O que fazer quando cai o link

    Citação Postado originalmente por oslain Ver Post
    Amigos passei por umas horas terríveis ^^, meu link caiu fiquei sem sinal de telefone, foi punk,
    eu uso hotspot, os clientes ja logando ficam preso, os que não nao conseguem se logar ficam sem saber o que esta acontecendo, o que eu queria era um opção que qndo caísse o link, ele ao menos abrisse a pagina do hotspot e os que estivessem logado fossem redirecionado para uma pagina de manutenção.


    Opa olha eu não testei porem a idéia é essa aqui olha o script abaixo, você tem que ter uma regra em /ip firewall nat que vai direcionar todos os seus cliente para um pag de aviso que vai esta em algum servidor na sua rede. Esse script ele vai desabilitar o hotspot e vai habilitar a regra de direcionamento

    /ip firewall nat add chain=dstnat src-address="ip dos seus clientes" protocol=tcp dst-port=0-65535 action=dst-nat to-address="do servidor da msg" to-port="porta do web service" comment="REDIRECT"


    /system script

    #---------------------------------------------------------------------------------
    #set variaveis
    :local pingcount 2
    :local pinginterval 2

    #ping enlaces
    #link www.uol.com.br
    :local pingresultA [/ping 200.147.67.142 interval=$pinginterval count=$pingcount]
    :log info "Run Script By Lcosta"

    #Se A Down
    :if ($pingresultA=0) do={
    /ip hotspot
    disable 0
    /ip firewall nat
    enable [find comment="REDIRECT"]
    }
    #Se A UP
    :if ($pingresultA=2) do={
    /ip hotspot
    enable 0
    /ip firewall nat
    disable [find comment="REDIRECT"]
    }
    #---------------------------------------------------------------------------------


    se nao funcionar voce me diz que vejo o que pode esta errado!

  4. #4

    Padrão Re: Link Down - O que fazer quando cai o link

    Se for constante vc deve comprar mais um link montar um balanceamento e ativar o failover, vc vai encontrar aqui no fórum várias receitas de bolo para montar tanto o balance quanto o failover, caso vc não tenha condições de fazer isso o ideal é montar uma pagina ai no seu servidor com uma mensagem de falta de link ou manutenção para não deixar os clientes exaltados.... é só criar uma pasta manutenção colocar a pagina dentro igual ao do hotspot e enviar para o servidor e trocar no profile a pasta base quando o link cair...



  5. #5

    Padrão Re: Link Down - O que fazer quando cai o link

    tambem uso o myauth 3 e coloco alem da explicação na pagina de manutenção, na volta do link eo posto no hotspot os pedidos de desculpas e tmbem um parecer do motivo da paralização

  6. #6
    tecnico chefe Avatar de naldo864
    Ingresso
    May 2010
    Localização
    Carapicuíba, Brazil, Brazil
    Posts
    3.104
    Posts de Blog
    1

    Padrão Re: Link Down - O que fazer quando cai o link

    muito bom mesmo myauth3 hotspot não troco por server nenhum



  7. #7

    Padrão Re: Link Down - O que fazer quando cai o link

    da até para vender espaço publicitário no hotspot

  8. #8
    tecnico chefe Avatar de naldo864
    Ingresso
    May 2010
    Localização
    Carapicuíba, Brazil, Brazil
    Posts
    3.104
    Posts de Blog
    1

    Padrão Re: Link Down - O que fazer quando cai o link

    eu ja faço isto so com propaganda eu tire r$ 700,00 por mes e estou achando mas cliente ,e ainda cai no site da empresa muito bom