+ Responder ao Tópico



  1. #1

    Wink MikroTik 5.2 + Squid 2.7 - Cache Full

    Olá Amigos, estou com problemas . meu Mikrotik é 5.2 está em paralelo com o Debian 6, estou tendo problemas para marcar, entregar o cache full para os clientes, vcs tem alguma dica de como devo marcar no MikroTik v 5.2, estou com squid 2.7

    Essas são as config do meu squid.conf 2.7 com ZPH

    # SQUID.CONF
    # PORTA E CONFS PADRAO
    http_port 3128 transparent
    visible_hostname proxy_server
    icp_port 0
    acl all src 0.0.0.0/0.0.0.0
    cache_effective_user proxy

    # LOGS RETIRADOS - MELHORA DESEMPENHO
    cache_access_log none
    cache_log none
    cache_store_log none

    # MEMORIA OBJETOS E CACHE
    cache_mem 512 MB
    maximum_object_size_in_memory 256 KB
    maximum_object_size 100 MB
    minimum_object_size 0 KB

    # STORE CACHE
    cache_swap_low 90
    cache_swap_high 95

    # DISKD CACHE
    cache_dir diskd /squid/cache/1 50000 128 512 Q1=64 Q2=72
    cache_dir diskd /squid/cache/2 50000 128 512 Q1=64 Q2=72
    cache_dir diskd /squid/cache/3 50000 128 512 Q1=64 Q2=72
    cache_dir diskd /squid/cache/4 50000 128 512 Q1=64 Q2=72
    cache_dir diskd /squid/cache/5 50000 128 512 Q1=64 Q2=72
    cache_dir diskd /squid/cache/6 50000 128 512 Q1=64 Q2=72
    cache_dir diskd /squid/cache/7 50000 128 512 Q1=64 Q2=72
    cache_dir diskd /squid/cache/8 50000 128 512 Q1=64 Q2=72

    # MARCAR PACOTES MIKROTIK IDENDIFICA
    zph_mode tos
    zph_local 0×30
    zph_parent 0
    zph_option 136

    # LIBERA TODA REDE
    http_access allow all


    ############### FIM SQUID.CONF ###############
    Última edição por Jonatanmcc; 08-05-2011 às 22:59.

  2. #2

    Padrão Re: MikroTik 5.2 + Squid 2.7 - Cache Full

    amigo, marque pelo TOS 12



  3. #3

    Padrão Re: MikroTik 5.2 + Squid 2.7 - Cache Full

    Olá Suascm .blz. Cara já tentei com TOS 12 mais não esta marcando . quando marca o controle de banda dos clientes fica full com toda banda, teria que ser apenas o cache não ?

  4. #4

    Padrão Re: MikroTik 5.2 + Squid 2.7 - Cache Full

    coloque a regra de controle acima de todas na mangle, adicione no Queues Tree uma REgra pra controle desses pacotes, se nao conseguir poste suas configurações do Mk mangle e nat



  5. #5

    Padrão Re: MikroTik 5.2 + Squid 2.7 - Cache Full

    Citação Postado originalmente por suascm Ver Post
    amigo, marque pelo TOS 12
    Olá Suascm .blz. Cara já tentei com TOS 12 mais não esta marcando . quando marca o controle de banda dos clientes fica full com toda banda, teria que ser apenas o cache não ?

  6. #6

    Padrão Re: MikroTik 5.2 + Squid 2.7 - Cache Full

    Citação Postado originalmente por suascm Ver Post
    coloque a regra de controle acima de todas na mangle, adicione no Queues Tree uma REgra pra controle desses pacotes, se nao conseguir poste suas configurações do Mk mangle e nat
    Minhas regras estão assim .

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Controle p2p" disabled=\
    no new-connection-mark=p2p_conn p2p=all-p2p passthrough=yes
    add action=mark-packet chain=prerouting connection-mark=p2p_conn disabled=no \
    new-packet-mark=p2p passthrough=yes
    add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" \
    disabled=no new-ttl=set:30 protocol=icmp
    add action=change-mss chain=forward comment="Tcp Mss" disabled=no \
    in-interface=pppoe new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=\
    1441-65535
    add action=change-mss chain=forward disabled=no new-mss=1440 out-interface=\
    pppoe protocol=tcp tcp-flags=syn tcp-mss=1441-65535
    add action=mark-connection chain=postrouting comment="Cache Full" disabled=no \
    dscp=12 new-connection-mark=n-cache passthrough=yes protocol=tcp \
    src-port=3128
    add action=mark-connection chain=postrouting disabled=no dscp=!12 \
    new-connection-mark=s-cache passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=postrouting connection-mark=n-cache disabled=no \
    new-packet-mark=Cache-Packet passthrough=no



    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=20k name=P2P-Down packet-mark=p2p parent=global-in priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=20k name=P2P-Up packet-mark=p2p parent=global-out priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5500k name=CacheFull packet-mark=Cache-Packet parent=global-out \
    priority=8 queue=default



  7. #7

    Padrão Re: MikroTik 5.2 + Squid 2.7 - Cache Full

    amigo não tenho a resolução do seu problema, porem estou com outro tp de problema em relação ao cache full
    não estou conseguindo fazer meu mk v5.2 fazer o cache full com o squid teria como vc postar as sua confs?