+ Responder ao Tópico



  1. #1

    Padrão Script para banda liberada da meia noite as 06:00

    Boa tarde amigos, estou tentando rodar um script para liberar a banda de madrugada, porem não estou tendo exito, segue regras.

    / system script

    add name="queue_disable" source="/queue simple { disable \[find \
    name=LIBERA_TUDO\] }" \
    policy=ftp,reboot,read,write,policy ,test,winbox,password
    add name="queue_enable" source="/queue simple { enable \[find \
    name=LIBERA_TUDO\] }" \
    policy=ftp,reboot,read,write,policy ,test,winbox,password


    AGENDAMENTO:

    / system scheduler

    add name="enable" on-event=queue_enable start-date=jan/21/2006 \
    start-time=00:00:01 interval=1d comment="" disabled=no
    add name="disable" on-event=queue_disable start-date=jan/21/2006 \
    start-time=06:00:01 interval=1d comment="HABILITA E DESABILITA TODA A \
    BANDA" disabled=no

    REGRA DE LIBERAÇÃO DA BANDA:

    / queue simple
    add name="LIBERA_TUDO" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 \
    interface=all parent=none direction=both priority=8 \
    queue=default-small/default-small limit-at=0/0 max-limit=6000000/6000000 \
    total-queue=default-small disabled=yes

    OBS. estou usando mikrotik 4.10
    Mesmo rodando manualmente o script ele não habilita e nem desabilita a queue para liberar a banda.

    Agradeço a todos que puderem me ajudar.
    Última edição por pereira925; 13-05-2011 às 18:32.

  2. #2

    Padrão Re: Script para banda liberada da meia noite as 06:00

    você quer liberar a banda durante um período de tempo?

    Se você faz uso de simple queue pra controle de banda pode usar a opção "time". No caso do exemplo na imagem o sistema fará o controle de banda das 8:00 da manhã às 23:59 da noite, ou seja, da meia noite às oito da manhã a banda é liberada.

    Clique na imagem para uma versão maior

Nome:	         simplequeue.jpg
Visualizações:	233
Tamanho: 	64,6 KB
ID:      	22558



  3. #3

    Padrão Re: Script para banda liberada da meia noite as 06:00

    Citação Postado originalmente por xandeact Ver Post
    você quer liberar a banda durante um período de tempo?

    Se você faz uso de simple queue pra controle de banda pode usar a opção "time". No caso do exemplo na imagem o sistema fará o controle de banda das 8:00 da manhã às 23:59 da noite, ou seja, da meia noite às oito da manhã a banda é liberada.


    Clique na imagem para uma versão maior

Nome:	         simplequeue.jpg
Visualizações:	233
Tamanho: 	64,6 KB
ID:      	22558
    Amigo xandeact explique melhor, essa queue ela fica antes de todas, ela que tem a função de liberar a banda de madrugada?

  4. #4

    Padrão Re: Script para banda liberada da meia noite as 06:00

    não...

    essa é a própria queue do usuário...

    aqui fazemos o controle de banda individual, ou seja, cada usuário tem a sua simple queue.

    e essa opçõa "time" deve ser configurada em cada configuração de queue de cada usuário.

    funciona muito bem.

    no caso pode usar script para ativar ou desativar a opção "time" em todas as simple queues de uma só vez, ou somente naquelas em que desejar.



  5. #5

    Padrão Re: Script para banda liberada da meia noite as 06:00

    Citação Postado originalmente por xandeact Ver Post
    não...

    essa é a própria queue do usuário...

    aqui fazemos o controle de banda individual, ou seja, cada usuário tem a sua simple queue.

    e essa opçõa "time" deve ser configurada em cada configuração de queue de cada usuário.

    funciona muito bem.

    no caso pode usar script para ativar ou desativar a opção "time" em todas as simple queues de uma só vez, ou somente naquelas em que desejar.
    Entendi amigo, vc teria esse script?
    Se possivel posta aqui pra gente.
    Obrigado

  6. #6

    Padrão Re: Script para banda liberada da meia noite as 06:00

    então, meu velho...

    ainda não tive tempo de desenvolver esse script...

    se o pessoal cabeça em script tiver alguma luz aí.....

    inclusive penso em utilizar essa função aqui para atrair os clientes para determinado plano.

    ex. digamos que o plano de 1 Mb seja o melhor para o provedor em termos de lucro...

    poderíamos utilizar essa ferramenta na intenção de deixar o plano mais "irresistível" para o cliente...



  7. #7

    Padrão Re: Script para banda liberada da meia noite as 06:00

    Entendi amigo xandeact, quanto ao script sem problema, bom essa queue que programada funciona legal entào amigo? vc acredita que fica bacana em uma rede com mil clientes.

  8. #8

    Padrão Re: Script para banda liberada da meia noite as 06:00

    acredito que sim.

    inclusive se tu desenvolver esse script, posta aí pra gente...



  9. #9

    Padrão Re: Script para banda liberada da meia noite as 06:00

    Citação Postado originalmente por xandeact Ver Post
    acredito que sim.

    inclusive se tu desenvolver esse script, posta aí pra gente...
    Combinado amigo, posto sim.

  10. #10

    Padrão Re: Script para banda liberada da meia noite as 06:00

    Citação Postado originalmente por xandeact Ver Post
    você quer liberar a banda durante um período de tempo?

    Se você faz uso de simple queue pra controle de banda pode usar a opção "time". No caso do exemplo na imagem o sistema fará o controle de banda das 8:00 da manhã às 23:59 da noite, ou seja, da meia noite às oito da manhã a banda é liberada.

    Clique na imagem para uma versão maior

Nome:	         simplequeue.jpg
Visualizações:	233
Tamanho: 	64,6 KB
ID:      	22558
    caro xandeact, é o seguinte trabalho num provedor e possuo acesso em minha casa, meu chefe me libera o um link maior durante a noite aparti das 21hrs que é qnd tem poucos clientes utilizando o serviço, so q tenho q entrar pelo winbox e aumentar meu link e qnd chego no escritorio tenho q lembrar de voltar td ao normal, isso é muito chato!

    Simplificando não entendo nada de mk como faço pra inserir isso ai no meu usuário? Pois não entendi.



  11. #11
    Correndo atrás... Avatar de Leonardo
    Ingresso
    Aug 2009
    Localização
    Próx. a Brasília
    Posts
    152

    Padrão Re: Script para banda liberada da meia noite as 06:00

    Olá

    Já tem um topico aonde ja foi discutido sobre isso, e eu consegui fazer funcionar 100%, inclusive libero 1MB para cada um cliente , para nao saturar o painel, so ainda nao cosegui limitar 1Mb os clientes q usam cabo

    https://under-linux.org/f143/script-...7-00-a-132522/