+ Responder ao Tópico



  1. #1

    Padrão Mikrotik - Tproxy - Lusca

    Boa noite a todos!
    Quero saber se alguem do forum tem ou teve experiencia em Tproxy com mikrotik?
    Atualmente faço tproxy usando lusca e iptables com rotas! e deixo o mikrotik como pppoe-server!
    Quero deixar o mikrotik como pppoe-server e controle de QoS! onde o servidor linux so servira de Proxy, dns e www!
    Queria saber se alguem tem este quadro! e se pode compartilhar a informação!
    Pois pretendo continuar a tribuir ip valido e fixo sem que o trafego da 80 deixe de ser em cima do ip do cliente!
    Desde já grato com a colaboração de todos!

  2. #2

    Padrão Re: Mikrotik - Tproxy - Lusca

    Citação Postado originalmente por tianguapontocom Ver Post
    Boa noite a todos!
    Quero saber se alguem do forum tem ou teve experiencia em Tproxy com mikrotik?
    Atualmente faço tproxy usando lusca e iptables com rotas! e deixo o mikrotik como pppoe-server!
    Quero deixar o mikrotik como pppoe-server e controle de QoS! onde o servidor linux so servira de Proxy, dns e www!
    Queria saber se alguem tem este quadro! e se pode compartilhar a informação!
    Pois pretendo continuar a tribuir ip valido e fixo sem que o trafego da 80 deixe de ser em cima do ip do cliente!
    Desde já grato com a colaboração de todos!
    Você pode explicar numa visão geral de método? Aqui estou para implandar o tproxy em série (lusca, tproxy, bridge), estou atualizando o kernel pois tive aumento de latência http.



  3. #3

    Padrão Re: Mikrotik - Tproxy - Lusca

    Bom dia amigo, enfim um tema bom, tenho usado Tproxy aqui com sucesso, minha rede está em bridge, e estou migrando para OSPF, e estamos tendo sucesso e uma melhoria absurda no desempenho. Estamos usando um concentrador pppoe para conectar os clientes que ainda estão na bridge e os pontos roteados vão a um concentrador OSPF, os pontos roteados são os concetradores pppoe de cada grupo. Todos vão a um servidor Tproxy. Tudo funcionando muito bem com ip validos em todos os clientes. Contudo aqui não estou com os ip fixos, estamos usando dinamicamente via radius. Estamos usando Squid e não o Lusca. Este tipo de rede é dificil de implementar mais parece ser o ideal.

  4. #4

    Padrão Re: Mikrotik - Tproxy - Lusca

    Bom dia, uma vez vc me "ajudou" pois bem, acho q agora chegou minha vez heheh nao digo ajuda, mas passar oq usava aqui no provedor.
    Usava Lusca em TProxy + Thunder3.1... servidor linux com ip valido em paralelo com o mk-pppoe, apenas adicionei algumas regras na mangle e setei em rotei esses marcações.
    Quem usa muito isso é o povo do overnix.com, ou thundercache.com.br.
    Segue o exemplo (funcionou por muito tempo).

    Código :
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="ROTAS PARA CLIENTES" disabled=yes dst-address-list=!sem_proxy dst-port=\
        80 in-interface=!CACHE new-routing-mark=cache-route passthrough=yes protocol=tcp src-address-list=ips_validos
    add action=mark-routing chain=prerouting comment="Rotas para o Cache" disabled=yes dst-address-list=ips_validos \
        in-interface=BALANCE new-routing-mark=cache-route passthrough=yes protocol=tcp src-address-list=!sem_proxy src-port=80
     
    /ip route
    add comment="ROTA CACHE-PROXY" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ip_do_linux routing-mark=cache-route \
        scope=30 target-scope=10

    Boa sorte a todos !!!



  5. #5

    Padrão Re: Mikrotik - Tproxy - Lusca

    Vou ver o que faço com estas regras!
    Tambem gostaria de mudar para OSPF! Porem vou ter que procurar material pra estudar e ver o que fazer!
    Já aqui da forma que estou trabalhando não estou tendo problemas com latencia! o que noto e que tenho uma perca de desempenho do lusca como se ele desse uns gargalo.
    E facil criar varias instancia dele porem o probleme e fazer cache_peer com tproxy! porque a instancia 2 pega arquivos no cache da instancia 1 porem a instancia 1 não consegue se comunicar com a instancia 2, este e um misterio que não sei como resolver ainda! porque criar varias instancias e duplicar os arquivos e osso!

  6. #6

    Padrão Re: Mikrotik - Tproxy - Lusca

    Citação Postado originalmente por bjaraujo Ver Post
    Você pode explicar numa visão geral de método? Aqui estou para implandar o tproxy em série (lusca, tproxy, bridge), estou atualizando o kernel pois tive aumento de latência http.
    Cabra, minha topologia acredito que seja = a sua! a unica diferença e que não uso bridge!
    Se quiser mais detalhes da o tok!



  7. #7

    Padrão Re: Mikrotik - Tproxy - Lusca

    Bom dia!
    Josue Guedes
    Teria como falar mais sobre sua migração pra OSPF? teria como disponibilizar material do mesmo?

  8. #8

    Padrão Re: Mikrotik - Tproxy - Lusca

    Citação Postado originalmente por tianguapontocom Ver Post
    Cabra, minha topologia acredito que seja = a sua! a unica diferença e que não uso bridge!
    Se quiser mais detalhes da o tok!
    Por favor, poste algúm material que não precise de wccp.



  9. #9

    Padrão Re: Mikrotik - Tproxy - Lusca

    Cara se quiser posso posta o que uso atualmente!

  10. #10

    Padrão Re: Mikrotik - Tproxy - Lusca

    Citação Postado originalmente por tianguapontocom Ver Post
    Cara se quiser posso posta o que uso atualmente!
    Quero.



  11. #11

    Padrão Re: Mikrotik - Tproxy - Lusca

    aqui e bem simples!
    Tenho um rota do roteador direcionando os 4 blocos de ip que tenho para meu servidor:
    Código :
    ip route 189.87.**.* 255.255.255.0 189.23.**.***
    ip route 189.87.**.* 255.255.255.0 189.23.**.***
    ip route 189.87.**.* 255.255.255.0 189.23.**.***
    ip route 189.87.**.* 255.255.255.0 189.23.**.***
    já no servidor tenho em paralelo um concentrador pppoe mikrotik onde tenho outra rota do servidor:
    Código :
    route add -net 189.87.**.*/24 gw 172.16.255.2
    route add -net 189.87.**.*/24 gw 172.16.255.2
    route add -net 189.87.**.*/24 gw 172.16.255.2
    route add -net 189.87.**.*/24 gw 172.16.255.2
    para fazer o tproxy funcionar "não uso bridge" usei a ideia de um colega que postou na VOL. Linux: Squid 3.1.5 com suporte a TPROXY (sem bridge) [Artigo]

    No squid ou lusca tem que se ativar e deve se estar compilado com tproxy
    No meu caso que estou usando lusca:
    Código :
    http_port transparent tproxy 3128

    Depois fiz marcação de pacotes com iptables e usei o seguinte:
    Código :
    $IPT -t mangle -N DIVERT
    $IPT -t mangle -A DIVERT -j MARK --set-mark 1
    $IPT -t mangle -A DIVERT -j ACCEPT
    $IPT -t mangle -A PREROUTING -p tcp -m socket -j DIVERT
    $IPT -t mangle -A PREROUTING -p tcp --dport 80 -j TPROXY --tproxy-mark 1 --on-port 3128
     
    ip rule add fwmark 1 lookup 100
    ip route add local 0.0.0.0/0 dev lo table 100

    Lembrando que para os clientes não precisa e não deve ter regras de MASQUERADE!

    Deve se ativar o spoofing
    Código :
    [B]echo 1 > /proc/sys/net/ipv4/conf/ethX/proxy_arp[/B]
    Código :
     
    Última edição por tianguapontocom; 01-06-2011 às 11:23. Razão: Erros

  12. #12

    Padrão Re: Mikrotik - Tproxy - Lusca

    Citação Postado originalmente por tianguapontocom Ver Post
    [...]já no servidor tenho em paralelo um concentrador pppoe mikrotik onde tenho outra rota do servidor[...]
    Fiquei um pouco perdido aqui, rsrs. Pelo que entendi você usa como gateway o servidor proxy, correto? Se, sim, você o faz com uma ou duas placas de rede? Grato.



  13. #13

    Padrão Re: Mikrotik - Tproxy - Lusca

    Duas placas de rede!
    uma ligada ao roteador e outra ligada ao mikrotik
    Todos os lcientes e obrigado a passar pelo mikrotik!

  14. #14

    Padrão Re: Mikrotik - Tproxy - Lusca

    Citação Postado originalmente por tianguapontocom Ver Post
    Duas placas de rede!
    uma ligada ao roteador e outra ligada ao mikrotik
    Todos os lcientes e obrigado a passar pelo mikrotik!
    Blz, muito obrigado. Tô sem entender como tudo vai parar no proxy (ao que pareceu pelo código o proxy é o gateway do concentrador), mas o que postou é de enorme ajuda vou me virar aqui.



  15. #15

    Padrão Re: Mikrotik - Tproxy - Lusca

    sim! o gateway e o concentrador! ele vai ta concentrado la! porem por rotas ele vai chegar até o servidor!