+ Responder ao Tópico



  1. #1

    Exclamation 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Ola galera do under-linux e o seguinte ja fui em todos os tutoriais, topicos que falam e dão dicas sobre balanceamento tanto usando PCC como outro tipo, e todos os cenarios que eu tive acesso de montagem até os meus proprios que eu mesmo criei não dão certo ou param de navegar tudo ou o MSN , Skype e ping funcionam mais a navegação não... vamo aos detalhes....

    Hoje possuo a versão 3.30 rodando numa maquina com 3 placas de rede sendo que estão as interfaces nesta ordem:

    GVT - 192.168.1.5 gatewai 192.168.1.1
    Oi - 192.168.3.5 gatewai 192.168.3.1
    Rede local com IP 192.168.0.1
    tenho web proxy
    não uso hotspot no momento
    os clientes tem amaração de ip sendo eles fixos
    Não USO PPOE ( odeio ppoe galera uso o modem como roteador ja me passando o ip fasso DMZ neles e fica tudo nos trinks)

    o link da Oi e o secundario e o GVT primario sendo que o da Oi não tem rota configurada nem nada so coloquei no IP>adress seu ip 192.168.3.5 nem rota, nem nat configurado ainda...

    Minha inteção inicial era tudo que for lixo na minha opinião como .PDF, .EXE, .ZIP, .RAR, .MP3, .AVI etc, tudo que fosse como download sairia pelo link novo da Oi deixando assim o link da GVT so pra navegação sendo um link limpo sem downloads esta e minha primeira duvida tentei fazer mais não funciona de jeito nenhum... (estou ciente que ao fazer isso posso dar bugs em alguns sites como megaupload fazendo que ao entrar no site acesse pela GVT e ao iniciar o download ele venha pela oi dando erro então o certo era jogar esses sites ja direto no link da Oi!)

    Minha segundo tentativa seria o PCC mais tambem configurei de cabo a rabo e sempre da os paus de não navegar mais o MSN e Skype ficarem on e ping funcionar ou cair de vez ...

    Screen da tela como esta hoje.

    Clique na imagem para uma versão maior

Nome:	         netsam.jpg
Visualizações:	202
Tamanho: 	44,6 KB
ID:      	23805
    Última edição por lexone; 19-06-2011 às 17:09. Razão: Adição do Screenshot

  2. #2
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Amigo nao sei se é o que vc quermas segue
    um script simples de pcc Documento sem t



  3. #3

    Cool Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Acronimo muito obrigado pela ajuda mais como eu disse eu não uso nenhuma interface como PPPOE (Discador) todos os dois modem estão como roteadores com a DMZ configurada para o IP do servidor e funciona muito bem , e depois de muita procura e pesquisa e um pedaço de script ali e outro aki consegui montar esse aew abaixo ....


    /ip address

    ADDRESS NETWORK BROADCAST INTERFACE
    ;;; Rede
    192.168.0.1/24 192.168.0.0 192.168.0.255 Rede
    192.168.1.5/24 192.168.1.0 192.168.1.255 GVT
    192.168.3.5/24 192.168.3.0 192.168.3.255 Oi

    /ip firewall mangle

    ;;; ________ Marcando Conex o do Balance GVT e Oi

    chain=input action=mark-connection new-connection-mark=GVT_conn passthrough=yes in-interface=GVT

    chain=input action=mark-connection new-connection-mark=Oi_conn passthrough=yes in-interface=Oi

    chain=output action=mark-routing new-routing-mark=GVT_route passthrough=yes connection-mark=GVT_conn

    chain=output action=mark-routing new-routing-mark=Oi_route passthrough=yes> connection-mark=Oi_conn

    /ip route

    # DST-ADDRESS PREF-SRC G GATEWAY DISTANCE IN..
    A S ;;; _____ Rota padr o com Fail Over
    0.0.0.0/0 r 192.168.1.1 1 GVT
    r 192.168.1.1 GVT
    r 192.168.1.1 GVT
    r 192.168.3.1 Oi
    r 192.168.3.1 Oi
    A S ;;; Saida do Balance GVT
    0.0.0.0/0 r 192.168.1.1 1 GVT
    A S ;;; Saida do Balance Oi
    0.0.0.0/0 r 192.168.3.1 1 Oi
    ADC 192.168.0.0/24 192.168.0.1 0 Rede
    ADC 192.168.1.0/24 192.168.1.5 0 GVT
    ADC 192.168.3.0/24 192.168.3.5 0 Oi

    /ip firewall nat

    ;;; Redirecionamento para o proxy

    chain=dstnat action=redirect to-ports=3128 protocol=tcp in-interface=Rede dst-port=80

    ;;; Nat Mascarade

    chain=srcnat action=masquerade out-interface=GVT
    chain=srcnat action=masquerade out-interface=Oi


    O unico problema que estou tendo que esta muito frequente a uma queda do MSN fora isso o script ta com fail over / balance funcionando, muitooooooooooooo bommmmm, pelo menos até onde eu montei.... o que eu gostaria de fazer agora, era so implementar sites que não entrassem no balance, sairem apenas por um dos links e caso esse link não responda, ele saia pelo secundario, acho que implementando isso ficaria nota 10, depois de terminar esse cenario vo postar aki o script completo pra todo mundo fiz algumas alterações que to terminando de resolver que quando um link cai ou para de responder o mikrotik me manda o nome do mesmo com hora por e-mail e avisa com um aviso sonoro ja ta funcionando aki 80% se alguem poder so me da uma luz nessa ultima duvida ou achar que da pra melhorar mais ainda o script fico muito agradecido vlw...

  4. #4

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Amigo nao entendi a parte do Router teria como tirar um print? ou algo do tipo, pois estou tentando fazer um load igual ao teu... 2 link ja roteados



  5. #5

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    outra coisa,pcc mais proxy juntos nao rola...

  6. #6

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Vo postar aew o fluxograma com as regras....
    Última edição por lexone; 23-06-2011 às 12:53.



  7. #7

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    EU me referi a como ficou a configuracao no MK pois nao entendi a parte do router... vlw

  8. #8

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Clique na imagem para uma versão maior

Nome:	         Rede.jpg
Visualizações:	109
Tamanho: 	39,6 KB
ID:      	23978


    /ip address
    add address=192.168.0.1/24 broadcast=192.168.0.255 comment="Rede" disabled=no \
    interface=Rede network=192.168.0.0
    add address=192.168.1.1/24 broadcast=192.168.1.255 comment="GVT″ disabled=no \
    interface=GVT network=192.168.1.0
    add address=192.168.3.1/24 broadcast=192.168.3.255 comment="Oi″ disabled=no \
    interface=Oi network=192.168.3.0

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.10,192.168.3.10 check-gateway=ping

    / ip firewall nat
    add chain=srcnat out-interface=GVT action=masquerade
    add chain=srcnat out-interface=Oi action=masquerade

    / ip firewall mangle
    add chain=input in-interface=GVT action=mark-connection new-connection-mark=GVT_conn
    add chain=input in-interface=Oi action=mark-connection new-connection-mark=Oi_conn
    add chain=output connection-mark=GVT_conn action=mark-routing new-routing-mark=to_GVT
    add chain=output connection-mark=Oi_conn action=mark-routing new-routing-mark=to_Oi

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_GVT
    add dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=to_Oi

    Explicação:

    -IP Address:

    /ip address
    add address=192.168.0.1/24 broadcast=192.168.0.255 comment="Rede" disabled=no \
    interface=ether2 network=192.168.0.0
    add address=192.168.1.5/24 broadcast=192.168.1.255 comment="GVT″ disabled=no \
    interface=GVT network=192.168.1.0
    add address=192.168.3.5/24 broadcast=192.168.3.255 comment="Oi″ disabled=no \
    interface=Oi network=192.168.3.0

    Aki setei os ips nas interfaces.

    -Routing:

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1,192.168.1.1,192.168.1.1,192.168.3.1,192.168.3.1 check-gateway=ping

    A rota aki e onde eu fiz o fail over e o balance a explicação fica assim como são 15 megas GVT e 10 Megas oi fiz na proporção de 3/2 sendo a cada 3 conexões sai para GVT e 2 na Oi (não sei se eh bem assim que funciona) e o Check Gateway verifica se o mesmo esta funcionando e caso caia o outro assume.

    -NAT:

    / ip firewall nat
    add chain=srcnat out-interface=GVT action=masquerade
    add chain=srcnat out-interface=Oi action=masquerade

    Nat acho que todo mundo ja sabe pra que server nem precisa comentar ....

    -Conexões Entrantes:

    / ip firewall mangle
    add chain=input in-interface=GVT action=mark-connection new-connection-mark=GVT_conn
    add chain=input in-interface=wRede2 action=mark-connection new-connection-mark=Oi_conn
    add chain=output connection-mark=GVT_conn action=mark-routing new-routing-mark=to_GVT
    add chain=output connection-mark=Oi_conn action=mark-routing new-routing-mark=to_Oi

    Marcação dos pacotes para que entre na GVT saia GVT e o mesmo com a Oi.

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_GVT
    add dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=to_Oi

    E aqui as rotas das duas redes com a marcação dos pacotes resumidamente eu fiz isso....
    Última edição por lexone; 26-06-2011 às 23:50.



  9. #9

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Vou testar hj de madrugada e aviso o resultado, vlw

  10. #10

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    to penssando em seguir a dica do ( sostenes ) "outra coisa,pcc mais proxy juntos nao rola..." tenho uma routerboard 750G e to penssando em colocar ela pra fazer o balance e depois jogar pro servidor que gerencia a banda....



  11. #11

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    bom eu nao uso proxy uso so o mk mesmo

  12. #12

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    hello word ????? Alguem aew dando um up no topico....



  13. #13

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Bom dia amigo, fiz outro tipo de PCC ficou SHOW... agora estou usando junto 3links 2adsl + 1dedicado... ficou show se precisar mando como fiz

  14. #14
    Eng. Telecomunicações Avatar de pkmc
    Ingresso
    May 2007
    Localização
    Foz do Iguaçu - PR
    Posts
    996
    Posts de Blog
    1

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Citação Postado originalmente por peritinaicos Ver Post
    Bom dia amigo, fiz outro tipo de PCC ficou SHOW... agora estou usando junto 3links 2adsl + 1dedicado... ficou show se precisar mando como fiz
    Seria legal postar aqui para todos poderem ter acesso mesmo que por curiosidade pois esse é o fundamento dos FORUN's !

    Grande Abraço !



  15. #15

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Bom amigos aqui funciona que é uma beleza, segue nat e firewall... se precisar de mais alguma coisa só avisar.
    OBS: Mudem os números de route para o número certo de suas redes.

    /ip firewall nat
    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no out-interface=Discador1
    add action=masquerade chain=srcnat disabled=no out-interface=Discador2
    add action=masquerade chain=srcnat disabled=no out-interface="3 link 3MB"

    /ip firewall mangle
    add action=accept chain=prerouting comment="Sem Balance" disabled=no dst-address-list=sem_balance in-interface=EthClientes
    add action=mark-connection chain=input connection-state=new disabled=no in-interface=Discador1 new-connection-mark=conn_na passthrough=yes
    add action=mark-connection chain=input connection-state=new disabled=no in-interface=Discador2 new-connection-mark=conn_nb passthrough=yes
    add action=mark-connection chain=input connection-state=new disabled=no in-interface="3 link 3MB" new-connection-mark=conn_nc passthrough=yes
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_ma0 passthrough=yes per-connection-classifier=\
    both-addresses:6/0
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_ma0 passthrough=yes per-connection-classifier=\
    both-addresses:6/1
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 passthrough=yes per-connection-classifier=\
    both-addresses:6/2
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mc3 passthrough=yes per-connection-classifier=\
    both-addresses:6/3
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mc3 passthrough=yes per-connection-classifier=\
    both-addresses:6/4
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mc3 passthrough=yes per-connection-classifier=\
    both-addresses:6/5
    add action=mark-routing chain=prerouting connection-mark=conn_ma0 disabled=no in-interface=EthClientes new-routing-mark=to_nra passthrough=no
    add action=mark-routing chain=prerouting connection-mark=conn_mb1 disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=no
    add action=mark-routing chain=prerouting connection-mark=conn_mc3 disabled=no in-interface=EthClientes new-routing-mark=to_nrc passthrough=no

    /ip route
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Discador1 routing-mark=to_nra scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Discador2 routing-mark=to_nrb scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.0.0.1 routing-mark=to_nrc scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Discador1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.0.0.1 scope=30 target-scope=10
    add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=Discador2 scope=30 target-scope=10

    Aqui o peso é de 3MB+2MB+1MB
    Segue o nome das interface abaixo, está numerado da seguinte forma: 1 = wan 1 e assim em diante.
    vlw.
    Clique na imagem para uma versão maior

Nome:	         Interface servidor LoadBlance.JPG
Visualizações:	92
Tamanho: 	52,4 KB
ID:      	24210
    Última edição por peritinaicos; 01-07-2011 às 11:52.

  16. #16

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    Caro amigo peritinaicos vo fazer um teste com essa sua regra creio que até ja vi ela em outro lugar aki no forum ou na net não me lembro vo tentar mais uma vez outro problema e que eu tenho somente um servidor e agora me preucupei com o proxy to penssando em desabilitalo ... vamos la.... volto aki pra dizer se deu certo ou não...

    Uma pergunta! Eu vi que vc uso uma RB750 vc uso ela separada do seu servidor que controla os clientes ?????
    Última edição por lexone; 03-07-2011 às 16:40.



  17. #17

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    uso assim: 3links ---> rb750 load ----> switch que manda pra lanhouse e para o PC-AP com hotspot e 3 placas wireless ligadas em 3 paineis de 17dbi da TSM ---> 100clientes média de 30 simultameos.
    Última edição por peritinaicos; 03-07-2011 às 18:44.

  18. #18

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    me add no MSN tem mandei uma menssagem to com uma duvida e quem sabe da pra trocar umas idéas vlw...



  19. #19

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo


  20. #20

    Padrão Re: 2 Links ADSL sem PPOE fazendo Balance PCC ou Por tipo de arquivo

    vlw brother coloquei pra funcionar e tem uma semana que esta rodando redondo muito boa a configuração mesmo vlw;;;;