+ Responder ao Tópico



  1. #1

    Padrão Integrar thunder cache ao mikrotik

    Pessoal minha situação é a seguinte:
    Tenho um link Dedicado da Copel que chega em minha cidade por enlace de rádio, neste link tenho uma mascara /25 a qual me dá direito há alguns IPs válidos, o corre que estou tentando implementar na RB Mikrotik que gerencia este link um servidor Proxy, mas apesar de muito tentar não obtive nenhum resultado positivo, por este motivo venho recorrer aos colegas do fórum, e desde já quero agradecer a todos aqueles que vierem contribuir comigo.

    Obs. Tentei seguir um tutorial disponibilizado aqui no fórum pelo Leandro Cesar Souza do forum MkAuth, porém também não obtive resultado.

    Para uma melhor ilustração reproduzi um desenho de como estaria hoje minha rede.
    Clique na imagem para uma versão maior

Nome:	         Rede.jpg
Visualizações:	755
Tamanho: 	18,9 KB
ID:      	24056

    Hoje tenho uma RB 450G que me gerencia este link o qual tem entrada na porta Ether 1 conforme podem observar no desenho, e gostaria de ligar na Ether 2 o servidor Proxy Thunder, na porta Ether3 desejo deixá-la para saída de links dedicados que vendo para empresas e na porta Ether4 que deixá-la para ligar o meu servidor MyAuth3 que gerencia por Hostpost a conexão de meus clientes.
    O corre que como dito acima tenho alguns IPs válidos os quais são repassados para algumas empresas que atendo com link dedicado, e também passo alguns IPs para meu servidor de autenticação de clientes através de Nat 1:1, sendo assim os IPs válidos ficam na minha RB, nos clientes que tenho link dedicado os equipamentos deles trabalham como Router com DMZ habilitada assim através do IP válido que lhes é passado eles conseguem acessar sua rede interna.
    Agora a grande dúvida e problema que tenho é como eu crio a regra na RB que gerencia meu link para integrar ela ao Thunder Cache.

  2. #2
    wiidinternet
    Visitante

    Padrão Re: Integrar thunder cache ao mikrotik

    Cara, ja implementei esse esquema em um Provedor.
    Da para trabalhar de doi modos, ou fazendo um redirect no mk, ou em Bridge Totalmente transparente.. Tproxy.
    Qql coisa da um toque.

    Abc



  3. #3

    Padrão Re: Integrar thunder cache ao mikrotik

    Wiidi acredito que Bridge para mim não seria interessante haja vista que esta RB q faz todo o roteamento do meu link, gostaria de fazer que todas as requisições tantas vindas da ether 4 que são dos meus clientes, quanto da ether3 que são dos link dedicados passem pelo proxy que estão na ether2 e caso não tenha akele arquivo no proxy ai sim vá para a ether1 que é saida para o link.

    Como faço isso vc poderia me explicar.

  4. #4

    Padrão Re: Integrar thunder cache ao mikrotik

    Em paralelo 100% transparente com Tproxy funciona bem...



  5. #5

    Padrão Re: Integrar thunder cache ao mikrotik

    Configure uma porta da RB para trabalhar com o thunder, com ips falsos, não se preocupe, pode ser assim mesmo.
    Então poderá marcar os pacotes e criar uma rota com destino a porta 80.

    Algo assim:
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=80 new-routing-mark=route-cache passthrough=yes protocol=tcp src-address=SUAREDE

    e criar uma rota assim:
    /ip route
    add comment="Rota para o Cache" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.2 routing-mark=route-cache scope=30 target-scope=10

    Assumindo que colocou 192.168.0.2 no server


    Poderá ativar um Tproxy, ou simplesmente deixar assim mesmo.

    Ative cache full em seus Mikrotik com PPPoE


    Irá funcionar cache full e fica muito bom!

  6. #6

    Padrão Re: Integrar thunder cache ao mikrotik

    Farias este IP 192.168.0.2 seria o IP do Thunder, e o que seria este Tproxy e como assim ativar cache full no meu Mikrotik com ppoe



  7. #7

    Padrão Re: Integrar thunder cache ao mikrotik

    sim ip do thunder, tproxy é um proxy 100% transparente, caso seu cliente tente acessar sites que mostram ip por exemplo, não irá mostrar o ip do server e sim do cliente.

    PPPoE foi apenas um exemplo, pode ser com hotspot.

  8. #8

    Padrão Re: Integrar thunder cache ao mikrotik

    Farias mas eu nao passo para todos os clientes um IP fixo, haja vista que não tenho classe de ips para todos, entao o tproxy no meu caso nao seria interessante neh, agora akela configuracao para redirecionar todo que for acessado para o thunder acho que sim é muito interessante, essa regra que vc postou faz isso, redireciona tdo para o thunder e nao tendo nele depois para o link e consequentemente armazenado no thunder.



  9. #9

    Padrão Re: Integrar thunder cache ao mikrotik

    O tproxy, é realmente funcional caso tenha ip válido nas antenas de clientes.

    quanto ao redirecionamento, você também pode colocar o thunder na mesma rede das RBs e simplesmente redirecionar o tráfego de http para ele.

  10. #10

    Padrão Re: Integrar thunder cache ao mikrotik

    Certo já entendi isso, mas qual é a regra que faz esse redirecionamento, isso é o que não sei fazer e estou tentando aprender.



  11. #11

    Padrão Re: Integrar thunder cache ao mikrotik

    Pessoal venho novamente pedir socorro!

    Tentei fazer uns testes aqui com a regra que o Farias postou acima:

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=80 new-routing-mark=route-cache passthrough=yes protocol=tcp src-address=SUAREDE

    e criar uma rota assim:
    /ip route
    add comment="Rota para o Cache" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.2 routing-mark=route-cache scope=30 target-scope=10

    Assumindo que colocou 192.168.0.2 no server

    Mas tbém sem sucesso, resolvi refazer o desenho de minha rede, acho q agora ficou mais fácil em entender, considerando que o mikrotik já está configurado e navegando na Internet, espero poder contar com a ajuda do pessoal.
    Clique na imagem para uma versão maior

Nome:	         Rede.jpg
Visualizações:	160
Tamanho: 	12,1 KB
ID:      	24189
    O que preciso é fazer que meus clientes ao navegarem passem pelo cache para depois irem para o link caso o arquivo não esteja em cache e armazenando este arquivo no cache para futuras requisições.

    Desde já obrigado a todos que contribuir e em especial ao Farias que já tentou me ajudar.


  12. #12

    Padrão Re: Integrar thunder cache ao mikrotik

    Sem querer ser chato, mais o que mais tem aqui no forum é regra de redirecionamento para cache, a regra que o amigo Farias postou esta 100% correta, basta adaptar pra sua rede!!



  13. #13

    Padrão Re: Integrar thunder cache ao mikrotik

    Essa regra que o amigo colocou aqui tb não funcionou não.
    A regra de Nat é necessária estar ligada tb?

    Em Web proxy eu preciso fazer alguma coisa?