+ Responder ao Tópico



  1. #1

    Padrão Ajustar o Hora e Time Zone

    eu estava fazendo alguns teste de script para ajustar hora no MK e deparei com a seguinte:
    quando eu acerto a hora pelo ntp o horario atualizado mas o time zone não , ou vice-versa , então modifiquei o script para o time zone e também e para o NTP...
    tudo via terminal na primeira vez depois fica a cada 24 horas..
    segue o script , espero que sirva pra alguém.....

    ###Cria o Script e o Agendamento para acertar o time zone##
    /system script add name="Ajustar_Time_Zone" policy=test,write,policy,read source="/system clock set time-zone-name=America/Sao_Paulo"
    /system scheduler add name="Ajustar_Time_Zone" policy=test,write,policy,read on-event="Ajustar_Time_Zone" interval=1d delay=2
    ###
    delay 5
    ###Cria o Script e o Agendamento para acertar Hora##
    /system script add name="Ajustar_Hora" policy=test,write,policy,read source= "/system ntp client set enabled=yes mode=unicast primary-ntp=64.90.182.55 secondary-ntp=200.160.7.192"
    /system scheduler add name="Ajustar_Hora" policy=test,write,policy,read on-event="Ajustar_Hora" interval=1d delay=2
    #script criado e agendado com sucesso
    ###
    acho que com isso basta para resolver o horario de verão ja que ele atualiza o time zone também...
    quem não for de São Paulo mudar para o Estado correto ou que faça parte do fuso...
    no Brasil tem Bahia,Belem,Boa_Vista,Campo_Grande,Cuiba,Fortaleza,Maceio,Noronha,Recife,Rio_Branco e outros...

  2. #2

    Padrão re: Ajustar o Hora e Time Zone

    Olha, faço dessa forma abaixo em todos Mikrotik que vou configurar pela primeira vez, veja abaixo:

    /system ntp client
    set enabled=yes mode=unicast primary-ntp=200.160.0.8 secondary-ntp=200.192.232.8


    /system clock
    set time-zone-name=America/Sao_Paulo



  3. #3

    Padrão re: Ajustar o Hora e Time Zone

    Muito bom funciona legal mas esse ip de onde é?

  4. #4
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão re: Ajustar o Hora e Time Zone

    IP dos servidores de hora/data do registro.br

    Citação Postado originalmente por deson00 Ver Post
    Muito bom funciona legal mas esse ip de onde é?



  5. #5

    Padrão Re: Ajustar o Hora e Time Zone

    Citação Postado originalmente por sergio Ver Post
    IP dos servidores de hora/data do registro.br
    Ola Sergio tudo bem com vc, maia, edson, a quanto tempo hein, ( desde curso curitiba) Seguinte( primeiro quero pedir desculpas, pois talves o espaço nao seria este, mas vai lah)...

    To com um caso aqui que ta me dexixando de cabelo em pe, ja revirei o under, a net, ja falei com tecnicos de provedro e nada, sera que vc nao me da uma luz:

    O CASO:
    To com um hotspot rodando bem, liberando ip pros clientes na boa,tudo tranquilo, mas preciso limitar alguns horarios por grupos(user profiles)

    Exemplo:
    Quero liberar a net para o grupo01(userprofile01) das:
    09:00 as 10:00
    12:00 as 14:00
    15:00 as 22:00

    Quero liberar a net para o grupo02(userprofile2) das:
    12:00 as 13:00
    14:00 as 15:00
    18:00 as 20:00

    Quero liberar a net para o grupo03(userprofile3) das:
    08:00 as 18:00

    Agradeco desde ja qualquer auxilio...

    grato

  6. #6

    Padrão Re: Ajustar o Hora e Time Zone

    Citação Postado originalmente por farias Ver Post
    Olha, faço dessa forma abaixo em todos Mikrotik que vou configurar pela primeira vez, veja abaixo:

    /system ntp client
    set enabled=yes mode=unicast primary-ntp=200.160.0.8 secondary-ntp=200.192.232.8


    /system clock
    set time-zone-name=America/Sao_Paulo
    Uso essa forma para atualizar a hora dos routerOs. Mais estou com um problema, agora os equipamentos estão em uma rede invalida (10.100.xxx.xxx).
    Alguma dica ?


    Abraços



  7. #7

    Thumbs up Re: Ajustar o Hora e Time Zone

    Consegui resolver meu problema, se resume em você configurar uma RB para ser o NTP server da sua rede.
    Se liga:
    Deixando a hora certa em todos seus mikrotiks da rede.
    Primeiro vamos ao nosso servidor, nele vamos configurar p/ buscar a hora certa nos nossos servidores ntp.br. é tudo muito simples, vamos lá:


    /system ntp client set enabled=yes mode=unicast primary-ntp=200.160.0.8 secondary-ntp=200.189.40.8


    200.160.0.8 (a.ntp.br.)
    200.189.40.8 (b.ntp.br.)

    Seu horario irá sincronizar autmaticamente. Em:

    /system clock manual set dst-delta=+00:00 dst-end="jan/01/2020 00:00:00" dst-start="jan/01/1970 00:00:00" time-zone=-03:00


    Perfeito, agora temos nosso servidor com a hora certa.
    Proximo passo, configurar p/ que nossos mikrotiks da rede atualizem a hora pelo nosso servidor. Simples, ainda no nosso server vamos ativar o Ntp Server.


    /system ntp server set broadcast=no enabled=yes manycast=no multicast=yes


    Agora em todos Mk da nossa rede configuramos da seguinte maneira.

    /system ntp client set enabled=yes mode=unicast primary-ntp=10.0.0.1


    Onde 10.0.0.1 é o ip do seu servidor.
    Se no seu mikrotik não tem o menu ntp server, faça o download do recurso em www.mikrotik.com, e instale no seu equipamento.
    Feito isso, execute os passos acima.

    Fonte: Sóstenes L. Teixeira em http://mk-auth.com.br.

    Serviu para você? Qualifique essa dica.








  8. #8

    Padrão Re: Ajustar o Hora e Time Zone

    Fiz isso porém as RB's não atualizam a hora de acordo com o meu servidor pc mikrotik.
    Das RB's consigo pingar o servidor, mas não atualiza. Preciso liberar alguma porta? Fazer mais alguma configuração? Fico no aguardo!