+ Responder ao Tópico



  1. Trober, tem como adicionar algum parametro no comando que você me passou (do mikrotik) para trazer tambem o last-ip?


    Obrigado.

  2. Citação Postado originalmente por zoom18 Ver Post
    Trober, tem como adicionar algum parametro no comando que você me passou (do mikrotik) para trazer tambem o last-ip?


    Obrigado.
    Boa tarde.

    Tem sim

    Crie um script (System / Script) com o seguinte código:


    Código :
    :local varID 0
    :foreach varRegistration in=[/interface wireless registration-table find] do {
       :put ($varID . "|" . [/interface wireless registration-table get $varRegistration interface] . "|" . [/interface wireless registration-table get $varRegistration mac-address] . "|" . [/interface wireless registration-table get $varRegistration last-ip] . "|" . [/interface wireless registration-table get $varRegistration comment])
       :set varID ($varID + 1)
    }

    Supondo que o nome que você atribui ao script é GETREG, para executá-lo, rode o comando abaixo:

    Código :
    /system script run GETREG

    Está pronto! Agora é fazer o Python, via Paramiko, chamar esse script

    Saudações,

    Trober
    -
    -
    -
    -
    -



  3. Bom dia Trober!
    Consegui fazer o scrip e rodar via Python, chamando pelo Paramiko, so estou apanhando ainda na parte de salvar apenas os macs que não se repetirem a cada chamada!

  4. Citação Postado originalmente por zoom18 Ver Post
    Bom dia Trober!
    Consegui fazer o scrip e rodar via Python, chamando pelo Paramiko, so estou apanhando ainda na parte de salvar apenas os macs que não se repetirem a cada chamada!
    Bom dia! Que bom que funcionou

    Em Python, você pode remover as duplicidades, com base em alguns exemplos[1]. Se quiser, também pode fazer contagens de itens repetidos, removendo os duplicados n-1 (se tem 10, remove 9; se tem 2, remove 1, etc.).

    Se for usar shell script, pode usar o uniq. Se passar o parâmetro -d, mostrará somente os registros duplicados.

    Se não for problema para o colega, publica o código no próximo post, para que assim possamos analisar e contribuir com sugestões.

    [1] http://code.activestate.com/recipes/...om-a-sequence/

    Saudações,

    Trober
    -
    -
    -
    -
    -



  5. Bom, vamos lá!

    É isso ai que esta acontecendo:
    o nome do script no mikrotik é tla.

    Na parte de jogar na lista ocorre o erro.


    Código :
     root@SuporteOS:/home/jefferson/Área de Trabalho# pythonPython 2.6.6 (r266:84292, Dec 27 2010, 00:02:40) 
    [GCC 4.4.5] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>> import paramiko
    /usr/lib/python2.6/dist-packages/Crypto/Util/randpool.py:40: RandomPool_DeprecationWarning: This application uses RandomPool, which is BROKEN in older releases.  See http://www.pycrypto.org/randpool-broken
      RandomPool_DeprecationWarning)
    >>> ssh = paramiko.SSHClient()
    >>> ssh.set_missing_host_key_policy(paramiko.AutoAddPolicy())
    >>> ssh.connect('192.168.88.1', username='admin', password='tequila')
    >>> stdin, stdout, stderr = ssh.exec_command('/system script run tla')
    >>> List = []
    >>> for line in stdout:
    ... List.append(line.replace('\r',''))
      File "<stdin>", line 2
        List.append(line.replace('\r',''))
           ^
    IndentationError: expected an indented block
    >>>






Tópicos Similares

  1. access.log registrando 192.168.0.0 invés de 192.168.0.10 !!!
    Por ajust no fórum Servidores de Rede
    Respostas: 5
    Último Post: 05-05-2005, 20:53
  2. scripts para logs do Radius
    Por dboom no fórum Servidores de Rede
    Respostas: 1
    Último Post: 15-09-2002, 15:00
  3. logs
    Por shido no fórum Servidores de Rede
    Respostas: 0
    Último Post: 13-08-2002, 08:36
  4. msgs estranhas no log
    Por shido no fórum Servidores de Rede
    Respostas: 1
    Último Post: 31-07-2002, 13:26
  5. Configuração de Log´s
    Por Mark_Yangst_Suaizer no fórum Servidores de Rede
    Respostas: 2
    Último Post: 27-07-2002, 11:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L