+ Responder ao Tópico



  1. #1

    Padrão Alterar velocidade por horário.

    Bom pessoal, estou com dificuldades em implementar o controle banda por horário no hotspot.

    Tenho uma RB750g com Loadbalance e hotspot com 2 adsl de 2mb

    Tenho clientes cadastrados nos seguintes profiles:

    Residencial 200
    Rate limit= 100k/200k 128k/384k 48k/96k 30/30 8 16k/32k

    Residencial 256
    Rate limit= 128k/256k 256k/512k 96k/192k 30/30 7 32k/64k

    Residencial 600
    Rate limit= 200k/600k 256k/1024k 192k/384k 30/30 5 64k/128k

    O que pretendo fazer é aumentar a velocidade dos clientes cadastrados nos profiles residencial 200 e 256 para a mesma velocidade do profile residencial 600, a partir das 00:00 até as 07:00.
    Já tentei alguns scripts dos forums mas não deu certo.
    Tem alguma forma de migrar os clientes para o profile residencial 600 automaticamente a partir da meia noite e retornar-los para seus respectivos profiles a partir das 07:00?
    Caso seja possível como devo proceder?

    Desde já agradeço o apoio de todos.

  2. #2

    Padrão Re: Alterar velocidade por horário

    Boa noite.

    Veja se o script deste post[1] lhe é útil

    [1] https://under-linux.org/f226/control...37/#post241423

    Saudações,

    Trober
    -
    -
    -
    -
    -



  3. #3

    Padrão Re: Alterar velocidade por horário

    SCRIPTS DE LIBERAÇÃO DE BANDA (habilita e desabilita):

    / system script

    add name="libera_banda1" source="/ip hotspot user profile set 3 rate-limit="64k/128k" \
    policy=ftp,reboot,read,write,p olicy,test,winbox,pa ssword
    add name="libera_banda2" source="/ip hotspot user profile set 4 rate-limit="32k/64k" \
    policy=ftp,reboot,read,write,p olicy,test,winbox,pa ssword
    add name="desliga_banda1" source="/ip hotspot user profile set 3 rate-limit="48k/96k" \
    policy=ftp,reboot,read,write,p olicy,test,winbox,pa ssword
    add name="desliga_banda2" source="/ip hotspot user profile set 4 rate-limit="32k/64k" \
    policy=ftp,reboot,read,write,p olicy,test,winbox,pa ssword




    AGENDAMENTO:

    / system scheduler

    add name="enable" on-event=libera_banda1 start-date=jan/21/2006 \
    start-time=22:00:01 interval=1d comment="" disabled=no
    add name="disable" on-event=desliga_banda1 start-date=jan/21/2006 \
    start-time=08:00:01 interval=1d comment="HABILITA E DESABILITA A \
    BANDA1" disabled=no
    add name="enable" on-event=libera_banda2 start-date=jan/21/2006 \
    start-time=22:00:01 interval=1d comment="" disabled=no
    add name="disable" on-event=desliga_banda2 start-date=jan/21/2006 \
    start-time=08:00:01 interval=1d comment="HABILITA E DESABILITA A \
    BANDA2" disabled=no

    Obrigado amigo!

    pergunta: Terei que substituir estas rate-limit="64k/128k" pelas velocidades dos meus profiles?

  4. #4

    Padrão Re: Alterar velocidade por horário

    Citação Postado originalmente por Paturi Ver Post
    Obrigado amigo!

    pergunta: Terei que substituir estas rate-limit="64k/128k" pelas velocidades dos meus profiles?
    Isso

    No "libera_bandaX" (sendo X a identificação do cliente) será a banda noturna, e no "desliga_bandaX" (sendo X a identificação do cliente) você reativa a banda diurna.

    O que você também pode fazer é ter um arquivo, tipo XML, CSV ou simples TXT, com campos respectivos ao nome do cliente, banda baixa, banda alta, horário de ativação e desativação, e fazer com que, via Python[1] + Paramiko[1], as regras sejam dinamicamente criadas dentro do RouterOS.

    Via MikroTik API[2] também é possível.

    Dessa forma, você pode delegar a função de gerência de bandas, horários de concessão, entre outros, sem que, por exemplo, um funcionário tenha acesso ao RouterOS

    [1] https://under-linux.org/f143/registr...69/#post565246
    [2] http://wiki.mikrotik.com/wiki/Manual:API

    Saudações,

    Trober
    -
    -
    -
    -
    -
    Última edição por trober; 06-08-2011 às 23:26. Razão: Complementação



  5. #5

    Thumbs up Re: Alterar velocidade por horário

    Citação Postado originalmente por trober Ver Post
    Isso

    No "libera_bandaX" (sendo X a identificação do cliente) será a banda noturna, e no "desliga_bandaX" (sendo X a identificação do cliente) você reativa a banda diurna.

    O que você também pode fazer é ter um arquivo, tipo XML, CSV ou simples TXT, com campos respectivos ao nome do cliente, banda baixa, banda alta, horário de ativação e desativação, e fazer com que, via Python[1] + Paramiko[1], as regras sejam dinamicamente criadas dentro do RouterOS.

    Via MikroTik API[2] também é possível.

    Dessa forma, você pode delegar a função de gerência de bandas, horários de concessão, entre outros, sem que, por exemplo, um funcionário tenha acesso ao RouterOS

    [1] https://under-linux.org/f143/registr...69/#post565246
    [2] http://wiki.mikrotik.com/wiki/Manual:API

    Saudações,

    Trober
    -
    -
    -
    -
    -
    Ok amigo. Vou testar e posto o resultado.
    Muito abrigado!

  6. #6

    Padrão Re: Alterar velocidade por horário.

    Caro Trober.

    Tentei de várias formas e não funcionou.
    Agora estou com mais um problema. O load balance não equilibra carga.
    Se não for incomodo, da uma checada no forum
    https://under-linux.org/f143/load-ba...40/#post566460

    Grato!



  7. #7

    Padrão Re: Alterar velocidade por horário.

    Pessoal, alguem pode me ajudar. não consegui fazer com que o controle por horário funcionasse.
    Coloquei o scrip indicado por nosso amigo Trober mas não funcionou.

  8. #8

    Padrão Re: Alterar velocidade por horário.

    também estou com esse msm problema! to querendo fazer este controle.



  9. #9

    Padrão Re: Alterar velocidade por horário.

    Vamos participar pessoal. Alguem dispõe de um pequeno espaço em seu precioso tempo para compartilhar conhecimento?
    Grato!

  10. #10
    Avatar de Aredeprovedor
    Ingresso
    Jan 2009
    Localização
    Pôrto Das Caixas, Rio De Janeiro, Brazil, Brazil
    Posts
    79

    Padrão Re: Alterar velocidade por horário

    Citação Postado originalmente por trober Ver Post
    Boa noite.

    Veja se o script deste post[1] lhe é útil

    [1] https://under-linux.org/f226/control...37/#post241423

    Saudações,

    Trober
    -
    -
    -
    -
    -


    Eu uso esses scripts para minha rede, o único problema é que que os usuários tem que desconectar e conectar novamente para usufruir da velocidade aumentada, alguém sabe mudar isso automaticamente sem desconectar o cliente????



  11. #11

    Padrão Re: Alterar velocidade por horário.

    Cria duas regras para cada clientes em queue simple e em cada regra voc~e põe um horário diferente por exemplo:

    das 06:00 as 19:00 128/256
    das 19:01 as 05:59 256/500

    esses horários são definidos na própria queue, dessa forma não é preciso criar script para ativar e desativar as regras.

  12. #12
    Avatar de Aredeprovedor
    Ingresso
    Jan 2009
    Localização
    Pôrto Das Caixas, Rio De Janeiro, Brazil, Brazil
    Posts
    79

    Padrão Re: Alterar velocidade por horário.

    Citação Postado originalmente por marcelbentes Ver Post
    Cria duas regras para cada clientes em queue simple e em cada regra voc~e põe um horário diferente por exemplo:

    das 06:00 as 19:00 128/256
    das 19:01 as 05:59 256/500

    esses horários são definidos na própria queue, dessa forma não é preciso criar script para ativar e desativar as regras.

    Vou tentar fazer aqui pelo Queue entaum, vlw...



  13. #13
    Avatar de Aredeprovedor
    Ingresso
    Jan 2009
    Localização
    Pôrto Das Caixas, Rio De Janeiro, Brazil, Brazil
    Posts
    79

    Padrão Re: Alterar velocidade por horário.

    Citação Postado originalmente por marcelbentes Ver Post
    Cria duas regras para cada clientes em queue simple e em cada regra voc~e põe um horário diferente por exemplo:

    das 06:00 as 19:00 128/256
    das 19:01 as 05:59 256/500

    esses horários são definidos na própria queue, dessa forma não é preciso criar script para ativar e desativar as regras.

    Bom dia, estava analisando a Simple Queue e percebi terei que colocar todos planos ema uma faixa de ip para funcionar, hj eu uso DHCP, não fixo os cliente com seus ips. Estou correto???