Página 3 de 3 PrimeiroPrimeiro 123
+ Responder ao Tópico



  1. #41

    Padrão Re: Load Balance não equilibra carga.

    Opa muito obrigado por tudo, eu digo assim o calculo da distribuição do link. Explo foi dito que soma todos os links e divide pelo menor no meu caso ficaria assim entao 35+15+15+5=70/5 que é o menor da 14 entao teria que fazer 14 marcações, como na explicalçao do nosso amigo Sostenes. 1536k+600k=2136k divididos por 600k=3,56 =3 marcações, 2 para o link de 1,5 e 1 para link de 600k
    3/0 3/1 3/2. ou estou errado?

    Citação Postado originalmente por peritinaicos Ver Post
    Amigo a configuração é normal... Só que coloca uma distancia menos no dedicado lá em router... Dai o MK vai saber que é o link principal.

  2. #42

    Padrão Re: Load Balance não equilibra carga.

    Amigo tem como vc passar o bkp pra mim e qual equipamento vc usar qual rb?



  3. #43

    Padrão Re: Load Balance não equilibra carga.

    Olá, uma dica para quem quer usar loadbalance PCC com hotspot junto isso não dar certo pode esquecer, o correto é usar um equipamento pra cada coisa exemplo uma RB só pra loadbalance e uma RB só pra hotspot.

  4. #44

    Padrão Re: Load Balance não equilibra carga.

    Bom da certo sim rssrrs eu uso... Só que tem uns detalhes e umas regras que peguei aqui mesmo no fórum com o Sergio. Ficou MUITO bom



  5. #45

    Padrão Re: Load Balance não equilibra carga.

    bom dia Sostenes, como eu vou dividir uma carga de 50+15+15+5 dedicado?

    Citação Postado originalmente por sostenes Ver Post
    bom e complicado ,tem muitos tutoriais aqui no fórum a respeito.
    para quem quer dar uma olhada, esse lb fiz para um amigo meu.
    3 Links assimétricos 4MB/2MB/1MB
    IP:201.29.22.118
    Login:Teste
    Senha:teste

  6. #46

    Angry Re: Load Balance não equilibra carga.

    Pessoal, fiz o Load Balance em uma RB 450G, mas como aconteceu com muitas pessoas aqui, não houve equilíbrio de carga. Estou usando duas ADSL,s de 11 mega inicialmente com os modens em modo router, e agora em modo bridge. Segue o meu export para análise, se alguém se dispor. Informando também que resetei e excluí as configurações de fábrica da RB. Obrigado.

    /ip firewall mangle
    add action=accept chain=prerouting comment="ESTABELECIMENTO DE CONEX\D5ES ENTRE SI." disabled=no dst-address=192.168.88.0/30 src-address=192.168.88.0/30
    add action=accept chain=prerouting disabled=yes dst-address=10.0.10.0/30 src-address=192.168.88.0/30
    add action=accept chain=prerouting disabled=yes dst-address=10.0.20.0/30 src-address=192.168.88.0/30
    add action=mark-connection chain=prerouting comment="CONEX\D5ES EXTERNAS." connection-mark=no-mark disabled=no in-interface=pppoe-out1 new-connection-mark=ISP1_conn \
    passthrough=yes
    add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no in-interface=pppoe-out2 new-connection-mark=ISP2_conn passthrough=yes
    add action=jump chain=prerouting comment="ENCAMINHAMENTO PERSONALIZADO" connection-mark=no-mark disabled=no in-interface=Local jump-target=policy_router
    add action=mark-routing chain=prerouting comment="ROTAS PARA SA\CDDAS DAS CONEX\D5ES MARCADAS." connection-mark=ISP1_conn disabled=no new-routing-mark=ISP1_trafic \
    passthrough=yes src-address=192.168.88.0/30
    add action=mark-routing chain=prerouting connection-mark=ISP2_conn disabled=no new-routing-mark=ISP2_trafic passthrough=yes src-address=192.168.88.0/30
    add action=mark-routing chain=output comment="MARCA\C7\D5ES DOS ROTEAMENTOS" connection-mark=ISP1_conn disabled=no new-routing-mark=ISP1_trafic passthrough=yes
    add action=mark-routing chain=output connection-mark=ISP2_conn disabled=no new-routing-mark=ISP2_trafic passthrough=yes
    add action=mark-connection chain=policy_router comment="DIVIS\C3O DE LINK" disabled=no dst-address-type=!local new-connection-mark=ISP1_conn passthrough=yes \
    per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=policy_router disabled=no dst-address-type=!local new-connection-mark=ISP2_conn passthrough=yes per-connection-classifier=\
    both-addresses:2/1



  7. #47

    Padrão Re: Load Balance não equilibra carga.

    Olá, amigo o problema está nas suas regras teste com essas aqui refaça tudo desde o começo que vai funcionar normalmente

    # ip firewall mangle------------------------


    /ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=ether1
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=ether1
    /ip firewall mangle add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" disabled=no new-ttl=set:30 protocol=icmp
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_ether5 new-connection-mark=adsl_ether5_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_ether4 new-connection-mark=adsl_ether4_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_ether5_conn disabled=no new-routing-mark=to_adsl_ether5 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_ether4_conn disabled=no new-routing-mark=to_adsl_ether4 passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether1 new-connection-mark=adsl_ether5_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether1 new-connection-mark=adsl_ether4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_ether5_conn disabled=no in-interface=ether1 new-routing-mark=to_adsl_ether5 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_ether4_conn disabled=no in-interface=ether1 new-routing-mark=to_adsl_ether4 passthrough=yes
    Última edição por freitascs; 26-03-2013 às 14:33.

  8. #48

    Cool Re: Load Balance não equilibra carga.

    Freitascs, estou voltando para lhe agradecer. Funcionou corretamente, obrigado.
    Assim ficou o meu mangle com as configurações recomendadas:

    /ip firewall mangle
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-list=LINK1 in-interface=ether5 new-connection-mark=Sites1 \
    passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=Sites1 disabled=no \
    in-interface=ether5 new-routing-mark=Rota1 passthrough=no
    add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" \
    disabled=no dst-port=443 in-interface=ether5 protocol=tcp
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no \
    dst-address-list=loopback in-interface=ether5
    add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" \
    disabled=no new-ttl=set:30 protocol=icmp
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    in-interface=adsl_ether2 new-connection-mark=adsl_ether2_conn passthrough=\
    yes
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    in-interface=adsl_ether1 new-connection-mark=adsl_ether1_conn passthrough=\
    yes
    add action=mark-routing chain=output connection-mark=adsl_ether2_conn disabled=\
    no new-routing-mark=to_adsl_ether2 passthrough=yes
    add action=mark-routing chain=output connection-mark=adsl_ether1_conn disabled=\
    no new-routing-mark=to_adsl_ether1 passthrough=yes
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    adsl_ether2_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/0
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    adsl_ether1_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/1
    add action=mark-routing chain=prerouting connection-mark=adsl_ether2_conn \
    disabled=no in-interface=ether5 new-routing-mark=to_adsl_ether2 \
    passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=adsl_ether1_conn \
    disabled=no in-interface=ether5 new-routing-mark=to_adsl_ether1 \
    passthrough=yes


    Muito obrigado, valeu!



  9. #49

    Padrão Re: Load Balance não equilibra carga.

    De nada amigo fico feliz que tenha conseguido resolver seu problema, até mais.

  10. #50

    Padrão Re: Load Balance não equilibra carga.

    Citação Postado originalmente por freitascs Ver Post
    Olá, amigo o problema está nas suas regras teste com essas aqui refaça tudo desde o começo que vai funcionar normalmente

    # ip firewall mangle------------------------


    /ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=ether1
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=ether1
    /ip firewall mangle add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" disabled=no new-ttl=set:30 protocol=icmp
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_ether5 new-connection-mark=adsl_ether5_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_ether4 new-connection-mark=adsl_ether4_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_ether5_conn disabled=no new-routing-mark=to_adsl_ether5 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_ether4_conn disabled=no new-routing-mark=to_adsl_ether4 passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether1 new-connection-mark=adsl_ether5_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether1 new-connection-mark=adsl_ether4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_ether5_conn disabled=no in-interface=ether1 new-routing-mark=to_adsl_ether5 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_ether4_conn disabled=no in-interface=ether1 new-routing-mark=to_adsl_ether4 passthrough=yes

    Ola freitascs!

    Voce pode me explicar a função destas interfaces citadas na regra acima? por exemplo, a ether1, ela é saida pros clientes, placa que conecta o modem 1, ou o discador pppoe1?

    Meu balance aqui não suga o link que tem disponivel, se comparado com testes feitos direto na saida de cada moden individual! Ele extrai apenas 20% da banda!

    desde ja obrigado!

    bhyll



  11. #51

    Padrão Re: Load Balance não equilibra carga.

    Isso mesmo amigo a ether1 é a porta de saída para o servidor mikrotik ou para os clientes e a ether2, ether3, ether4, ether5 são a portas de entrada de links que conecta os modens que ai é criado os discadores PPPoE.
    Última edição por freitascs; 27-03-2013 às 21:34.