+ Responder ao Tópico



  1. Citação Postado originalmente por minelli Ver Post
    hehehehehehe, adoro isso ninguém capaz de ler um manual e dizer algo diferente incrível.....
    Aqui mesmo no forum já foi postado material que daria conceito suficiente para qualquer um fazer isso. O que ocorre é que o povo não lê e quando lê não entende por falta de conhecimento (conceito técnico) e sabem porque, porque a maioria só sabe pedir, ver copiar e colar e a minoria e capaz de fazer algo em geral os mais antigos no forum.
    Porque a moçada nova não se salva nem 5%, mas apesar do meu desabafo aos crtl+c e ctrl+v vamos ao que interessa na minha próximo aqui.
    Esse é o mal do ser humano, se achar superior, provavelmente você é o sabidão e "O CARA" de redes, por que, tomara Deus que quando você tiver alguma dificuldade, UM ZÉ MANÉ lhe dê uma dica BOA como esta.

    Passar bem.

  2. Citação Postado originalmente por rodrigoMK Ver Post
    Esse é o mal do ser humano, se achar superior, provavelmente você é o sabidão e "O CARA" de redes, por que, tomara Deus que quando você tiver alguma dificuldade, UM ZÉ MANÉ lhe dê uma dica BOA como esta.

    Passar bem.
    Não, não me acho superior, não sou o sabidão, não sou "O CARA" não sou melhor do que ninguém aqui no forum.
    Aprenda a ser educado e já começará melhorando muito.
    Se tivesse prestado atenção no que escrevi viria que:
    "vamos ao que interessa na minha próximo aqui..."
    Sendo assim se pelo menos interpreta-se o texto entenderia que estou fazendo algo que não costumo fazer que é arrumando um ctrl+c e ctrl_v para ajudar a quem ler esse poste, já que a maioria tem preguiça de ler ou até traduzir o manual ou documentação disponível no wiki da mikrotik.



  3. Pessoal tento aqui resumir em regras o que o titulo do tópico diz.
    Claro que terão de adaptar as regras a rede na qual forem utilizar, de acordo com cada rede as regras podem sofrer e muito alterações para seu funcionamento correto.

    Segue explicações básicas:
    Clientes = Aqui deve conter a classe de IP dos clientes que deverão passar pelo proxy.
    Sem_Proxy = Aqui deve conter os IPs ou classes de IPs que não terá o cache feito geralmente usado para sites governamentais.
    Código :
    /ip firewall address-list
    add address=10.10.10.0/24 comment="" disabled=no list=Clientes
    add address=200.157.0.0/16 comment=ReceitaNet disabled=no list=Sem_Proxy

    Marcação das conexões vindas do Proxy.
    Marcação dos pacotes vindos do Proxy.
    Código :
    /ip firewall mangle
    add action=mark-connection chain=postrouting comment="InstallAPP_Cache" content="X-Cache: HIT from InstallAPP" disabled=no new-connection-mark=LinuxInstallAPP_Cache-Conn-HIT passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting comment="" connection-mark=LinuxInstallAPP_Cache-Conn-HIT disabled=no new-packet-mark=LinuxInstallAPP_Cache-Packet-HIT passthrough=yes

    Nat para o IP do Proxy
    Redirecionamento para clientes IP+Mac e PPPoe.
    Redirecionamento para clientes HotSpot.
    Código :
    /ip firewall nat
    add action=masquerade chain=srcnat comment="NAT InstallAPP_Cache" disabled=no src-address=192.168.10.0/24
    add action=dst-nat chain=dstnat comment="Redirect - InstallAPP_Cache" disabled=yes dst-address=!192.168.10.2 dst-address-list=!Sem_Proxy dst-port=80 protocol=tcp src-address-list=Clientes to-addresses=192.168.10.2 to-ports=5128
    add action=dst-nat chain=pre-hotspot comment="Redirect HotSpot - InstallAPP_Cache" disabled=yes dst-address=!192.168.10.2 dst-address-list=!Sem_Proxy dst-port=80 hotspot=auth protocol=tcp src-address-list=Clientes to-addresses=192.168.10.2 to-ports=5128

    Aceitar trafego do Proxy
    Bloquear acesso externo ao Proxy
    Código :
    /ip firewall filter
    add action=accept chain=forward comment="Aceita InstallAPP_Cache" disabled=no src-address=192.168.10.0/24
    add action=accept chain=forward comment="" disabled=no dst-address=192.168.10.0/24
    add action=drop chain=input comment="Bloqueio InstallAPP_Cache" disabled=no dst-port=3128 in-interface="Router" protocol=tcp
    add action=drop chain=input comment="" disabled=no dst-port=8080 in-interface="Router" protocol=tcp

    Queue Type responsável pelo titulo do tópico. (Deve-se tomar cuidado com este tipo de Queue Type - Para cada rede deve-se aplicar de uma forma)
    Código :
    /queue type
    add kind=pcq name=InstallAPP_Cache pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000

    Controle da Banda do que foi marcado vindo do Proxy.
    Código :
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=10240 name="2 - InstallAPP_Cache_Full" packet-mark=LinuxInstallAPP_Cache-Packet-HIT parent=global-out priority=2 queue=InstallAPP_Cache

    Observem que esta Queue Tree tem sua "queue" selecionada para a Queue Type adicionado anteriormente "InstallAPP_Cache" e não para a "queue" padrão "default".
    Na Queue Type anterior vocês devem ter reparado que foi setado pcq-total-limit=2000, logo tudo que vier do Proxy terá seu máximo de trafego na rede de 10MiB, como configurado na Queue Tree e cada cliente 2MiB como configurado no Queue type.
    Recomendo o estudo do manual do Mikrotik e também de documentação sobre PCQ no Mikrotik, pois só a aplicação das regras não serão suficiente para o perfeito funcionamento.

    Link´s para consulta:
    http://wiki.mikrotik.com
    http://wiki.mikrotik.com/wiki/Manual:Queues_-_PCQ
    https://under-linux.org/blogs/m4d3/p...-por-m4d3-852/

    Caro leitor se foi útil, então agradeça.
    Última edição por minelli; 10-08-2011 às 16:17. Razão: Composição e correção do post, correção da regra queue type..

  4. Obrigado pelas dicas, irei fazer os testes com calma e retorno os resultados.

    Abraço



  5. Citação Postado originalmente por minelli Ver Post
    Pessoal tento aqui resumir em regras o que o titulo do tópico diz.<br>
    Claro que terão de adaptar as regras a rede na qual forem utilizar, de acordo com cada rede as regras podem sofrer e muito alterações para seu funcionamento correto.<br>
    <br>
    <font color="#0000ff"> Segue explicações básicas:</font><br>
    .....
    Boa tarde a todos, caro Minelli e companheiros, pergunto: seria possivel criar uma queue tree (setando a respectiva interface em parent)para cada interface de entrada? por ex. wlan1 (2,4ghz) total cache 2MB, eth1 (5,8ghz) total cache 10MB, etc, para não estourar a capacidade de cada interface nem sacrificar o cache full em detrimento das 2,4ghz???
    Última edição por egservice; 10-08-2011 às 15:50. Razão: formatação..






Tópicos Similares

  1. Respostas: 2
    Último Post: 14-04-2014, 16:52
  2. cache full com hotspot
    Por pedrovigia no fórum Redes
    Respostas: 4
    Último Post: 07-11-2008, 19:56
  3. (Cache Full) com (Hotspot + RADIUS)
    Por e-eduardo no fórum Redes
    Respostas: 13
    Último Post: 05-04-2008, 10:07
  4. Respostas: 7
    Último Post: 30-06-2007, 12:20
  5. Respostas: 2
    Último Post: 14-01-2007, 11:48

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L