+ Responder ao Tópico



  1. #1

    Padrão Ignorar IP em regra de NAT

    Boa tarde, pessoal.

    Tenho uma regra de NAT no firewall do meu mikrotik que redireciona o trafego das portas 80 e 443 para o Squid. Funcionar perfeitamente. É a última regra na lista.

    Clique na imagem para uma versão maior

Nome:	         1.png
Visualizações:	81
Tamanho: 	18,8 KB
ID:      	26414Clique na imagem para uma versão maior

Nome:	         2.png
Visualizações:	62
Tamanho: 	14,7 KB
ID:      	26415

    Agora quero liberar um computador desta regra, quero que ele navegue direto sem redirecionar, mas o campo Src.Adress já está preenchido com o IP do squid para não entrar em loop.

    Como eu faço para liberar este outro IP (Ex.10.0.0.21) desta regra de NAT??

    Já tentei colocar uma acima com o action Acept, mas não adiantou.

    Grato,
    Ezequiel

  2. #2

    Padrão Re: Ignorar IP em regra de NAT

    faça identico ao que você fez com as portas: dois IPs na mesma regra.



  3. #3

    Padrão Re: Ignorar IP em regra de NAT

    Citação Postado originalmente por arauadbr Ver Post
    faça identico ao que você fez com as portas: dois IPs na mesma regra.
    arauadbr,

    Bom dia. Obrigado pela resposta.

    Idêntico não funciona, pois já tinha tentando colocando dois IPs separados por vírgula e separados por espaço e não funcionou. Mas depois de sua resposta que era possível, eu insisti e consegui colocando com hífem.

    Ficou assim: 10.0.0.5-10.0.0.21

    A dúvida é, ele pegou todo esse intervalo ou somente os dois IPs??

    Grato,
    Ezequiel

  4. #4
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: Ignorar IP em regra de NAT

    Usa a address-list e seja feliz


    Abraços



  5. #5

    Padrão Re: Ignorar IP em regra de NAT

    Citação Postado originalmente por edcomrocha Ver Post
    Usa a address-list e seja feliz


    Abraços
    edcomrocha,

    Nunca tinha utilizado o address-list mas funcionou perfeitamente.

    Muito obrigado.

  6. #6

    Padrão Re: Ignorar IP em regra de NAT

    Estou com um problema idêntico quando ativo as regras para redirecionar para o meu cache um cliente não acessa algumas paginas de serviços quando desativo funciona td normal. Queria uma forma de deixar esse cliente fora do meu cache como faço?



  7. #7

    Padrão Re: Ignorar IP em regra de NAT

          Estou com um problema idêntico quando ativo as regras para redirecionar para o meu cache um cliente não acessa algumas paginas de serviços quando desativo funciona td normal. Queria uma forma de deixar esse cliente fora do meu cache como faço?

  8. #8

    Padrão Re: Ignorar IP em regra de NAT

    Citação Postado originalmente por marcoscx Ver Post
    Estou com um problema idêntico quando ativo as regras para redirecionar para o meu cache um cliente não acessa algumas paginas de serviços quando desativo funciona td normal. Queria uma forma de deixar esse cliente fora do meu cache como faço?
    marcoscx,
    Vai no Firewall / Address List, inclua uma linha com o IP deste cliente e coloque um nome, por exemplo "semproxy".

    Na sua regra de Nat, no campo Src.Address List você seleciona estre grupo "semproxy" e marca a opção de negação "!".

    Assim sua regra de redirecionamento vai ignorar todos os IP deste grupo.



  9. #9

    Padrão Re: Ignorar IP em regra de NAT

    vou testar e posto o resultado

  10. #10

    Padrão Re: Ignorar IP em regra de NAT

    Essas são as regras de redirecionamento para o proxy, gostaria que o ip 10.12.0.33 ficasse fora desde redirecionamento.
    Testei colocar o IP 10.12.0.33 no anddress lists e coloquei no src-address-list mais tb não deu certo.

    Coloquei o endereço dos site que esse ip precissa acessar no anddress lists mais tb não deu certo

    Não sei se precisa de um script para atualizar as anddress lists ou algo parecido.
    Esse cliente pega ip automatico mais sempre é esse mesmo ip marcado do dhcp-serv



    /ip firewall nat
    add action=dst-nat chain=pre-hotspot comment="Redirect Agility Cache" \
    disabled=yes dst-address=!160.31.0.2 dst-port=80 hotspot=auth protocol=\
    tcp src-address=10.12.0.0/24 src-address-list=!sem_cache_dst \
    to-addresses=160.31.0.2 to-ports=10001
    add action=dst-nat chain=dstnat comment="Redirect Agilitycache" disabled=yes \
    dst-address=!160.31.0.2 dst-port=80 protocol=tcp src-address=10.12.0.0/24 \
    src-address-list=!sem_cache_dst to-addresses=160.31.0.2 to-ports=10001