+ Responder ao Tópico



  1. #1

    Question Problema com o apt

    Bom dia, apos realizar um apt-get update, estou tendo o seguinte problema:

    Use of uninitialized value $text in concatenation (.) or string at /usr/share/perl5/Text/WrapI18N.pm line 101, <GEN1> line 5.
    substr outside of string at /usr/share/perl5/Text/WrapI18N.pm line 130, <GEN1> line 5.


    Essa linha fica se repetindo infinitamente, e não consigo instalar mais nada. Tentei usar um dpkg --configure -a e o erro se repete.


    subprocess script post-installation instalado was interrupted
    dpkg: problemas de dependência impedem a configuração de libmagickcore4:
    libmagickcore4 depende de libc6 (>= 2.3.6-6~); porém:
    Pacote libc6 não está configurado ainda.




    Se alguem puder me ajudar!

  2. #2

    Padrão Re: Problema com o apt

    Poste o conteúdo do sources.list para dar uma idéia.



  3. #3

    Padrão Re: Problema com o apt

    o conteudo:



    deb ftp://ftp.br.debian.org/debian/ stable main contrib non-free
    deb ftp://mirrors.kernel.org/debian/ stable main contrib non-free
    deb Index of /debian lenny main contrib
    deb Index of /debian lenny main contrib non-free
    deb Index of /debian lenny-proposed-updates contrib main
    deb Index of /debian-multimedia lenny main
    deb Index of /debian-multimedia lenny main
    deb Index of /debian oldstable main
    deb Index of /debian stable main
    deb Index of /debian stable main contrib non-free
    deb Index of / stable all
    deb Debian -- Security Information lenny/updates main contrib
    deb Debian -- Security Information lenny/updates main contrib non-free
    deb Debian -- Security Information stable/updates main contrib non-free
    deb Index of /debian-volatile lenny/volatile main
    deb http://www.backports.org/debian lenny-backports main contrib non-free
    deb Debian Multimedia Packages::Home stable main
    deb-src ftp://ftp.br.debian.org/debian/ stable main contrib non-free
    deb-src ftp://mirrors.kernel.org/debian/ stable main contrib non-free
    deb-src Index of /debian lenny main contrib
    deb-src Index of /debian lenny main contrib non-free
    deb-src Index of /debian lenny-proposed-updates contrib main
    deb-src Index of /debian oldstable main
    deb-src Index of /debian stable main
    deb-src Index of /debian stable main contrib non-free
    deb-src Index of / stable all
    deb-src Debian -- Security Information lenny/updates main contrib
    deb-src Debian -- Security Information lenny/updates main contrib non-free
    deb-src Debian -- Security Information stable/updates main contrib non-free
    deb-src Index of /debian-volatile lenny/volatile main
    deb-src http://www.backports.org/debian lenny-backports main contrib non-free
    deb-src Debian Multimedia Packages::Home stable main

  4. #4

    Padrão Re: Problema com o apt

    Inicialmente não percebi nada de errado nos índices do sources.list, porém a indicação de outras versões podem gerar problema com versão de aplicativos e isso pode ser o que está acontecendo contigo.

    Você usa o Lenny??

    Observer que quando você refere "oldstable" e "lenny" nas linhas do source list você está apontando para os pacotes do LENNY, mas quando você aponta para "stable" você indica os pacotes do SQUEEZE. Evite manter essas referências de versões diferentes sempre ativadas.

    Comente as linhas e tente o procedimento de update novamente.



  5. #5

    Padrão Re: Problema com o apt

    Uso o lenny amigo! Então, comentei aqui, porém continuou com o mesmo problema

  6. #6

    Padrão Re: Problema com o apt

    Tente executar o seguinte comando para limpar as indicações para instalação:

    # apt-get -f install



  7. #7

    Padrão Re: Problema com o apt

    Tentei amigo, tanto o apt-get -f install, como o apt-get -f remove, ambos dao o mesmo problema!

  8. #8

    Padrão Re: Problema com o apt

    Digo, o comando é esse, sem nenhuma outra opção.

    # apt-get -f install


    esse comando executa um flush no status dos arquivos à serem instalados.
    Última edição por edsonrsjr; 17-08-2011 às 15:39.



  9. #9

    Padrão Re: Problema com o apt

    Então amigo, usei o comando ,mas continua dando primeiro erro mencionado!

  10. #10

    Padrão Re: Problema com o apt

    Amigo,

    Faça o seguinte:

    Na linha 130 de /usr/share/perl5/Text/WrapI18N.pm existe isto:

    $r = substr($string, $l);
    Comente e adicione isto no mesmo lugar.

    if (length($text) < $l) { $r = ''; } else { $r = substr($string, $l); }
    Abs.;



  11. #11

    Wink Re: Problema com o apt

    Obrigado amigo, funcionou graças a sua dica!

    Obrigado!

  12. #12

    Padrão Re: Problema com o apt

    Opa!!

    Estamos aqui pra isso!!