+ Responder ao Tópico



  1. #1

    Padrão Todos os Clientes aparecem com o mesmo Mac no MK

    Ola pessoal tudo bem!!!!!
    sou novato nao forum, primeira vez que estou postando aqui, mais ja venho lendo sobre mikrotik a muito tempo....
    bom meu problema é o seguinte... montei um MK com load balance tem varios ajustes pare ser feito, mais o meu maior problema que tenho é que todos as meus clientes aparecem com o mesmo mac no MK sendo assim os demais nao conectam, nao sei o que devo fazer neste casso.

    desde ja agradeço pela ajuda.

  2. #2

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    isso geralmente acontece quando seu enlace que chega os clientes nao esta feito em WDS, ae todos seus clientes chegam pra vc com o MAC do radio cliente que fecha o enlace... oq vc usa pra fechar o enlace? caso seja esse seu caso...



  3. #3

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    depois de postar minha duvida, etive lendo posts falando sobre o asunto.
    cheguei a conclusao que o problema esta na repetidora. entao a soluçao seria colocar ela em WDS, entao surgiu mais uma duvida, como fica a situaçao do cliente que tiver mais de um pc ligado no seu ap?
    estive pensando se nao seria possivel fazer com que o MK ignore o MAC e fasa controle apenas pelo IP nao sei se isso seria possivel.... para mim seria a soluçao mais pratica

  4. #4

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    vc configura o AP do cliente no modo Wireless ISP, Wireless ISP Lans Bridge, Cliente ISP, tem varios nomes que variam de equipamento para equipamento, nesse modo a porta WAN do AP do cliente fica sendo a wireless, que compartilha a internet para todas maquinas que estiverem ligadas na portas Lan, entao vc cadastra soh um IP e MAC apenas, caso use MAC+IP podendo assim configurar qualquer classe diferente para a rede interna do cliente



  5. #5

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    fico muito grato com a ajuda.... surgiram mais duvidas, em alguns clientes tenho bullet2, os quais tem mais de um pc... sera que o bullet causa o mesmo problema com o mac?

  6. #6

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    no bullet vc vai configura-lo como router e nao bridge, o IP+MAC a liberar no servidor vai ser o da WAN do bullet, ae o ip da rede interna do cliente vc coloca do jeito que precisar... o equipamento tera dois IPs, o da WAN que va conectar como servidor e o da Lan que vai atender aos clientes da rede interna... isso tudo se vc estiver usando MAC+IP



  7. #7

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    eu configurando o ap em cliente WDS posso usar a lan com ip 10.1.1.1 e o gateway padrao da wan 10.1.1.1 tambem?
    para que o gateway de entrada seje o mesmo da saida.

  8. #8

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    quando vc passa o bullet pra Router, ele abre duas config de IPs, uma para a WAN que ira receber a internet do servidor, e outra para Lan que ira repassar para as maquinas atras dele... entao vc pode ter WAN 10.1.1.1 Mask 255.0.0.0 Gateway (ip do servidor) DNS (XXX.XXX.XXX.XXX); Lan 192.168.1.20 Mask 255.255.255.0



  9. #9

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    sua ajuda esta sendo muito util..... obrigado

    estou com problema no load balance que nao esta funcionando coretamente as regras que usei sao essas

    regras
    ****************************** ****************************** *******
    /ip route
    add check-gateway=arp comment="WAN 2 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=wan2
    add check-gateway=arp comment="WAN 1 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=wan1
    add check-gateway=arp comment="WAN 1 - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=wan1
    add check-gateway=arp comment="Default Route - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe
    add check-gateway=arp comment="Default Route - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe
    add check-gateway=arp comment="Rota estática - WAN1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=static-wan1
    add check-gateway=arp comment="Rota estática - WAN2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=static-wan2
    ############################## #############################
    /ip firewall address-list
    add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    add address=208.69.32.0/24 comment="" disabled=no list=loopback
    add address=208.67.217.0/24 comment="" disabled=no list=loopback
    add address=201.7.178.0/24 comment="" disabled=no list=loopback
    add address=201.7.176.0/24 comment="" disabled=no list=loopback
    add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    add address=201.7.176.0/20 comment="Vdeos - Globo" disabled=no list=loopback
    add address=208.84.247.0/24 comment="Vdeos - terratv" disabled=no list=loopback
    add address=200.154.56.0/24 comment="Vdeos - terratv" disabled=no list=loopback
    add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    add address=200.201.166.0/24 comment="" disabled=no list=loopback
    add address=200.201.173.0/24 comment="" disabled=no list=loopback
    add address=200.201.174.0/24 comment="" disabled=no list=loopback
    add address=200.141.207.3 comment=Detran disabled=no list=loopback
    add address=85.17.216.46 comment=www.easy-share.com disabled=no list=loopback
    add address=200.222.8.9 comment=Detran disabled=no list=loopback
    ############################## #############################
    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOAD BALACED" disabled=no dst-address-list=loopback in-interface=lan
    add action=mark-connection chain=input comment="Marca nova conexão de entrada wan1" connection-state=new disabled=no in-interface=wan1-pppoe new-connection-mark=wan1 \
    passthrough=yes
    add action=mark-connection chain=input comment="Marca nova conexão de entrada wan2" connection-state=new disabled=no in-interface=wan2-pppoe new-connection-mark=wan2 \
    passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada estabelecidas wan1" connection-state=established disabled=no in-interface=wan1-pppoe \
    new-connection-mark=wan1 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada estabelecidas wan2" connection-state=established disabled=no in-interface=wan2-pppoe \
    new-connection-mark=wan2 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada relacionadas wan1" connection-state=related disabled=no in-interface=wan1-pppoe \
    new-connection-mark=wan1 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada relacionadas wan2" connection-state=related disabled=no in-interface=wan2-pppoe \
    new-connection-mark=wan2 passthrough=yes
    add action=mark-routing chain=output comment="Marca nova rota de entrada wan1" connection-mark=wan1 disabled=no new-routing-mark=static-wan1 passthrough=no
    add action=mark-routing chain=output comment="Marca nova rota de entrada wan2" connection-mark=wan2 disabled=no new-routing-mark=static-wan2 passthrough=no
    add action=mark-connection chain=prerouting comment="Marca tráfego que não é local com rand marca PCC (2 possibilidades) - opção 1" connection-state=new disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="Marca tráfego que não é local com rand marca PCC (2 possibilidades) - opção 2" connection-state=new disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-connection chain=prerouting comment="Marca tráfego estabelecido que não é local com rand marca PCC (2 possibilidades) - opção 1" connection-state=\
    established disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=\
    both-addresses:2/0
    add action=mark-connection chain=prerouting comment="Marca tráfego estabelecido que não é local com rand marca PCC (2 possibilidades) - opção 2" connection-state=\
    established disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=\
    both-addresses:2/1
    add action=mark-connection chain=prerouting comment="Marca tráfego relacionado que não é local com rand marca PCC (2 possibilidades) - opção 1" connection-state=related \
    disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="Marca tráfego relacionado que não é local com rand marca PCC (2 possibilidades) - opção 2" connection-state=related \
    disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="Marca encaminhamento para marcar PCC - opção 1" connection-mark=wan1_pcc_conn disabled=no new-routing-mark=wan1 passthrough=\
    yes
    add action=mark-routing chain=prerouting comment="Marca encaminhamento para marcar PCC - opção 2" connection-mark=wan2_pcc_conn disabled=no new-routing-mark=wan2 passthrough=\
    yes
    ****************************** ****************************** *******

  10. #10

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    de balance manjo pouco, fiz umas duas vezes e funcionou de primeira, caso queira eu posto minhas regras pra vc usar...



  11. #11

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    eu ficaria muito grato se poder me envir

  12. #12

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    fiz em uma RB450G entao vc mude as opções de ether5 para a interface que ira se comunicar com seus clientes... lembrando que essa eh a config para dois links simetricos

    Mangle
    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=foradobalance in-interface=ether5
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=pppoe-out1 new-connection-mark=wan1_conn passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=pppoe-out2 new-connection-mark=wan2_conn passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wan1_conn connection-state=new disabled=no new-routing-mark=to_wan1 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=wan2_conn connection-state=new disabled=no new-routing-mark=to_wan2 passthrough=no
    add action=accept chain=prerouting comment="" disabled=no dst-address=192.168.1.1/24 in-interface=ether5
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=ether5 new-connection-mark=wan1_conn passthrough=no / per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=ether5 new-connection-mark=wan2_conn passthrough=yes / per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="" connection-mark=wan1_conn disabled=no in-interface=ether5 new-routing-mark=to_wan1 passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=wan2_conn disabled=no in-interface=ether5 new-routing-mark=to_wan2 passthrough=no

    NAT
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-out1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-out2

    Routes
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ether5
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_wan1
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out2
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_wan2
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1



  13. #13

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    uma duvida vc usa hotspot com load balance?

  14. #14

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    uso uma RB450G soh para o balance, e um servidor com MK em pppoe para os clientes...



  15. #15

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    ok minha ideia seria usar um servidor mk para fazer o load e hotspot juntos, mais pelo que andei lendo nao seria possivel...

  16. #16

    Padrão Re: todos os clientes aparecem com o mesmo mac no MK

    eh vero, eh recomendado fazer separado mesmo...